Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условное форматирование на повтор по содержанию другой ячейк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование на повтор по содержанию другой ячейк (Формулы/Formulas)
Условное форматирование на повтор по содержанию другой ячейк
ovechkin1973 Дата: Суббота, 13.05.2017, 18:31 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
не соображу как сделать условное форматирования столбца для заливки ячейки цветом, если в есть повтор в этом столбце. Но это надо делать по условию в другом столбце - т.е. допустим есть в столбце Иванов три раза, но выделять надо цветом только две ячейки, потому как в этих строках в столбце А стоит "К". Ну и если ячейка пустая, то выделять ее цветом тоже не надо
К сообщению приложен файл: ____.xls(26Kb)
 
Ответить
Сообщениене соображу как сделать условное форматирования столбца для заливки ячейки цветом, если в есть повтор в этом столбце. Но это надо делать по условию в другом столбце - т.е. допустим есть в столбце Иванов три раза, но выделять надо цветом только две ячейки, потому как в этих строках в столбце А стоит "К". Ну и если ячейка пустая, то выделять ее цветом тоже не надо

Автор - ovechkin1973
Дата добавления - 13.05.2017 в 18:31
buchlotnik Дата: Суббота, 13.05.2017, 19:23 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2775
Репутация: 791 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
например, так
Код
=(СЧЁТЕСЛИ($B:$B;$B1)>1)*ЕТЕКСТ($B1)*($A1="К")
К сообщению приложен файл: 1954582.xls(27Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениенапример, так
Код
=(СЧЁТЕСЛИ($B:$B;$B1)>1)*ЕТЕКСТ($B1)*($A1="К")

Автор - buchlotnik
Дата добавления - 13.05.2017 в 19:23
vikttur Дата: Суббота, 13.05.2017, 20:43 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2265
Репутация: 390 ±
Замечаний: 0% ±

Лишние вычисления обрезаем:
Код
=ЕСЛИ(B1<>"";ЕСЛИ(A1="К";СЧЁТЕСЛИ($B:$B;B1)>1))
 
Ответить
СообщениеЛишние вычисления обрезаем:
Код
=ЕСЛИ(B1<>"";ЕСЛИ(A1="К";СЧЁТЕСЛИ($B:$B;B1)>1))

Автор - vikttur
Дата добавления - 13.05.2017 в 20:43
ovechkin1973 Дата: Суббота, 13.05.2017, 20:46 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
блин... спецы экселя.. у меня в столбце А еще есть буквы Т, ТО, С.. с ними как быть?
 
Ответить
Сообщениеблин... спецы экселя.. у меня в столбце А еще есть буквы Т, ТО, С.. с ними как быть?

Автор - ovechkin1973
Дата добавления - 13.05.2017 в 20:46
vikttur Дата: Суббота, 13.05.2017, 20:57 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2265
Репутация: 390 ±
Замечаний: 0% ±

Удалите. Или допишите имена: Таня, Тоня, Степан... Или объясните, что нужно.
 
Ответить
СообщениеУдалите. Или допишите имена: Таня, Тоня, Степан... Или объясните, что нужно.

Автор - vikttur
Дата добавления - 13.05.2017 в 20:57
ovechkin1973 Дата: Суббота, 13.05.2017, 21:04 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
извиняюсь, что не совсем корректно задал вопрос. В реальном файле в столбце "А" стоит несколько букв, которые обозначают определенную информацию для пользователя- "К" "Т" "С" "ТО". В столбце "В" находится около 4000 уникальных значений. Мне надо выделить заливкой ячейку в столбце "В" повторы, если повторы так же имеются в столбце "А"
 
Ответить
Сообщениеизвиняюсь, что не совсем корректно задал вопрос. В реальном файле в столбце "А" стоит несколько букв, которые обозначают определенную информацию для пользователя- "К" "Т" "С" "ТО". В столбце "В" находится около 4000 уникальных значений. Мне надо выделить заливкой ячейку в столбце "В" повторы, если повторы так же имеются в столбце "А"

Автор - ovechkin1973
Дата добавления - 13.05.2017 в 21:04
vikttur Дата: Суббота, 13.05.2017, 21:08 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2265
Репутация: 390 ±
Замечаний: 0% ±

Повторы пар в столбцах А:В?
 
Ответить
СообщениеПовторы пар в столбцах А:В?

Автор - vikttur
Дата добавления - 13.05.2017 в 21:08
ovechkin1973 Дата: Суббота, 13.05.2017, 21:11 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
да, но в "А" их немного, а вот "В" очень много
 
Ответить
Сообщениеда, но в "А" их немного, а вот "В" очень много

Автор - ovechkin1973
Дата добавления - 13.05.2017 в 21:11
ovechkin1973 Дата: Суббота, 13.05.2017, 21:12 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
и выделять заливкой надо ячейки в столбце "В"
 
Ответить
Сообщениеи выделять заливкой надо ячейки в столбце "В"

Автор - ovechkin1973
Дата добавления - 13.05.2017 в 21:12
vikttur Дата: Суббота, 13.05.2017, 21:22 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2265
Репутация: 390 ±
Замечаний: 0% ±

Код
=ЕСЛИ(B1<>"";ЕСЛИ(ИЛИ(A1={"К";"С";"Т";"ТО"});СУММПРОИЗВ(--($A$1:$A$15&$B$1:$B$15=A1&B1))>1))

Если в проверке задействованы все буквы столбца, второе условие из формулы можно удалитьь.

Тем более, что применение массивов констант в условном форматировании недопустимо :)
Код
=ЕСЛИ(B1<>"";СУММПРОИЗВ(--($A$1:$A$15&$B$1:$B$15=A1&B1))>1)


Сообщение отредактировал vikttur - Суббота, 13.05.2017, 21:24
 
Ответить
Сообщение
Код
=ЕСЛИ(B1<>"";ЕСЛИ(ИЛИ(A1={"К";"С";"Т";"ТО"});СУММПРОИЗВ(--($A$1:$A$15&$B$1:$B$15=A1&B1))>1))

Если в проверке задействованы все буквы столбца, второе условие из формулы можно удалитьь.

Тем более, что применение массивов констант в условном форматировании недопустимо :)
Код
=ЕСЛИ(B1<>"";СУММПРОИЗВ(--($A$1:$A$15&$B$1:$B$15=A1&B1))>1)

Автор - vikttur
Дата добавления - 13.05.2017 в 21:22
ovechkin1973 Дата: Воскресенье, 14.05.2017, 19:03 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 81
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
огромное всем спасибо за помощь. Остановился на варианте
Код
ЕСЛИ(O5="";0;ЕСЛИ(O5<>"";СУММПРОИЗВ(--($O$5:$O$2000&$D$5:$D$2000=O5&D5))>1))

формула с реального файла и сын сделал еще одну проверку по пустой ячейке
 
Ответить
Сообщениеогромное всем спасибо за помощь. Остановился на варианте
Код
ЕСЛИ(O5="";0;ЕСЛИ(O5<>"";СУММПРОИЗВ(--($O$5:$O$2000&$D$5:$D$2000=O5&D5))>1))

формула с реального файла и сын сделал еще одну проверку по пустой ячейке

Автор - ovechkin1973
Дата добавления - 14.05.2017 в 19:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условное форматирование на повтор по содержанию другой ячейк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!