Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция "Суммпроизв", как суммировать диапазон исключая пуст - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "Суммпроизв", как суммировать диапазон исключая пуст (Формулы/Formulas)
Функция "Суммпроизв", как суммировать диапазон исключая пуст
Alesasa Дата: Воскресенье, 14.05.2017, 18:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Во вложении пример сложения дробных чисел, формула работает только при заполнении всех ячеек в диапазоне, а как сделать так чтобы пустые ячейки игнорировались
К сообщению приложен файл: _-__.xlsx(11Kb)
 
Ответить
СообщениеДобрый день!
Во вложении пример сложения дробных чисел, формула работает только при заполнении всех ячеек в диапазоне, а как сделать так чтобы пустые ячейки игнорировались

Автор - Alesasa
Дата добавления - 14.05.2017 в 18:22
buchlotnik Дата: Воскресенье, 14.05.2017, 18:30 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2775
Репутация: 791 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
попробуйте так:
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(B3:F3;ПОИСК("/";B3:F3)-1);0))
К сообщению приложен файл: 0208691.xlsx(11Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениепопробуйте так:
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(B3:F3;ПОИСК("/";B3:F3)-1);0))

Автор - buchlotnik
Дата добавления - 14.05.2017 в 18:30
Alesasa Дата: Воскресенье, 14.05.2017, 18:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, но в таком случае при удалении одного из значений в диапазоне результат вычисления "0", а нужна сумма значений не пустых ячеек.
К сообщению приложен файл: 8301345.xlsx(11Kb)
 
Ответить
СообщениеСпасибо, но в таком случае при удалении одного из значений в диапазоне результат вычисления "0", а нужна сумма значений не пустых ячеек.

Автор - Alesasa
Дата добавления - 14.05.2017 в 18:34
vikttur Дата: Воскресенье, 14.05.2017, 18:39 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2267
Репутация: 391 ±
Замечаний: 0% ±

Код
=СУММПРОИЗВ(--ЛЕВСИМВ(0&B3:F3;ПОИСК("/";0&B3:F3&"/")-1))

Код
=СУММПРОИЗВ(--ЗАМЕНИТЬ(B3:F3;1;ПОИСК("/";B3:F3&"/");0))
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ЛЕВСИМВ(0&B3:F3;ПОИСК("/";0&B3:F3&"/")-1))

Код
=СУММПРОИЗВ(--ЗАМЕНИТЬ(B3:F3;1;ПОИСК("/";B3:F3&"/");0))

Автор - vikttur
Дата добавления - 14.05.2017 в 18:39
buchlotnik Дата: Воскресенье, 14.05.2017, 18:59 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2775
Репутация: 791 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
но в таком случае
в таком случае объясните, зачем вы формулу массива переписали на обычную?
К сообщению приложен файл: 9358013.xlsx(11Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
но в таком случае
в таком случае объясните, зачем вы формулу массива переписали на обычную?

Автор - buchlotnik
Дата добавления - 14.05.2017 в 18:59
Alesasa Дата: Воскресенье, 14.05.2017, 19:00 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur, Спасибо Большое, то что надо!!!
 
Ответить
Сообщениеvikttur, Спасибо Большое, то что надо!!!

Автор - Alesasa
Дата добавления - 14.05.2017 в 19:00
Alesasa Дата: Воскресенье, 14.05.2017, 19:04 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik Спасибо, формула рабочая, но нужно было через "суммпроизв" для развития формулы.
 
Ответить
Сообщениеbuchlotnik Спасибо, формула рабочая, но нужно было через "суммпроизв" для развития формулы.

Автор - Alesasa
Дата добавления - 14.05.2017 в 19:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "Суммпроизв", как суммировать диапазон исключая пуст (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!