Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование динамичного диапозона с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование динамичного диапозона с условием (Формулы/Formulas)
Суммирование динамичного диапозона с условием
CrazyNice Дата: Понедельник, 15.05.2017, 17:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Подскажите, пожалуйста, как просуммировать:
Есть 2 таблицы:
- одна не изменяется, данные представлены в разбивке регион-бренд-суббренд и по месяцам
- во второй таблице нужно просуммировать данные из 1й таблице с разбивкой регион-бренд (т.е. "схлопнуть" суббренды) по 3м месяцам, которые "двигаются" каждый месяц на 1.

Во вложении пример.
Сводную сделать нельзя, это кусок из большого отчета.

заранее большое спасибо за помощь.
К сообщению приложен файл: -...xlsx(11.0 Kb)
 
Ответить
СообщениеДобрый день!

Подскажите, пожалуйста, как просуммировать:
Есть 2 таблицы:
- одна не изменяется, данные представлены в разбивке регион-бренд-суббренд и по месяцам
- во второй таблице нужно просуммировать данные из 1й таблице с разбивкой регион-бренд (т.е. "схлопнуть" суббренды) по 3м месяцам, которые "двигаются" каждый месяц на 1.

Во вложении пример.
Сводную сделать нельзя, это кусок из большого отчета.

заранее большое спасибо за помощь.

Автор - CrazyNice
Дата добавления - 15.05.2017 в 17:15
Nic70y Дата: Понедельник, 15.05.2017, 17:25 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4679
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИМН(ИНДЕКС($E$3:$K$11;;ПОИСКПОЗ(R$2;$E$2:$K$2;));$B$3:$B$11;$P3;$D$3:$D$11;$Q3)
К сообщению приложен файл: 4596271.xlsx(10.9 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(ИНДЕКС($E$3:$K$11;;ПОИСКПОЗ(R$2;$E$2:$K$2;));$B$3:$B$11;$P3;$D$3:$D$11;$Q3)

Автор - Nic70y
Дата добавления - 15.05.2017 в 17:25
китин Дата: Вторник, 16.05.2017, 08:04 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4889
Репутация: 782 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СУММПРОИЗВ($E$3:$P$11*($E$2:$P$2=U$2)*($A$3:$A$11=$R3))
или без сцепки
Код
=СУММПРОИЗВ($E$3:$P$11*($E$2:$P$2=U$2)*($B$3:$B$11=$S22)*($D$3:$D$11=$T22))
К сообщению приложен файл: 222111.xlsx(12.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=СУММПРОИЗВ($E$3:$P$11*($E$2:$P$2=U$2)*($A$3:$A$11=$R3))
или без сцепки
Код
=СУММПРОИЗВ($E$3:$P$11*($E$2:$P$2=U$2)*($B$3:$B$11=$S22)*($D$3:$D$11=$T22))

Автор - китин
Дата добавления - 16.05.2017 в 08:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование динамичного диапозона с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!