Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция Если для таблицы с выводом данных при условии - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Если для таблицы с выводом данных при условии (Формулы/Formulas)
Функция Если для таблицы с выводом данных при условии
Skittish Дата: Вторник, 16.05.2017, 12:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Помогите написать функцию для таких условий.
В ячейке А1 текст с 1/9, 1/20 или 1/24.
В ячейке А2 количество.
И нужно чтоб если в А1 встречается 1/9, то цифру из А2 делим на 9 и результат в А3 например, так же и с остальными 1/20 и 1/24.
И в итоге все 3 результата в А3, А4 и А5.
Сумбурно написала, но пробовала - не получилось(


Сообщение отредактировал Skittish - Вторник, 16.05.2017, 13:47
 
Ответить
СообщениеПомогите написать функцию для таких условий.
В ячейке А1 текст с 1/9, 1/20 или 1/24.
В ячейке А2 количество.
И нужно чтоб если в А1 встречается 1/9, то цифру из А2 делим на 9 и результат в А3 например, так же и с остальными 1/20 и 1/24.
И в итоге все 3 результата в А3, А4 и А5.
Сумбурно написала, но пробовала - не получилось(

Автор - Skittish
Дата добавления - 16.05.2017 в 12:32
китин Дата: Вторник, 16.05.2017, 12:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ЕСЛИ(A1="1/9";A2/9;ЕСЛИ(A1="1/20";A2/20;A2/24)

если не так прикладывайте файл пример: гадать не булем


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 16.05.2017, 12:38
 
Ответить
Сообщение
Код
=ЕСЛИ(A1="1/9";A2/9;ЕСЛИ(A1="1/20";A2/20;A2/24)

если не так прикладывайте файл пример: гадать не булем

Автор - китин
Дата добавления - 16.05.2017 в 12:38
Skittish Дата: Вторник, 16.05.2017, 12:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
нужно чтоб в каждую колонку при своем условии выносило
К сообщению приложен файл: 2788658.xlsx(9Kb)
 
Ответить
Сообщениенужно чтоб в каждую колонку при своем условии выносило

Автор - Skittish
Дата добавления - 16.05.2017 в 12:46
китин Дата: Вторник, 16.05.2017, 13:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вот такое извращение :D
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(D$2;ПОИСК("/";D$2)+2));$B3));$C3/--ПСТР(D$2&" ";ПОИСК("/";D$2&" ")+1;2);"")
К сообщению приложен файл: 222222.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 16.05.2017, 13:11
 
Ответить
Сообщениевот такое извращение :D
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(ЛЕВБ(D$2;ПОИСК("/";D$2)+2));$B3));$C3/--ПСТР(D$2&" ";ПОИСК("/";D$2&" ")+1;2);"")

Автор - китин
Дата добавления - 16.05.2017 в 13:08
Skittish Дата: Вторник, 16.05.2017, 13:09 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
я просто озвучить условия могу, а вот написать уже не получается.
если в а1 есть 1/9, то а2/9 и пишет в а3; если в а1 есть 1/20, то а2/20 и пишет в а4; если в а1 есть 1/24, то а2/24 и пишет в а5.
как то так killed
 
Ответить
Сообщениея просто озвучить условия могу, а вот написать уже не получается.
если в а1 есть 1/9, то а2/9 и пишет в а3; если в а1 есть 1/20, то а2/20 и пишет в а4; если в а1 есть 1/24, то а2/24 и пишет в а5.
как то так killed

Автор - Skittish
Дата добавления - 16.05.2017 в 13:09
Skittish Дата: Вторник, 16.05.2017, 13:12 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
офигеть)) спасибо
я б такое точно бы не смогла))
 
Ответить
Сообщениеофигеть)) спасибо
я б такое точно бы не смогла))

Автор - Skittish
Дата добавления - 16.05.2017 в 13:12
китин Дата: Вторник, 16.05.2017, 13:13 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 16.05.2017, 13:16
 
Ответить
Skittish Дата: Вторник, 16.05.2017, 13:48 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
вроде изменила.. не уверена что правильно. первый раз тут
 
Ответить
Сообщениевроде изменила.. не уверена что правильно. первый раз тут

Автор - Skittish
Дата добавления - 16.05.2017 в 13:48
AlexM Дата: Вторник, 16.05.2017, 13:48 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3585
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Еще вариант формулы
Код
=ТЕКСТ($C3*ЕЧИСЛО(ПОИСК(ЛЕВБ(D$2;4);$B3))/ПСТР(D$2;3;2);"0,0#;;")
К сообщению приложен файл: 2788658_01.xlsx(9Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант формулы
Код
=ТЕКСТ($C3*ЕЧИСЛО(ПОИСК(ЛЕВБ(D$2;4);$B3))/ПСТР(D$2;3;2);"0,0#;;")

Автор - AlexM
Дата добавления - 16.05.2017 в 13:48
китин Дата: Вторник, 16.05.2017, 13:59 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
первый раз тут

надеемся , что не последний :D hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
первый раз тут

надеемся , что не последний :D hands

Автор - китин
Дата добавления - 16.05.2017 в 13:59
Skittish Дата: Вторник, 16.05.2017, 14:07 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
после таких извращений.. я еще подумаю :D
 
Ответить
Сообщениепосле таких извращений.. я еще подумаю :D

Автор - Skittish
Дата добавления - 16.05.2017 в 14:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция Если для таблицы с выводом данных при условии (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!