Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма уникальных значений в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма уникальных значений в диапазоне (Формулы/Formulas)
Сумма уникальных значений в диапазоне
Ktulu Дата: Среда, 17.05.2017, 05:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день, уважаемые коллеги!
Прошерстил поиск, но точного ответа так и не нашёл.
Нужно просуммировать уникальные значения в диапазоне
Для 2003 Экселя.
Заранее спасибо
К сообщению приложен файл: 7484480.xls(14Kb)
 
Ответить
СообщениеДобрый день, уважаемые коллеги!
Прошерстил поиск, но точного ответа так и не нашёл.
Нужно просуммировать уникальные значения в диапазоне
Для 2003 Экселя.
Заранее спасибо

Автор - Ktulu
Дата добавления - 17.05.2017 в 05:14
buchlotnik Дата: Среда, 17.05.2017, 07:14 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3429
Репутация: 920 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно так (массивка):
Код
=СУММ(ЕСЛИ((C4:C33)>0;C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);0))
чуть короче можно
Код
=СУММ(ЕСЛИ(C4:C33;C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);))
К сообщению приложен файл: 7611929.xls(28Kb)


"заступлюсь за Юрия" - публичный плевок в душу!

Сообщение отредактировал buchlotnik - Среда, 17.05.2017, 10:14
 
Ответить
Сообщениеможно так (массивка):
Код
=СУММ(ЕСЛИ((C4:C33)>0;C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);0))
чуть короче можно
Код
=СУММ(ЕСЛИ(C4:C33;C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);))

Автор - buchlotnik
Дата добавления - 17.05.2017 в 07:14
vikttur Дата: Среда, 17.05.2017, 10:02 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Форула массива:
Код
=СУММ(ЕСЛИОШИБКА(C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);))

Как обычная, должна быть шустрее:
Код
=СУММПРОИЗВ(--(ПОИСКПОЗ(C4:C33;--C4:C33;)=СТРОКА(C4:C33)-3);C4:C33)

Она же, формула массива:
Код
=СУММ(ЕСЛИ(ПОИСКПОЗ(C4:C33;--C4:C33;)=СТРОКА(C4:C33)-3;C4:C33))


Сообщение отредактировал vikttur - Среда, 17.05.2017, 10:08
 
Ответить
СообщениеФорула массива:
Код
=СУММ(ЕСЛИОШИБКА(C4:C33/СЧЁТЕСЛИ(C4:C33;C4:C33);))

Как обычная, должна быть шустрее:
Код
=СУММПРОИЗВ(--(ПОИСКПОЗ(C4:C33;--C4:C33;)=СТРОКА(C4:C33)-3);C4:C33)

Она же, формула массива:
Код
=СУММ(ЕСЛИ(ПОИСКПОЗ(C4:C33;--C4:C33;)=СТРОКА(C4:C33)-3;C4:C33))

Автор - vikttur
Дата добавления - 17.05.2017 в 10:02
Ktulu Дата: Четверг, 18.05.2017, 04:44 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Большое спасибо!
 
Ответить
СообщениеБольшое спасибо!

Автор - Ktulu
Дата добавления - 18.05.2017 в 04:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма уникальных значений в диапазоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!