Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула суммы разностей строк с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммы разностей строк с условием (Формулы/Formulas)
Формула суммы разностей строк с условием
Ajpitac Дата: Среда, 17.05.2017, 08:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, участники сообщества!

Столкнулся со следующей проблемой: есть две строки А1:J1 и A2:J2 с числовыми значениями. Вычисляются разности A1-A2, B1-B2, ... , J1-J2. Затем из полученных разностей берутся только те, что больше нуля, и складываются друг с другом. Получается финальное значение.
Упрощенный до трех значений в строке пример:
2 3 8
1 5 3
Итоговый результат будет =6 (сумма (2-1) и (8-3))
По частям это реализовать смог, а вот в одну формулу упихнуть что-то никак((( Пришел к формуле
Код
=СУММЕСЛИ(A1:J1-A2:J2;">0")
, но она выдает ошибку, а как по-другому сделать не смог придумать.

Буду признателен, если подскажите как реализовать подобное одной формулой!


Сообщение отредактировал Ajpitac - Среда, 17.05.2017, 09:24
 
Ответить
СообщениеЗдравствуйте, участники сообщества!

Столкнулся со следующей проблемой: есть две строки А1:J1 и A2:J2 с числовыми значениями. Вычисляются разности A1-A2, B1-B2, ... , J1-J2. Затем из полученных разностей берутся только те, что больше нуля, и складываются друг с другом. Получается финальное значение.
Упрощенный до трех значений в строке пример:
2 3 8
1 5 3
Итоговый результат будет =6 (сумма (2-1) и (8-3))
По частям это реализовать смог, а вот в одну формулу упихнуть что-то никак((( Пришел к формуле
Код
=СУММЕСЛИ(A1:J1-A2:J2;">0")
, но она выдает ошибку, а как по-другому сделать не смог придумать.

Буду признателен, если подскажите как реализовать подобное одной формулой!

Автор - Ajpitac
Дата добавления - 17.05.2017 в 08:58
_Boroda_ Дата: Среда, 17.05.2017, 09:10 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10439
Репутация: 4382 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=СУММПРОИЗВ((A1:J1>A2:J2)*(A1:J1-A2:J2))

Еще
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:J1-A2:J2;"0;\0"))
Блин! Я тормоз! формулу без тегов не заметил. Ответ скрыл пока
Андрей, войдите в правку своего поста, выделите формулу и нажмите кнопочку # на панели

Я точно еще не проснулся. Не #, а Fx. Поправил Вам, извините
Свой пост открыл
К сообщению приложен файл: 516786.xlsm(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=СУММПРОИЗВ((A1:J1>A2:J2)*(A1:J1-A2:J2))

Еще
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:J1-A2:J2;"0;\0"))
Блин! Я тормоз! формулу без тегов не заметил. Ответ скрыл пока
Андрей, войдите в правку своего поста, выделите формулу и нажмите кнопочку # на панели

Я точно еще не проснулся. Не #, а Fx. Поправил Вам, извините
Свой пост открыл

Автор - _Boroda_
Дата добавления - 17.05.2017 в 09:10
buchlotnik Дата: Среда, 17.05.2017, 09:13 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 782 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Ajpitac, здравствуйте.
Как-то так
Код
=СУММПРОИЗВ((A1:J1-A2:J2)*(A1:J1>A2:J2))
Код
=СУММ(ЕСЛИ(A1:J1>A2:J2;A1:J1-A2:J2;0))


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 17.05.2017, 09:32
 
Ответить
СообщениеAjpitac, здравствуйте.
Как-то так
Код
=СУММПРОИЗВ((A1:J1-A2:J2)*(A1:J1>A2:J2))
Код
=СУММ(ЕСЛИ(A1:J1>A2:J2;A1:J1-A2:J2;0))

Автор - buchlotnik
Дата добавления - 17.05.2017 в 09:13
_Boroda_ Дата: Среда, 17.05.2017, 09:30 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10439
Репутация: 4382 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я точно еще не проснулся. Не #, а Fx. Поправил Вам, извините. Кстати, В Правилах форума есть ссылка на пояснялку для тегов.
Пост открыл

Михаил, сейчас придет Виктор и скажет, что вот так быстрее :D
Код
=СУММПРОИЗВ(--(A1:J1>A2:J2);A1:J1-A2:J2)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ точно еще не проснулся. Не #, а Fx. Поправил Вам, извините. Кстати, В Правилах форума есть ссылка на пояснялку для тегов.
Пост открыл

Михаил, сейчас придет Виктор и скажет, что вот так быстрее :D
Код
=СУММПРОИЗВ(--(A1:J1>A2:J2);A1:J1-A2:J2)

Автор - _Boroda_
Дата добавления - 17.05.2017 в 09:30
buchlotnik Дата: Среда, 17.05.2017, 09:34 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2742
Репутация: 782 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
[offtop]
Цитата
сейчас придет Виктор и скажет
[/offtop] но по крайней мере на волатильность ругаться не будет :D :D :D


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение[offtop]
Цитата
сейчас придет Виктор и скажет
[/offtop] но по крайней мере на волатильность ругаться не будет :D :D :D

Автор - buchlotnik
Дата добавления - 17.05.2017 в 09:34
Ajpitac Дата: Среда, 17.05.2017, 09:36 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное! Именно то, что нужно!

По замечаниям в оформлении: про файл решил, что оговорка "кроме тех случаев, когда вопрос носит общий характер и не касается конкретно Вашего файла" в правилах как раз для моего случая, поэтому не приложил. Пожалуй, что зря, для порядку нужно было бы приложить. Извиняюсь.
А про теги, что чего-то подумал что речь про хэштеги по типу инстаграммовских и не понял зачем они вообще здесь :D Теперь сообразил)))

To _Boroda_: вы ответ в тексте закрыли до исправления ошибок, а файл тем не менее был доступен)) На следующий раз Вам, когда будете приучать к порядку нерадивых как я))

Еще раз Большое Спасибо!
 
Ответить
СообщениеСпасибо огромное! Именно то, что нужно!

По замечаниям в оформлении: про файл решил, что оговорка "кроме тех случаев, когда вопрос носит общий характер и не касается конкретно Вашего файла" в правилах как раз для моего случая, поэтому не приложил. Пожалуй, что зря, для порядку нужно было бы приложить. Извиняюсь.
А про теги, что чего-то подумал что речь про хэштеги по типу инстаграммовских и не понял зачем они вообще здесь :D Теперь сообразил)))

To _Boroda_: вы ответ в тексте закрыли до исправления ошибок, а файл тем не менее был доступен)) На следующий раз Вам, когда будете приучать к порядку нерадивых как я))

Еще раз Большое Спасибо!

Автор - Ajpitac
Дата добавления - 17.05.2017 в 09:36
_Boroda_ Дата: Среда, 17.05.2017, 09:38 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 10439
Репутация: 4382 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
вы ответ в тексте закрыли до исправления ошибок, а файл тем не менее был доступен

Я знаю. Хотел удалить, но забыл. За 3 последних ночи спал 7,5 часов. Не очень соображаю...


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
вы ответ в тексте закрыли до исправления ошибок, а файл тем не менее был доступен

Я знаю. Хотел удалить, но забыл. За 3 последних ночи спал 7,5 часов. Не очень соображаю...

Автор - _Boroda_
Дата добавления - 17.05.2017 в 09:38
vikttur Дата: Среда, 17.05.2017, 09:54 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

Ростки сомнений проросли :)
 
Ответить
СообщениеРостки сомнений проросли :)

Автор - vikttur
Дата добавления - 17.05.2017 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула суммы разностей строк с условием (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!