Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ячейки и сравнение результатов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячейки и сравнение результатов (Формулы/Formulas)
Поиск ячейки и сравнение результатов
AVI Дата: Среда, 17.05.2017, 10:50 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Формула в столбце D ищет первое пустое место.
В примере это D4.
Далее цифру из ячейки A4 формула ищет в диапазоне от A5 до А9 (то есть на 5 ячеек вниз) и, в случае нахождения сопадений, проверяет содержимое соответсвующих ячеек в столбце D, и если в ячейках пусто, то пишет "Пусто" в той самой первой ячейке, что в самом начале нашла формула, а если не пусто, то
Код
=сжпробелы(F3&" "&G3&" "&H3)


Пример того, что надо отражен в столбце E
К сообщению приложен файл: 9830674.xlsx(11Kb)


Сообщение отредактировал AVI - Среда, 17.05.2017, 12:04
 
Ответить
СообщениеФормула в столбце D ищет первое пустое место.
В примере это D4.
Далее цифру из ячейки A4 формула ищет в диапазоне от A5 до А9 (то есть на 5 ячеек вниз) и, в случае нахождения сопадений, проверяет содержимое соответсвующих ячеек в столбце D, и если в ячейках пусто, то пишет "Пусто" в той самой первой ячейке, что в самом начале нашла формула, а если не пусто, то
Код
=сжпробелы(F3&" "&G3&" "&H3)


Пример того, что надо отражен в столбце E

Автор - AVI
Дата добавления - 17.05.2017 в 10:50
Nic70y Дата: Среда, 17.05.2017, 11:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3923
Репутация: 830 ±
Замечаний: 0% ±

Excel 2013
такштоли
Код
=ЕСЛИОШИБКА(ВПР(A2;A3:D$9;);СЖПРОБЕЛЫ(СЦЕПИТЬ(F2;" ";G2;" ";H2)))

[p.s.]функцию СЦЕПИТЬ() используют только лентяи :)[/p.s.]
К сообщению приложен файл: 9801418.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 17.05.2017, 11:11
 
Ответить
Сообщениетакштоли
Код
=ЕСЛИОШИБКА(ВПР(A2;A3:D$9;);СЖПРОБЕЛЫ(СЦЕПИТЬ(F2;" ";G2;" ";H2)))

[p.s.]функцию СЦЕПИТЬ() используют только лентяи :)[/p.s.]

Автор - Nic70y
Дата добавления - 17.05.2017 в 11:10
AVI Дата: Среда, 17.05.2017, 12:02 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Подправил задание)
[p.s.]учел
 
Ответить
СообщениеNic70y, Подправил задание)
[p.s.]учел

Автор - AVI
Дата добавления - 17.05.2017 в 12:02
sboy Дата: Среда, 17.05.2017, 12:44 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 601
Репутация: 156 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
сделал точно по заданию(наверно %) ), с Вашим "надо" не совсем совпало
и вопрос почему именно проверяем на 5 ячеек вниз?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;A3:A7;))*(D2="");"Пусто";D2)
К сообщению приложен файл: 4573578.xlsx(12Kb)
 
Ответить
СообщениеДобрый день.
сделал точно по заданию(наверно %) ), с Вашим "надо" не совсем совпало
и вопрос почему именно проверяем на 5 ячеек вниз?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;A3:A7;))*(D2="");"Пусто";D2)

Автор - sboy
Дата добавления - 17.05.2017 в 12:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячейки и сравнение результатов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!