Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула выдает ошибку, если она ссылается на ячейку с формул - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула выдает ошибку, если она ссылается на ячейку с формул (Формулы/Formulas)
Формула выдает ошибку, если она ссылается на ячейку с формул
kallinin Дата: Среда, 17.05.2017, 19:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте.
Есть формула:
Код
=ЕСЛИ(K37>0;N$33;"")

По умолчании формула работает хорошо, но если вышеуказанная формула ссылается на ячейки, где есть формула(ссылка), то формула выдает ошибку. По подробнее так:
Есть столбец B5-B20, если непосредственно в него вводить цифры, то формула работает отлично, а если в ячейки B5-B20 записать формулы, ссылка на другие ячейки, например:
Код
=ЕСЛИОШИБКА(ЕСЛИ($A30>0;ИНДЕКС('[Материальный отчет 10.5 (зап. части) за 2017 год.xlsx]апрель 17 '!$T$11:$T$230;$A30));"")
, и так далее тогда и выдает вышеуказанная формула ошибку, а нужно чтобы не выдавала формула ошибку. Помогите поправить эту ошибку.
Заранее Спасибо.
К сообщению приложен файл: 5769178.xls(52Kb)


Сообщение отредактировал kallinin - Среда, 17.05.2017, 20:53
 
Ответить
СообщениеЗдравствуйте.
Есть формула:
Код
=ЕСЛИ(K37>0;N$33;"")

По умолчании формула работает хорошо, но если вышеуказанная формула ссылается на ячейки, где есть формула(ссылка), то формула выдает ошибку. По подробнее так:
Есть столбец B5-B20, если непосредственно в него вводить цифры, то формула работает отлично, а если в ячейки B5-B20 записать формулы, ссылка на другие ячейки, например:
Код
=ЕСЛИОШИБКА(ЕСЛИ($A30>0;ИНДЕКС('[Материальный отчет 10.5 (зап. части) за 2017 год.xlsx]апрель 17 '!$T$11:$T$230;$A30));"")
, и так далее тогда и выдает вышеуказанная формула ошибку, а нужно чтобы не выдавала формула ошибку. Помогите поправить эту ошибку.
Заранее Спасибо.

Автор - kallinin
Дата добавления - 17.05.2017 в 19:17
gling Дата: Среда, 17.05.2017, 19:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1506
Репутация: 374 ±
Замечаний: 0% ±

2010
В формуле
Цитата
=ЕСЛИОШИБКА(ЕСЛИ($A30>0;ИНДЕКС('[Материальный отчет 10.5 (зап. части) за 2017 год.xlsx]апрель 17 '!$T$11:$T$230;$A30));0)
вместо кавычек напишите ноль.


Сообщение отредактировал gling - Среда, 17.05.2017, 19:21
 
Ответить
СообщениеВ формуле
Цитата
=ЕСЛИОШИБКА(ЕСЛИ($A30>0;ИНДЕКС('[Материальный отчет 10.5 (зап. части) за 2017 год.xlsx]апрель 17 '!$T$11:$T$230;$A30));0)
вместо кавычек напишите ноль.

Автор - gling
Дата добавления - 17.05.2017 в 19:20
buchlotnik Дата: Среда, 17.05.2017, 19:22 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2601
Репутация: 744 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
kallinin, здравствуйте.
В соответствиями с правилами форума приложите пример и оформите формулы тегами


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеkallinin, здравствуйте.
В соответствиями с правилами форума приложите пример и оформите формулы тегами

Автор - buchlotnik
Дата добавления - 17.05.2017 в 19:22
kallinin Дата: Среда, 17.05.2017, 19:27 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата
вместо кавычек напишите ноль
Тогда как убрать нули, которые отображаются в пустых ячейках?


Сообщение отредактировал kallinin - Среда, 17.05.2017, 20:51
 
Ответить
Сообщение
Цитата
вместо кавычек напишите ноль
Тогда как убрать нули, которые отображаются в пустых ячейках?

Автор - kallinin
Дата добавления - 17.05.2017 в 19:27
gling Дата: Среда, 17.05.2017, 19:50 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1506
Репутация: 374 ±
Замечаний: 0% ±

2010
Тогда как убрать нули,

Исправьте ошибки в сообщениях и ознакомьтесь с правилами форума. В правилах есть информация о количестве вопросов в теме.
 
Ответить
Сообщение
Тогда как убрать нули,

Исправьте ошибки в сообщениях и ознакомьтесь с правилами форума. В правилах есть информация о количестве вопросов в теме.

Автор - gling
Дата добавления - 17.05.2017 в 19:50
Nic70y Дата: Среда, 17.05.2017, 21:11 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3910
Репутация: 827 ±
Замечаний: 0% ±

Excel 2013
если не менять "" на 0
Код
=ЕСЛИ(--(0&F20)>0;N$23;"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 17.05.2017, 21:12
 
Ответить
Сообщениеесли не менять "" на 0
Код
=ЕСЛИ(--(0&F20)>0;N$23;"")

Автор - Nic70y
Дата добавления - 17.05.2017 в 21:11
kallinin Дата: Среда, 17.05.2017, 21:18 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Спасибо просто супер!
 
Ответить
СообщениеNic70y, Спасибо просто супер!

Автор - kallinin
Дата добавления - 17.05.2017 в 21:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула выдает ошибку, если она ссылается на ячейку с формул (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!