Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение значения с таблицей данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значения с таблицей данных (Формулы/Formulas)
Сравнение значения с таблицей данных
Didrou Дата: Четверг, 18.05.2017, 09:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброе время суток!
Исполюзую формулу:
Код
=ЕСЛИ(B5="";"";ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;0)))

для сравнения числа из ячейки Лист2!B5 с данными из ячеек Лист1!B5:B15, чтобы получить соответствующее значение для Лист2!C5 из ячеек Лист1!B5:B15.

Необходимо запилить следующее ограничение. Если Лист2!B5 > Лист1!A5, то Лист2!С5 = Лист1!B5 и если Лист2!B5 < Лист1!A15, то Лист2!C5 = Лист1!A15.
Прошу помощи в решении этой задачи. Может лучше макросом, но я в них не особо ориентируюсь.
К сообщению приложен файл: 8711539.xlsx(9Kb)


Сообщение отредактировал Didrou - Четверг, 18.05.2017, 09:18
 
Ответить
СообщениеДоброе время суток!
Исполюзую формулу:
Код
=ЕСЛИ(B5="";"";ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;0)))

для сравнения числа из ячейки Лист2!B5 с данными из ячеек Лист1!B5:B15, чтобы получить соответствующее значение для Лист2!C5 из ячеек Лист1!B5:B15.

Необходимо запилить следующее ограничение. Если Лист2!B5 > Лист1!A5, то Лист2!С5 = Лист1!B5 и если Лист2!B5 < Лист1!A15, то Лист2!C5 = Лист1!A15.
Прошу помощи в решении этой задачи. Может лучше макросом, но я в них не особо ориентируюсь.

Автор - Didrou
Дата добавления - 18.05.2017 в 09:15
_Boroda_ Дата: Четверг, 18.05.2017, 09:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(B5="";"";ЕСЛИ(B5>Лист1!A5;Лист1!B5;ЕСЛИ(B5<Лист1!A15;Лист1!B15;ВПР(B5;Лист1!A5:B16;2;))))

Код
=ЕСЛИ(B5="";"";ЕСЛИ(B5>Лист1!A5;Лист1!B5;ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;-1))))
К сообщению приложен файл: 8711539_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(B5="";"";ЕСЛИ(B5>Лист1!A5;Лист1!B5;ЕСЛИ(B5<Лист1!A15;Лист1!B15;ВПР(B5;Лист1!A5:B16;2;))))

Код
=ЕСЛИ(B5="";"";ЕСЛИ(B5>Лист1!A5;Лист1!B5;ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;-1))))

Автор - _Boroda_
Дата добавления - 18.05.2017 в 09:48
Didrou Дата: Четверг, 18.05.2017, 14:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не могу осмыслить формулу в части
Код
ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;-1))

а что именно делает значение -1. Прочёл, что это тип сопостовления
Цитата
ПОИСКПОЗ(искомое_значение;просматриваемый_массив;[тип_сопоставления])
При тип_сопоставления=-1 функция ПОИСКПОЗ находит наименьшее значение, которое больше или равно значению аргумента искомое_значение. Просматриваемый_массив должен быть упорядочен по убыванию: ИСТИНА, ЛОЖЬ, Z-A, ..., 2, 1, 0, -1, -2, ... и т. д.

Всё равно не понял как оно с -1 работает в нашем примере.


Сообщение отредактировал Didrou - Четверг, 18.05.2017, 14:45
 
Ответить
СообщениеНе могу осмыслить формулу в части
Код
ИНДЕКС(Лист1!B5:B15;ПОИСКПОЗ(B5;Лист1!A5:A15;-1))

а что именно делает значение -1. Прочёл, что это тип сопостовления
Цитата
ПОИСКПОЗ(искомое_значение;просматриваемый_массив;[тип_сопоставления])
При тип_сопоставления=-1 функция ПОИСКПОЗ находит наименьшее значение, которое больше или равно значению аргумента искомое_значение. Просматриваемый_массив должен быть упорядочен по убыванию: ИСТИНА, ЛОЖЬ, Z-A, ..., 2, 1, 0, -1, -2, ... и т. д.

Всё равно не понял как оно с -1 работает в нашем примере.

Автор - Didrou
Дата добавления - 18.05.2017 в 14:45
_Boroda_ Дата: Четверг, 18.05.2017, 15:22 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас массив по убыванию, правильно? Следовательно, для для всех значений, меньших самого маленького (последнего), ПОИСКПОЗ дает позицию этого последнего.
Так понятнее?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас массив по убыванию, правильно? Следовательно, для для всех значений, меньших самого маленького (последнего), ПОИСКПОЗ дает позицию этого последнего.
Так понятнее?

Автор - _Boroda_
Дата добавления - 18.05.2017 в 15:22
Didrou Дата: Четверг, 18.05.2017, 15:31 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так понятно, спасибо)
 
Ответить
СообщениеТак понятно, спасибо)

Автор - Didrou
Дата добавления - 18.05.2017 в 15:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значения с таблицей данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!