Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/SUMIFS с 3 параметрами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » SUMIFS с 3 параметрами (Формулы/Formulas)
SUMIFS с 3 параметрами
Gopronotmore Дата: Четверг, 08.06.2017, 16:13 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Добрый день формучане, подскажите есть ли кто знающий как написать формулу, файл во вложении .....
К сообщению приложен файл: SOS.xlsx(10Kb)
 
Ответить
СообщениеДобрый день формучане, подскажите есть ли кто знающий как написать формулу, файл во вложении .....

Автор - Gopronotmore
Дата добавления - 08.06.2017 в 16:13
_Boroda_ Дата: Четверг, 08.06.2017, 16:23 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Всё аналогично
Код
=СУММЕСЛИМН(ИНДЕКС($C$11:$E$13;ПОИСКПОЗ(I14;B11:B13;););C9:E9;J12;C10:E10;J13)
К сообщению приложен файл: SOS-1-1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВсё аналогично
Код
=СУММЕСЛИМН(ИНДЕКС($C$11:$E$13;ПОИСКПОЗ(I14;B11:B13;););C9:E9;J12;C10:E10;J13)

Автор - _Boroda_
Дата добавления - 08.06.2017 в 16:23
Gopronotmore Дата: Четверг, 08.06.2017, 16:28 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_,

Спасибо большое, но есть одна проблема, если изменить название параметра например не A а поставить B то выдаст 0, потому что как я понял сумеслимн берет только по 1 столбцу ((((
 
Ответить
Сообщение_Boroda_,

Спасибо большое, но есть одна проблема, если изменить название параметра например не A а поставить B то выдаст 0, потому что как я понял сумеслимн берет только по 1 столбцу ((((

Автор - Gopronotmore
Дата добавления - 08.06.2017 в 16:28
Gopronotmore Дата: Четверг, 08.06.2017, 16:42 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Я потестировал, если параметры в столбце не равны друг другу то не считает, а если равны то берет верное значение ....
 
Ответить
СообщениеЯ потестировал, если параметры в столбце не равны друг другу то не считает, а если равны то берет верное значение ....

Автор - Gopronotmore
Дата добавления - 08.06.2017 в 16:42
_Boroda_ Дата: Четверг, 08.06.2017, 16:50 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не A а поставить B то выдаст 0

А что Вы хотите? b даст число только в том случае, если вместе с ним мы будем искать еще и двойку
Приведите пример в файле - что вводите и что получить хотите
Кстати, можно еще и вот такой формулой, попроще, но позадумчивей
Код
=СУММПРОИЗВ(C11:E13*(B11:B13=I14)*(C9:E9=J12)*(C10:E10=J13))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не A а поставить B то выдаст 0

А что Вы хотите? b даст число только в том случае, если вместе с ним мы будем искать еще и двойку
Приведите пример в файле - что вводите и что получить хотите
Кстати, можно еще и вот такой формулой, попроще, но позадумчивей
Код
=СУММПРОИЗВ(C11:E13*(B11:B13=I14)*(C9:E9=J12)*(C10:E10=J13))

Автор - _Boroda_
Дата добавления - 08.06.2017 в 16:50
Gopronotmore Дата: Четверг, 08.06.2017, 16:52 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, а Вы были правы! Спасибо! Я сам тупанул, значения должны быть одинаковыми по столбцам, по этмоу и не считало, спасибо за альтернативный ответ, ну и + к карме


Сообщение отредактировал Gopronotmore - Четверг, 08.06.2017, 16:53
 
Ответить
Сообщение_Boroda_, а Вы были правы! Спасибо! Я сам тупанул, значения должны быть одинаковыми по столбцам, по этмоу и не считало, спасибо за альтернативный ответ, ну и + к карме

Автор - Gopronotmore
Дата добавления - 08.06.2017 в 16:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » SUMIFS с 3 параметрами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!