Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как создать интеллектуальный подсчет з/п и долгов? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как создать интеллектуальный подсчет з/п и долгов? (Формулы/Formulas)
Как создать интеллектуальный подсчет з/п и долгов?
boulingist Дата: Пятница, 09.06.2017, 09:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Привет, уважаемые специалисты!
Есть задумка подсчета зп и долгов по ней, и хотелось бы узнать, на сколько она реализуема, если да, то как.
И так:
Есть таблица из пяти столбцов
Столбец 1 Месяцы
Столбец 2 Зарплата
Столбец 3 Выдано
Столбец 4 Долг по зп
Столбец 5 Дата.
Суть идеи вот такая:
Можно ли сделать так, что бы ексель подсчитывал долг не полность по столбцу, а по дате.
т.е. Если ЗП выдаётся каждого 10-го числа, то сумма долга выводится на текущий момент.
Другими словами Если до 10 июня 2017г был долг 1000руб. то показывается только этот долг (в промежутке дат с 10.01.2017 по 09.06.2017).
Но как только наступило 10 июня 2017 то долг автоматически (ексель видит дату) и меняется на такую формулу Долг+(зарплата-выдано)
В файле, я сделал как мог, но его надо прибрать. А именно:
Так как Июль, Август и другие месяца еще не наступили (точнее не наступило 10 число соответствующего месяца) то учета по этим месяцам не должно выводиться.

Если выразил мысль не достаточно понятно, задавайте вопросы... Сейчас я сформулировал как мог...

Или можно выразить мою мысль по другому:
В ячейке "долг на текущий момент" выводится через диапозон дат
Например:
Если в диапазоне дат с 10.01.2017 по 09.02.2017 есть долг то он выводится.
Но как только наступило 10.02.2017 то диапазон смотрится в промежутке с 10.01.2017 по 09.03.2017
К сообщению приложен файл: 5598744.xlsx(10Kb)


Сообщение отредактировал boulingist - Пятница, 09.06.2017, 09:45
 
Ответить
СообщениеПривет, уважаемые специалисты!
Есть задумка подсчета зп и долгов по ней, и хотелось бы узнать, на сколько она реализуема, если да, то как.
И так:
Есть таблица из пяти столбцов
Столбец 1 Месяцы
Столбец 2 Зарплата
Столбец 3 Выдано
Столбец 4 Долг по зп
Столбец 5 Дата.
Суть идеи вот такая:
Можно ли сделать так, что бы ексель подсчитывал долг не полность по столбцу, а по дате.
т.е. Если ЗП выдаётся каждого 10-го числа, то сумма долга выводится на текущий момент.
Другими словами Если до 10 июня 2017г был долг 1000руб. то показывается только этот долг (в промежутке дат с 10.01.2017 по 09.06.2017).
Но как только наступило 10 июня 2017 то долг автоматически (ексель видит дату) и меняется на такую формулу Долг+(зарплата-выдано)
В файле, я сделал как мог, но его надо прибрать. А именно:
Так как Июль, Август и другие месяца еще не наступили (точнее не наступило 10 число соответствующего месяца) то учета по этим месяцам не должно выводиться.

Если выразил мысль не достаточно понятно, задавайте вопросы... Сейчас я сформулировал как мог...

Или можно выразить мою мысль по другому:
В ячейке "долг на текущий момент" выводится через диапозон дат
Например:
Если в диапазоне дат с 10.01.2017 по 09.02.2017 есть долг то он выводится.
Но как только наступило 10.02.2017 то диапазон смотрится в промежутке с 10.01.2017 по 09.03.2017

Автор - boulingist
Дата добавления - 09.06.2017 в 09:20
AlexM Дата: Пятница, 09.06.2017, 10:08 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3560
Репутация: 898 ±
Замечаний: 0% ±

Excel 2003
Код
=ВПР(ТЕКСТ(СЕГОДНЯ();"ММММ");A3:D14;4;)
невнимательно прочитал задание. Скорее всего так нужно
Код
=ИНДЕКС(D2:D14;ПОИСКПОЗ(СЕГОДНЯ();E2:E14))
эта формула во втором файле
К сообщению приложен файл: 5598744_01.xlsx(9Kb) · 5598744_02.xlsx(9Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 09.06.2017, 10:19
 
Ответить
Сообщение
Код
=ВПР(ТЕКСТ(СЕГОДНЯ();"ММММ");A3:D14;4;)
невнимательно прочитал задание. Скорее всего так нужно
Код
=ИНДЕКС(D2:D14;ПОИСКПОЗ(СЕГОДНЯ();E2:E14))
эта формула во втором файле

Автор - AlexM
Дата добавления - 09.06.2017 в 10:08
boulingist Дата: Пятница, 09.06.2017, 11:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Спасибо!!!
Это именно то, что мне надо было!!!
 
Ответить
СообщениеСпасибо!!!
Это именно то, что мне надо было!!!

Автор - boulingist
Дата добавления - 09.06.2017 в 11:00
AlexM Дата: Пятница, 09.06.2017, 11:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3560
Репутация: 898 ±
Замечаний: 0% ±

Excel 2003
Первая формула или вторая?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПервая формула или вторая?

Автор - AlexM
Дата добавления - 09.06.2017 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как создать интеллектуальный подсчет з/п и долгов? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!