Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Фильтр только по содержанию только цифр. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Фильтр только по содержанию только цифр. (Формулы/Formulas)
Фильтр только по содержанию только цифр.
pinocioo Дата: Пятница, 16.06.2017, 14:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте форумчане.
Вопрос в следующем.
у меня есть таблица
____А____!________В__________________________________
01-0029A ! Проморолик "Русская ночь"
01-0035K ! ОТБИВКА "РЕКЛАМА НА КАНАЛЕ КОМЕДИЯ" с 16.09.09
01-143487! OTBIVKA_REKLAMA_4_SEC
01-143488! OTBIVKA_REKLAMA_5_SEC
01-144038! Promo_RussNoch_2013
01-173762! Mmenu_com_15sec
.......
всего 86к строк
необходимо провести выборку по столбцу "А" и оставить ячейки в которых присутствую буквы (тоесть скрыть/удалить ячейки в которых только цифры)

из приведеного примера оставить только
____А___!________В__________________________________
01-0029A! Проморолик "Русская ночь"
01-0035K! ОТБИВКА "РЕКЛАМА НА КАНАЛЕ КОМЕДИЯ" с 16.09.09
...
Возможно ли это сделать с помощью расширено фильтра, или необходимо писать макрос?
и если да, то посоветуйте чонить.
Я в экселе новичок.
Заранее благодарю всех за уделенное время.


это Йа!
 
Ответить
СообщениеЗдравствуйте форумчане.
Вопрос в следующем.
у меня есть таблица
____А____!________В__________________________________
01-0029A ! Проморолик "Русская ночь"
01-0035K ! ОТБИВКА "РЕКЛАМА НА КАНАЛЕ КОМЕДИЯ" с 16.09.09
01-143487! OTBIVKA_REKLAMA_4_SEC
01-143488! OTBIVKA_REKLAMA_5_SEC
01-144038! Promo_RussNoch_2013
01-173762! Mmenu_com_15sec
.......
всего 86к строк
необходимо провести выборку по столбцу "А" и оставить ячейки в которых присутствую буквы (тоесть скрыть/удалить ячейки в которых только цифры)

из приведеного примера оставить только
____А___!________В__________________________________
01-0029A! Проморолик "Русская ночь"
01-0035K! ОТБИВКА "РЕКЛАМА НА КАНАЛЕ КОМЕДИЯ" с 16.09.09
...
Возможно ли это сделать с помощью расширено фильтра, или необходимо писать макрос?
и если да, то посоветуйте чонить.
Я в экселе новичок.
Заранее благодарю всех за уделенное время.

Автор - pinocioo
Дата добавления - 16.06.2017 в 14:42
AlexM Дата: Пятница, 16.06.2017, 15:06 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Доп. столбец с формулой возможно подойдет.
Правила форума прочтите и поправьте сообщение.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДоп. столбец с формулой возможно подойдет.
Правила форума прочтите и поправьте сообщение.

Автор - AlexM
Дата добавления - 16.06.2017 в 15:06
pinocioo Дата: Пятница, 16.06.2017, 17:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доп. столбец с формулой возможно подойдет.

Спасибо за информацию. а как примерно будет выглядеть формула?


это Йа!
 
Ответить
Сообщение
Доп. столбец с формулой возможно подойдет.

Спасибо за информацию. а как примерно будет выглядеть формула?

Автор - pinocioo
Дата добавления - 16.06.2017 в 17:05
Pelena Дата: Пятница, 16.06.2017, 17:57 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11467
Репутация: 2546 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
pinocioo, файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеpinocioo, файл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 16.06.2017 в 17:57
AlexM Дата: Пятница, 16.06.2017, 18:32 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
как примерно будет выглядеть формула?
Могу рассказать.
Примерно так: отделить последний символ, потом, одним из многих способов определить, что этот символ не является буквой.
Протянув эту примерную формулу получим столбец значений буква/не буква (ИСТИНА/ЛОЖЬ, 1/0).
Автофильтром поэтому столбцу выбираем буквы.
Есть вариант без выделения последней буквы.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
как примерно будет выглядеть формула?
Могу рассказать.
Примерно так: отделить последний символ, потом, одним из многих способов определить, что этот символ не является буквой.
Протянув эту примерную формулу получим столбец значений буква/не буква (ИСТИНА/ЛОЖЬ, 1/0).
Автофильтром поэтому столбцу выбираем буквы.
Есть вариант без выделения последней буквы.

Автор - AlexM
Дата добавления - 16.06.2017 в 18:32
zs Дата: Пятница, 16.06.2017, 21:27 | Сообщение № 6
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Код
=ЕСЛИ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A6;"-";"");0;"");1;"");2;"");3;"");4;"");5;"");6;"");7;"");8;"");9;"")="";"";A6)
 
Ответить
Сообщение
Код
=ЕСЛИ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A6;"-";"");0;"");1;"");2;"");3;"");4;"");5;"");6;"");7;"");8;"");9;"")="";"";A6)

Автор - zs
Дата добавления - 16.06.2017 в 21:27
Nic70y Дата: Пятница, 16.06.2017, 21:43 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕЧИСЛО(-ПОДСТАВИТЬ(ЛЕВБ(A2;ПОИСК("!";A2)-1);"-";))
фильтр по ЛЖИ

zs, следуя Вашей логике
Код
=ЕСЛИ(ЕЧИСЛО(-A6);"";A6)
а точнее
Код
=ЕСЛИ(ЕЧИСЛО(-ПОДСТАВИТЬ(A6;"-";));"";A6)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 16.06.2017, 22:14
 
Ответить
Сообщение
Код
=ЕЧИСЛО(-ПОДСТАВИТЬ(ЛЕВБ(A2;ПОИСК("!";A2)-1);"-";))
фильтр по ЛЖИ

zs, следуя Вашей логике
Код
=ЕСЛИ(ЕЧИСЛО(-A6);"";A6)
а точнее
Код
=ЕСЛИ(ЕЧИСЛО(-ПОДСТАВИТЬ(A6;"-";));"";A6)

Автор - Nic70y
Дата добавления - 16.06.2017 в 21:43
AlexM Дата: Пятница, 16.06.2017, 22:14 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Nic70y, Символом "!" pinocioo рисовал таблицу, поэтому искать не имеет смысла.
PS. я из ТС файл вытягиваю, а тут ответы посыпались. :(



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеNic70y, Символом "!" pinocioo рисовал таблицу, поэтому искать не имеет смысла.
PS. я из ТС файл вытягиваю, а тут ответы посыпались. :(

Автор - AlexM
Дата добавления - 16.06.2017 в 22:14
Nic70y Дата: Пятница, 16.06.2017, 22:17 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
Алексей, у нас тут с zs просто соревнование у кого ответ более на бота похож...
такшо звиняй %)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеАлексей, у нас тут с zs просто соревнование у кого ответ более на бота похож...
такшо звиняй %)

Автор - Nic70y
Дата добавления - 16.06.2017 в 22:17
AlexM Дата: Пятница, 16.06.2017, 22:25 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Присоединюсь. ;)
Код
=ЕСЛИ(ПРАВБ(A6)<"A";"";A6)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 16.06.2017, 22:26
 
Ответить
СообщениеПрисоединюсь. ;)
Код
=ЕСЛИ(ПРАВБ(A6)<"A";"";A6)

Автор - AlexM
Дата добавления - 16.06.2017 в 22:25
Nic70y Дата: Пятница, 16.06.2017, 22:29 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
вот это класс %)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевот это класс %)

Автор - Nic70y
Дата добавления - 16.06.2017 в 22:29
AlexM Дата: Пятница, 16.06.2017, 22:33 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Nic70y, я же об этом писал
отделить последний символ, потом ... определить, что этот символ не является буквой.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеNic70y, я же об этом писал
отделить последний символ, потом ... определить, что этот символ не является буквой.

Автор - AlexM
Дата добавления - 16.06.2017 в 22:33
Nic70y Дата: Пятница, 16.06.2017, 22:38 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
Алексей, я погорячился
(днюха у жены - то се)
ответ не верный
следуя логике БОТА, а вдруг между числами буква!


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеАлексей, я погорячился
(днюха у жены - то се)
ответ не верный
следуя логике БОТА, а вдруг между числами буква!

Автор - Nic70y
Дата добавления - 16.06.2017 в 22:38
AlexM Дата: Пятница, 16.06.2017, 22:44 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
А вдруг не считается.
А вдруг электричество кончится или ПК упадет. Сортировка не получится. ;)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеА вдруг не считается.
А вдруг электричество кончится или ПК упадет. Сортировка не получится. ;)

Автор - AlexM
Дата добавления - 16.06.2017 в 22:44
Nic70y Дата: Пятница, 16.06.2017, 22:49 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
А вдруг
т.к. реклама запрещена на форуме,
конкретное место называть не буду,
но все решается,
т.к. я работаю подпольным продавцом энергии
и друг у меня лучший сиадмин севасии :)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
А вдруг
т.к. реклама запрещена на форуме,
конкретное место называть не буду,
но все решается,
т.к. я работаю подпольным продавцом энергии
и друг у меня лучший сиадмин севасии :)

Автор - Nic70y
Дата добавления - 16.06.2017 в 22:49
zs Дата: Суббота, 17.06.2017, 08:42 | Сообщение № 16
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
работает даже когда комп упадёт
Код
=ЕСЛИ(ДЛСТР(ПОДСТАВИТЬ(A2;"-";""))=СУММ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;{1;2;3;4;5;6;7;8;9;0};)));"";A2)

P.S. Не реклама
 
Ответить
Сообщениеработает даже когда комп упадёт
Код
=ЕСЛИ(ДЛСТР(ПОДСТАВИТЬ(A2;"-";""))=СУММ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;{1;2;3;4;5;6;7;8;9;0};)));"";A2)

P.S. Не реклама

Автор - zs
Дата добавления - 17.06.2017 в 08:42
gling Дата: Суббота, 17.06.2017, 08:55 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 1620
Репутация: 394 ±
Замечаний: 0% ±

2010
Здравствуйте!
а вдруг между числами буква!

Вариант, длинная формула получилась, мож кто сократит.
Код
=ЕСЛИ(СУММПРОИЗВ(--(КОДСИМВ(ПСТР(A1;СТРОКА(A1:ИНДЕКС(A1:A100;ДЛСТР(A1)));1))>58));A1;"")
Или по примеру Алексея (AlexM)
Код
=ЕСЛИ(СУММПРОИЗВ(--(ПСТР(A1;СТРОКА(A1:ИНДЕКС(A1:A100;ДЛСТР(A1)));1)>"A"));A1;"")
 
Ответить
СообщениеЗдравствуйте!
а вдруг между числами буква!

Вариант, длинная формула получилась, мож кто сократит.
Код
=ЕСЛИ(СУММПРОИЗВ(--(КОДСИМВ(ПСТР(A1;СТРОКА(A1:ИНДЕКС(A1:A100;ДЛСТР(A1)));1))>58));A1;"")
Или по примеру Алексея (AlexM)
Код
=ЕСЛИ(СУММПРОИЗВ(--(ПСТР(A1;СТРОКА(A1:ИНДЕКС(A1:A100;ДЛСТР(A1)));1)>"A"));A1;"")

Автор - gling
Дата добавления - 17.06.2017 в 08:55
AlexM Дата: Суббота, 17.06.2017, 08:57 | Сообщение № 18
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
gling, >= правильнее и закрепить А1
Код
=ЕСЛИ(СУММПРОИЗВ(--(ПСТР(A1;СТРОКА(A$1:ИНДЕКС(A$1:A100;ДЛСТР(A1)));1)>="A"));A1;"")
или можно так
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ПРАВБ(ЛЕВБ(A1;СТРОКА($1:$19)))>="A"));A1;"")
или
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ПСТР(A1;СТРОКА($1:$19);1)>="A"));A1;"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 17.06.2017, 09:13
 
Ответить
Сообщениеgling, >= правильнее и закрепить А1
Код
=ЕСЛИ(СУММПРОИЗВ(--(ПСТР(A1;СТРОКА(A$1:ИНДЕКС(A$1:A100;ДЛСТР(A1)));1)>="A"));A1;"")
или можно так
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ПРАВБ(ЛЕВБ(A1;СТРОКА($1:$19)))>="A"));A1;"")
или
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ПСТР(A1;СТРОКА($1:$19);1)>="A"));A1;"")

Автор - AlexM
Дата добавления - 17.06.2017 в 08:57
gling Дата: Суббота, 17.06.2017, 09:16 | Сообщение № 19
Группа: Друзья
Ранг: Старожил
Сообщений: 1620
Репутация: 394 ±
Замечаний: 0% ±

2010
AlexM, замечания правильные. Нет примера - нет проверки, от сюда и ошибки. Спасибо.
 
Ответить
СообщениеAlexM, замечания правильные. Нет примера - нет проверки, от сюда и ошибки. Спасибо.

Автор - gling
Дата добавления - 17.06.2017 в 09:16
AlexM Дата: Суббота, 17.06.2017, 09:17 | Сообщение № 20
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
zs, красиво, но работать не будет
ПОДСТАВИТЬ(A2;{1;2;3;4;5;6;7;8;9;0};)
Прошу прощения. ошибся. :(



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Суббота, 17.06.2017, 09:22
 
Ответить
Сообщениеzs, красиво, но работать не будет
ПОДСТАВИТЬ(A2;{1;2;3;4;5;6;7;8;9;0};)
Прошу прощения. ошибся. :(

Автор - AlexM
Дата добавления - 17.06.2017 в 09:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Фильтр только по содержанию только цифр. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!