Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Задача сравнить два диапазона ячеек, и вывести результат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задача сравнить два диапазона ячеек, и вывести результат (Формулы/Formulas)
Задача сравнить два диапазона ячеек, и вывести результат
skais Дата: Воскресенье, 18.06.2017, 21:13 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
Задача формулой сравнить два диапазона ячеек, и вывести результат если они одинаковы или нет.
Диапазоны к примеру A1:A10 и B1:B10. Нужен итоговой результат если они идентичны или нет.
 
Ответить
СообщениеЗадача формулой сравнить два диапазона ячеек, и вывести результат если они одинаковы или нет.
Диапазоны к примеру A1:A10 и B1:B10. Нужен итоговой результат если они идентичны или нет.

Автор - skais
Дата добавления - 18.06.2017 в 21:13
buchlotnik Дата: Воскресенье, 18.06.2017, 21:27 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
и вам здрасьте (массивка)
Код
=И(A1:A10=B1:B10)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеи вам здрасьте (массивка)
Код
=И(A1:A10=B1:B10)

Автор - buchlotnik
Дата добавления - 18.06.2017 в 21:27
Che79 Дата: Воскресенье, 18.06.2017, 21:39 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 599
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
skais, здравствуйте. См. файл. Результаты в желтой и зеленой ячейках (сделано на ИЛИ и И + формат ячеек) Пока файл делал (зачем?), Михаил Вам выше уже всё написал.
К сообщению приложен файл: 1221.xlsx(10Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 18.06.2017, 21:40
 
Ответить
Сообщениеskais, здравствуйте. См. файл. Результаты в желтой и зеленой ячейках (сделано на ИЛИ и И + формат ячеек) Пока файл делал (зачем?), Михаил Вам выше уже всё написал.

Автор - Che79
Дата добавления - 18.06.2017 в 21:39
skais Дата: Воскресенье, 18.06.2017, 21:43 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
Спасибо всем, эта формула мне нужна была для УФ не знаю если там работают формулы массива. Как вариант нашел и такое:
Код
=СУММПРОИЗВ(--(A1:A10<>B1:B10))>0


Сообщение отредактировал skais - Воскресенье, 18.06.2017, 21:43
 
Ответить
СообщениеСпасибо всем, эта формула мне нужна была для УФ не знаю если там работают формулы массива. Как вариант нашел и такое:
Код
=СУММПРОИЗВ(--(A1:A10<>B1:B10))>0

Автор - skais
Дата добавления - 18.06.2017 в 21:43
buchlotnik Дата: Воскресенье, 18.06.2017, 21:52 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
не знаю если там работают формулы массива
а проверить и убедиться?


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
не знаю если там работают формулы массива
а проверить и убедиться?

Автор - buchlotnik
Дата добавления - 18.06.2017 в 21:52
skais Дата: Понедельник, 19.06.2017, 08:54 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
buchlotnik, Проверил - возможность есть - в УФ формула массива вводится как обычная формула, работает!
Che79 - а как Вы сделали эти надписи одинаково и неодинаково? кроме формул ничего не вижу, а надписи и цвет есть!


Сообщение отредактировал skais - Понедельник, 19.06.2017, 09:15
 
Ответить
Сообщениеbuchlotnik, Проверил - возможность есть - в УФ формула массива вводится как обычная формула, работает!
Che79 - а как Вы сделали эти надписи одинаково и неодинаково? кроме формул ничего не вижу, а надписи и цвет есть!

Автор - skais
Дата добавления - 19.06.2017 в 08:54
buchlotnik Дата: Понедельник, 19.06.2017, 09:28 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
skais, Алексей (Che79) же написал
Цитата
сделано на ИЛИ и И + формат ячеек
посмотрите на формат внимательнее. Цвет - это просто заливка ячеек, но если хотите, чтобы слова окрашивались замените формат на [Зеленый]"Одинаково";;[Красный]"Не одинаково"


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 19.06.2017, 09:28
 
Ответить
Сообщениеskais, Алексей (Che79) же написал
Цитата
сделано на ИЛИ и И + формат ячеек
посмотрите на формат внимательнее. Цвет - это просто заливка ячеек, но если хотите, чтобы слова окрашивались замените формат на [Зеленый]"Одинаково";;[Красный]"Не одинаково"

Автор - buchlotnik
Дата добавления - 19.06.2017 в 09:28
skais Дата: Понедельник, 19.06.2017, 11:24 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
buchlotnik Спасибо! Даже не предполагал о таких возможностях формата.
 
Ответить
Сообщениеbuchlotnik Спасибо! Даже не предполагал о таких возможностях формата.

Автор - skais
Дата добавления - 19.06.2017 в 11:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задача сравнить два диапазона ячеек, и вывести результат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!