Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Варианты комбинаций с вариантыми ДА/НЕТ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Варианты комбинаций с вариантыми ДА/НЕТ (Иное/Other)
Варианты комбинаций с вариантыми ДА/НЕТ
SRIPIT Дата: Вторник, 20.06.2017, 14:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день
Необходима помощь, не могу сообразить как корректно проставить макрос.
Задача в след: 8 вопросов, 2 варианта ДА или НЕТ, как я посчитала выходит 256 вариантов, нужно чтоб представились все возможные варианты ответов.
пример во вложении[size=12][font=Times][color=black]
:facepalm:
К сообщению приложен файл: 1863234.xls(28Kb)
 
Ответить
СообщениеДобрый день
Необходима помощь, не могу сообразить как корректно проставить макрос.
Задача в след: 8 вопросов, 2 варианта ДА или НЕТ, как я посчитала выходит 256 вариантов, нужно чтоб представились все возможные варианты ответов.
пример во вложении[size=12][font=Times][color=black]
:facepalm:

Автор - SRIPIT
Дата добавления - 20.06.2017 в 14:45
vikttur Дата: Вторник, 20.06.2017, 14:51 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2263
Репутация: 389 ±
Замечаний: 0% ±

Каждому варианту - по ячейке :)
Код
=ТЕКСТ(ДЕС.В.ДВ(СТРОКА(A1)-1);"00000000")


Сообщение отредактировал vikttur - Вторник, 20.06.2017, 14:53
 
Ответить
СообщениеКаждому варианту - по ячейке :)
Код
=ТЕКСТ(ДЕС.В.ДВ(СТРОКА(A1)-1);"00000000")

Автор - vikttur
Дата добавления - 20.06.2017 в 14:51
SRIPIT Дата: Вторник, 20.06.2017, 15:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur, если честно не очень поняла как это будет.:facepalm: если не сложно можете пример скинуть... или более подробно описать %)
 
Ответить
Сообщениеvikttur, если честно не очень поняла как это будет.:facepalm: если не сложно можете пример скинуть... или более подробно описать %)

Автор - SRIPIT
Дата добавления - 20.06.2017 в 15:01
buchlotnik Дата: Вторник, 20.06.2017, 15:08 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2774
Репутация: 790 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
попаразитировал на формуле Виктора
Код
=ЕСЛИ(-ПСТР(ТЕКСТ(ДЕС.В.ДВ(СТРОКА(A1)-1);"00000000");B$1;1);"Д";"Н")
UPD чутка упростил
Код
=ЕСЛИ(-ПСТР(ДЕС.В.ДВ(СТРОКА(A1)-1;8);B$1;1);"Д";"Н")
К сообщению приложен файл: 1863234-1-.xlsb(21Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Вторник, 20.06.2017, 15:23
 
Ответить
Сообщениепопаразитировал на формуле Виктора
Код
=ЕСЛИ(-ПСТР(ТЕКСТ(ДЕС.В.ДВ(СТРОКА(A1)-1);"00000000");B$1;1);"Д";"Н")
UPD чутка упростил
Код
=ЕСЛИ(-ПСТР(ДЕС.В.ДВ(СТРОКА(A1)-1;8);B$1;1);"Д";"Н")

Автор - buchlotnik
Дата добавления - 20.06.2017 в 15:08
SRIPIT Дата: Вторник, 20.06.2017, 15:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, оооо, спасибо большущие :prof:
 
Ответить
Сообщениеbuchlotnik, оооо, спасибо большущие :prof:

Автор - SRIPIT
Дата добавления - 20.06.2017 в 15:14
AlexM Дата: Вторник, 20.06.2017, 15:41 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3559
Репутация: 898 ±
Замечаний: 0% ±

Excel 2003
Для любой версии Excel
Код
=ЕСЛИ(ОТБР(ОСТАТ($A2/2^(8-B$1);2));"Д";"Н")
или так
Код
=ЕСЛИ(ОСТАТ($A2/2^(8-B$1);2)>=1;"Д";"Н")
К сообщению приложен файл: Spirit_01.xlsx(25Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 20.06.2017, 15:46
 
Ответить
СообщениеДля любой версии Excel
Код
=ЕСЛИ(ОТБР(ОСТАТ($A2/2^(8-B$1);2));"Д";"Н")
или так
Код
=ЕСЛИ(ОСТАТ($A2/2^(8-B$1);2)>=1;"Д";"Н")

Автор - AlexM
Дата добавления - 20.06.2017 в 15:41
_Boroda_ Дата: Вторник, 20.06.2017, 15:52 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10830
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты похожие
Код
=ИНДЕКС({"Н":"Д"};ОСТАТ($A2/2^A$1;2)+1)

Код
=ПСТР("НД";ОСТАТ($A2/2^A$1;2)+1;1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты похожие
Код
=ИНДЕКС({"Н":"Д"};ОСТАТ($A2/2^A$1;2)+1)

Код
=ПСТР("НД";ОСТАТ($A2/2^A$1;2)+1;1)

Автор - _Boroda_
Дата добавления - 20.06.2017 в 15:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Варианты комбинаций с вариантыми ДА/НЕТ (Иное/Other)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!