Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод наименование журнала - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод наименование журнала (Формулы/Formulas)
Вывод наименование журнала
tweeker Дата: Четверг, 22.06.2017, 14:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток.
Обращался уже на этот форум и очень быстро мне помогли,прошу помощи еще раз :С
Нужно найти наименование журнала,принесшего наибольший доход в последнем месяц.


Т.е. нужно перемножить строку 8 со строкой 17,и найти наименование журнала,который больше всего принес прибыли.
Делаю такой код,но пишет,что слишком много аргументов :С

Код
=ИНДЕКС($A$2:$A$8;ПОИСКПОЗ(МАКС(B8*B17;C8*C17;D8*D17;E8*E17;F8*F17;G8*G17;H8*H17;I8*I17;J8*J17;K8*K17;L8*L17;M8*M17;N8*N17;O8*O17;P8*P17);B8*B17;C8*C17;D8*D17;E8*E17;F8*F17;G8*G17;H8*H17;I8*I17;J8*J17;K8*K17;L8*L17;M8*M17;N8*N17;O8*O17;P8*P17;0)

Сам файл
К сообщению приложен файл: _2.xlsm(32Kb)
 
Ответить
СообщениеВсем доброго времени суток.
Обращался уже на этот форум и очень быстро мне помогли,прошу помощи еще раз :С
Нужно найти наименование журнала,принесшего наибольший доход в последнем месяц.


Т.е. нужно перемножить строку 8 со строкой 17,и найти наименование журнала,который больше всего принес прибыли.
Делаю такой код,но пишет,что слишком много аргументов :С

Код
=ИНДЕКС($A$2:$A$8;ПОИСКПОЗ(МАКС(B8*B17;C8*C17;D8*D17;E8*E17;F8*F17;G8*G17;H8*H17;I8*I17;J8*J17;K8*K17;L8*L17;M8*M17;N8*N17;O8*O17;P8*P17);B8*B17;C8*C17;D8*D17;E8*E17;F8*F17;G8*G17;H8*H17;I8*I17;J8*J17;K8*K17;L8*L17;M8*M17;N8*N17;O8*O17;P8*P17;0)

Сам файл

Автор - tweeker
Дата добавления - 22.06.2017 в 14:41
AlexM Дата: Четверг, 22.06.2017, 15:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Код
=ПРОСМОТР(2;1/(МАКС(B8:P8*B17:P17)=B8:P8*B17:P17);B2:P2)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ПРОСМОТР(2;1/(МАКС(B8:P8*B17:P17)=B8:P8*B17:P17);B2:P2)

Автор - AlexM
Дата добавления - 22.06.2017 в 15:16
buchlotnik Дата: Четверг, 22.06.2017, 15:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2989
Репутация: 838 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ПРОСМОТР(;-1/(МАКС(B8:P8*B17:P17)=B8:P8*B17:P17);B2:P2)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 22.06.2017, 15:23
 
Ответить
Сообщение
Код
=ПРОСМОТР(;-1/(МАКС(B8:P8*B17:P17)=B8:P8*B17:P17);B2:P2)

Автор - buchlotnik
Дата добавления - 22.06.2017 в 15:19
Sancho Дата: Четверг, 22.06.2017, 15:34 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 181
Репутация: 10 ±
Замечаний: 0% ±

2007, 2010, 2013
дел


Сообщение отредактировал Sancho - Четверг, 22.06.2017, 15:41
 
Ответить
Сообщениедел

Автор - Sancho
Дата добавления - 22.06.2017 в 15:34
tweeker Дата: Четверг, 22.06.2017, 15:38 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое,да не поставил ни плюсов,ни репку,с этим экселем спешу,прошу прощения)
 
Ответить
СообщениеСпасибо большое,да не поставил ни плюсов,ни репку,с этим экселем спешу,прошу прощения)

Автор - tweeker
Дата добавления - 22.06.2017 в 15:38
tweeker Дата: Четверг, 22.06.2017, 15:39 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
UPD: не могу + и репу ставить,так как менее 24 зареган
 
Ответить
СообщениеUPD: не могу + и репу ставить,так как менее 24 зареган

Автор - tweeker
Дата добавления - 22.06.2017 в 15:39
Manyasha Дата: Четверг, 22.06.2017, 16:12 | Сообщение № 7
Группа: Модераторы
Ранг: Старожил
Сообщений: 1957
Репутация: 815 ±
Замечаний: 0% ±

Excel 2010, 2016
Sancho, накручивание репутации - это нарушение Правил форума, в следующий раз замечание будет.
tweeker, поставились, репутацию раз в сутки можно менять (репутация - это и есть плюсы).


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеSancho, накручивание репутации - это нарушение Правил форума, в следующий раз замечание будет.
tweeker, поставились, репутацию раз в сутки можно менять (репутация - это и есть плюсы).

Автор - Manyasha
Дата добавления - 22.06.2017 в 16:12
zs Дата: Четверг, 22.06.2017, 16:24 | Сообщение № 8
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Код
=ИНДЕКС(B1:P16;1;ПОИСКПОЗ(1;B7:P7*B16:P16/НАИБОЛЬШИЙ(B7:P7*B16:P16;1);0))

P.S. формула массива, первая строка таблицы-наименование журналов
 
Ответить
Сообщение
Код
=ИНДЕКС(B1:P16;1;ПОИСКПОЗ(1;B7:P7*B16:P16/НАИБОЛЬШИЙ(B7:P7*B16:P16;1);0))

P.S. формула массива, первая строка таблицы-наименование журналов

Автор - zs
Дата добавления - 22.06.2017 в 16:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод наименование журнала (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!