Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сумма сцепленных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма сцепленных ячеек (Формулы/Formulas)
сумма сцепленных ячеек
zs Дата: Пятница, 23.06.2017, 12:07 | Сообщение № 1
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
в столбце В знаки +,-; в столбце С числа-вопрос почему формула массива
Код
=СУММ(--($B$2:$B$11&C2:C11))

дает неправильный результат, считает минусовые значения дважды
 
Ответить
Сообщениев столбце В знаки +,-; в столбце С числа-вопрос почему формула массива
Код
=СУММ(--($B$2:$B$11&C2:C11))

дает неправильный результат, считает минусовые значения дважды

Автор - zs
Дата добавления - 23.06.2017 в 12:07
Nic70y Дата: Пятница, 23.06.2017, 12:12 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
все она правильно считает
Код
=СУММЕСЛИ($B$2:$B$11;"+";C2:C11)-СУММЕСЛИ($B$2:$B$11;"-";C2:C11)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевсе она правильно считает
Код
=СУММЕСЛИ($B$2:$B$11;"+";C2:C11)-СУММЕСЛИ($B$2:$B$11;"-";C2:C11)

Автор - Nic70y
Дата добавления - 23.06.2017 в 12:12
AndreTM Дата: Пятница, 23.06.2017, 12:14 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
Где дважды?

К сообщению приложен файл: 6570575.jpg(20Kb)


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
СообщениеГде дважды?


Автор - AndreTM
Дата добавления - 23.06.2017 в 12:14
AlexM Дата: Пятница, 23.06.2017, 12:27 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Еще не массивная формула
Код
=СУММ(СУММЕСЛИ($B$2:$B$11;{"+";"-"};C2:C11)*{1;-1})
и
Код
=СУММПРОИЗВ(--($B$2:$B$11&C2:C11))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 23.06.2017, 12:27
 
Ответить
СообщениеЕще не массивная формула
Код
=СУММ(СУММЕСЛИ($B$2:$B$11;{"+";"-"};C2:C11)*{1;-1})
и
Код
=СУММПРОИЗВ(--($B$2:$B$11&C2:C11))

Автор - AlexM
Дата добавления - 23.06.2017 в 12:27
zs Дата: Пятница, 23.06.2017, 12:50 | Сообщение № 5
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Еще ... формула

следует отметить, что суммпроизв считает ячейки, где вместо знака пусто, а сумм требует знака в каждой ячейке
 
Ответить
Сообщение
Еще ... формула

следует отметить, что суммпроизв считает ячейки, где вместо знака пусто, а сумм требует знака в каждой ячейке

Автор - zs
Дата добавления - 23.06.2017 в 12:50
AlexM Дата: Пятница, 23.06.2017, 13:00 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
zs, и сумм и суммпроизв считают одинаково, а формулы с суммесли иначе.
Показывайте файл с примерами.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеzs, и сумм и суммпроизв считают одинаково, а формулы с суммесли иначе.
Показывайте файл с примерами.

Автор - AlexM
Дата добавления - 23.06.2017 в 13:00
zs Дата: Суббота, 24.06.2017, 18:04 | Сообщение № 7
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Показывайте файл с примерами.

пример
К сообщению приложен файл: 0633891.jpg(23Kb)
 
Ответить
Сообщение
Показывайте файл с примерами.

пример

Автор - zs
Дата добавления - 24.06.2017 в 18:04
AndreTM Дата: Суббота, 24.06.2017, 18:45 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
Обращаю внимание на ваше же:
в столбце В знаки +,-

Про "пустые" ячейки вы в голове держали?
Телепаты, к сожалению, в отпуске...


Skype: andre.tm.007
Donate: Qiwi: 9517375010


Сообщение отредактировал AndreTM - Суббота, 24.06.2017, 18:55
 
Ответить
СообщениеОбращаю внимание на ваше же:
в столбце В знаки +,-

Про "пустые" ячейки вы в голове держали?
Телепаты, к сожалению, в отпуске...

Автор - AndreTM
Дата добавления - 24.06.2017 в 18:45
vikttur Дата: Суббота, 24.06.2017, 19:08 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2387
Репутация: 412 ±
Замечаний: 0% ±

Да и не пример это. Картинка.
 
Ответить
СообщениеДа и не пример это. Картинка.

Автор - vikttur
Дата добавления - 24.06.2017 в 19:08
zs Дата: Суббота, 24.06.2017, 19:55 | Сообщение № 10
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Обращаю внимание на ваше же:

AndreTM это не так критично, как проиграть кубок конфедерации
 
Ответить
Сообщение
Обращаю внимание на ваше же:

AndreTM это не так критично, как проиграть кубок конфедерации

Автор - zs
Дата добавления - 24.06.2017 в 19:55
Nic70y Дата: Суббота, 24.06.2017, 19:57 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
фиг с ним с кубком,
а вот это
не пример это. Картинка
критично


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениефиг с ним с кубком,
а вот это
не пример это. Картинка
критично

Автор - Nic70y
Дата добавления - 24.06.2017 в 19:57
zs Дата: Суббота, 24.06.2017, 20:03 | Сообщение № 12
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
пжт, файл,)
P.S.
vikttur, мне кажется нет разницы между скрином и файлом
К сообщению приложен файл: 0292923.xls(28Kb)


Сообщение отредактировал zs - Суббота, 24.06.2017, 20:17
 
Ответить
Сообщениепжт, файл,)
P.S.
vikttur, мне кажется нет разницы между скрином и файлом

Автор - zs
Дата добавления - 24.06.2017 в 20:03
Nic70y Дата: Суббота, 24.06.2017, 20:18 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
Вы серьезно?
или это прикол такой?
а формулы с суммесли иначе
что будет суммировать суммесли, если плюсов 0

Ваше же первая формула "идентична" суммпроизв %)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 24.06.2017, 20:20
 
Ответить
СообщениеВы серьезно?
или это прикол такой?
а формулы с суммесли иначе
что будет суммировать суммесли, если плюсов 0

Ваше же первая формула "идентична" суммпроизв %)

Автор - Nic70y
Дата добавления - 24.06.2017 в 20:18
AndreTM Дата: Суббота, 24.06.2017, 20:19 | Сообщение № 14
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
пжт, файл,)

Не пример это, а абзац.
Напомню:
в столбце В знаки +,-

Далее:


Нет, не понимает человек... Даже наказания не помогают... Может, по стандарту - всем скинуться минусами в репу?
Это я так от безысходности уже...
К сообщению приложен файл: 7049593.jpg(20Kb)


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
Сообщение
пжт, файл,)

Не пример это, а абзац.
Напомню:
в столбце В знаки +,-

Далее:


Нет, не понимает человек... Даже наказания не помогают... Может, по стандарту - всем скинуться минусами в репу?
Это я так от безысходности уже...

Автор - AndreTM
Дата добавления - 24.06.2017 в 20:19
zs Дата: Суббота, 24.06.2017, 20:29 | Сообщение № 15
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
в столбце В знаки +,-

а какая разница +,- или только -;
P.S. AndreTM действительно не понятно, к какому селу слово "абзац"
 
Ответить
Сообщение
в столбце В знаки +,-

а какая разница +,- или только -;
P.S. AndreTM действительно не понятно, к какому селу слово "абзац"

Автор - zs
Дата добавления - 24.06.2017 в 20:29
Nic70y Дата: Суббота, 24.06.2017, 20:40 | Сообщение № 16
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
какая разница
AlexM ответил в сообщении №6
дискуссию можно уже после этого прекратить.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
какая разница
AlexM ответил в сообщении №6
дискуссию можно уже после этого прекратить.

Автор - Nic70y
Дата добавления - 24.06.2017 в 20:40
AndreTM Дата: Суббота, 24.06.2017, 20:45 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
"Ба-а-альшая разница-а-а-а (тыгы-дым)" (с)

Осмелюсь ещё раз напомнить:
в столбце В знаки +,-
Никаких "пусто", "пробел", "ничего как плюс" :)

Кроме того, хотите ещё проблем? Их есть у меня: а если у вас "число" будет отрицательным, а перед ним ещё и "знак минус"? СЦЕПИТЬ() символьное значение и числовое даст вам символьное, и как вы будете считать в этом случае, например, "--5"?


Skype: andre.tm.007
Donate: Qiwi: 9517375010


Сообщение отредактировал AndreTM - Воскресенье, 25.06.2017, 11:19
 
Ответить
Сообщение"Ба-а-альшая разница-а-а-а (тыгы-дым)" (с)

Осмелюсь ещё раз напомнить:
в столбце В знаки +,-
Никаких "пусто", "пробел", "ничего как плюс" :)

Кроме того, хотите ещё проблем? Их есть у меня: а если у вас "число" будет отрицательным, а перед ним ещё и "знак минус"? СЦЕПИТЬ() символьное значение и числовое даст вам символьное, и как вы будете считать в этом случае, например, "--5"?

Автор - AndreTM
Дата добавления - 24.06.2017 в 20:45
vikttur Дата: Воскресенье, 25.06.2017, 00:19 | Сообщение № 18
Группа: Друзья
Ранг: Старожил
Сообщений: 2387
Репутация: 412 ±
Замечаний: 0% ±

удалено


Сообщение отредактировал vikttur - Воскресенье, 25.06.2017, 00:21
 
Ответить
Сообщениеудалено

Автор - vikttur
Дата добавления - 25.06.2017 в 00:19
zs Дата: Воскресенье, 25.06.2017, 11:32 | Сообщение № 19
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
а если у вас "число"

это уже (по правилам форума)) - другая тема))
 
Ответить
Сообщение
а если у вас "число"

это уже (по правилам форума)) - другая тема))

Автор - zs
Дата добавления - 25.06.2017 в 11:32
AndreTM Дата: Воскресенье, 25.06.2017, 12:04 | Сообщение № 20
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 496 ±
Замечаний: 0% ±

2003 & 2010
Неверно.

Позволю себе напомнить ещё раз:
в столбце С числа
Никаких указаний на то,что там только положительные числа - нет. :)


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
СообщениеНеверно.

Позволю себе напомнить ещё раз:
в столбце С числа
Никаких указаний на то,что там только положительные числа - нет. :)

Автор - AndreTM
Дата добавления - 25.06.2017 в 12:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма сцепленных ячеек (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!