Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с кол-вом дней на сегодня - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с кол-вом дней на сегодня (Формулы/Formulas)
Формула с кол-вом дней на сегодня
гала Дата: Вторник, 27.06.2017, 11:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Необходимо посчитать среднее значение, исходя из кол-ва дней с начала года.
Пример:
Код
=(B3+B4+B5+B6+B7+B8+B9+B10+B11+B12)/176
. Т.е суммируются показатели в единицах, и делятся на 176 дней (176 дней это с 1.01.2017 по 26.06.17г.)
Как прописать формулу, чтоб автоматически делилось на то кол-во дней в году, когда открываю файл (актуальная дата).
Открыла таблицу 26.06.17, у меня делится на 176 дней. Открыла 28.06.17 - делится на 178 дней. Прилагаю файл (ячейку для расчета выделила желтым)
Спасибо
К сообщению приложен файл: 4020620.xlsx(9Kb)


Сообщение отредактировал гала - Вторник, 27.06.2017, 12:57
 
Ответить
СообщениеДобрый день.
Необходимо посчитать среднее значение, исходя из кол-ва дней с начала года.
Пример:
Код
=(B3+B4+B5+B6+B7+B8+B9+B10+B11+B12)/176
. Т.е суммируются показатели в единицах, и делятся на 176 дней (176 дней это с 1.01.2017 по 26.06.17г.)
Как прописать формулу, чтоб автоматически делилось на то кол-во дней в году, когда открываю файл (актуальная дата).
Открыла таблицу 26.06.17, у меня делится на 176 дней. Открыла 28.06.17 - делится на 178 дней. Прилагаю файл (ячейку для расчета выделила желтым)
Спасибо

Автор - гала
Дата добавления - 27.06.2017 в 11:53
гала Дата: Вторник, 27.06.2017, 12:56 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Приложила файл. Спасибо
 
Ответить
СообщениеПриложила файл. Спасибо

Автор - гала
Дата добавления - 27.06.2017 в 12:56
zs Дата: Вторник, 27.06.2017, 13:02 | Сообщение № 3
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Код
=СЕГОДНЯ()

минус первоначальная дата


Сообщение отредактировал zs - Вторник, 27.06.2017, 13:04
 
Ответить
Сообщение
Код
=СЕГОДНЯ()

минус первоначальная дата

Автор - zs
Дата добавления - 27.06.2017 в 13:02
vikttur Дата: Вторник, 27.06.2017, 13:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2522
Репутация: 452 ±
Замечаний: 0% ±

Код
=Сумм(B3:B12)/(СЕГОДНЯ()-ДАТА(ГОД(СЕГОДНЯ());1;1))

Функцию СЕГОДНЯ(TODAY) лучше вывести в отдельную ячейку.


Сообщение отредактировал vikttur - Вторник, 27.06.2017, 13:09
 
Ответить
Сообщение
Код
=Сумм(B3:B12)/(СЕГОДНЯ()-ДАТА(ГОД(СЕГОДНЯ());1;1))

Функцию СЕГОДНЯ(TODAY) лучше вывести в отдельную ячейку.

Автор - vikttur
Дата добавления - 27.06.2017 в 13:08
китин Дата: Вторник, 27.06.2017, 13:10 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4421
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СУММ(B3:B12)/РАЗНДАТ(ДАТА(2017;1;1);СЕГОДНЯ();"d")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=СУММ(B3:B12)/РАЗНДАТ(ДАТА(2017;1;1);СЕГОДНЯ();"d")

Автор - китин
Дата добавления - 27.06.2017 в 13:10
and_evg Дата: Вторник, 27.06.2017, 13:12 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 230
Репутация: 40 ±
Замечаний: 0% ±

Excel 2007
Код
=(B3+B4+B5+B6+B7+B8+B9+B10+B11+B12)/(СЕГОДНЯ()-ДАТА(ГОД(СЕГОДНЯ());1;1)-1)
 
Ответить
Сообщение
Код
=(B3+B4+B5+B6+B7+B8+B9+B10+B11+B12)/(СЕГОДНЯ()-ДАТА(ГОД(СЕГОДНЯ());1;1)-1)

Автор - and_evg
Дата добавления - 27.06.2017 в 13:12
_Boroda_ Дата: Вторник, 27.06.2017, 13:14 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще
Код
=СУММ(B3:B12)/(СЕГОДНЯ()-1-(1&-ГОД(СЕГОДНЯ())))

Код
=СУММ(B3:B12)/(СЕГОДНЯ()-1-(1&-ГОД(ТДАТА())))

Код
=СУММ(B3:B12)/(СЕГОДНЯ()-2-КОНМЕСЯЦА(СЕГОДНЯ();-МЕСЯЦ(СЕГОДНЯ())))

Позвольте, а почему "176 - колво дней с 01.01.2017 по 26.06.17"?
с 01.01.2017 по 26.06.17 177 дней
01.01 мы считаем, правильно?
Поскольку вопрос был задан 27 июня днем, а в тексте вопроса фигурирует 26 июня, то и его (26 июня) нужно считать. Тогда получается 177 дней


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще
Код
=СУММ(B3:B12)/(СЕГОДНЯ()-1-(1&-ГОД(СЕГОДНЯ())))

Код
=СУММ(B3:B12)/(СЕГОДНЯ()-1-(1&-ГОД(ТДАТА())))

Код
=СУММ(B3:B12)/(СЕГОДНЯ()-2-КОНМЕСЯЦА(СЕГОДНЯ();-МЕСЯЦ(СЕГОДНЯ())))

Позвольте, а почему "176 - колво дней с 01.01.2017 по 26.06.17"?
с 01.01.2017 по 26.06.17 177 дней
01.01 мы считаем, правильно?
Поскольку вопрос был задан 27 июня днем, а в тексте вопроса фигурирует 26 июня, то и его (26 июня) нужно считать. Тогда получается 177 дней

Автор - _Boroda_
Дата добавления - 27.06.2017 в 13:14
гала Дата: Вторник, 27.06.2017, 14:16 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
да,177 день. Ошиблась.

Всем большое спасибо! :)
 
Ответить
Сообщениеда,177 день. Ошиблась.

Всем большое спасибо! :)

Автор - гала
Дата добавления - 27.06.2017 в 14:16
_Boroda_ Дата: Вторник, 27.06.2017, 14:36 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда единичку нужно прибавить
Код
=СУММ(B3:B12)/(СЕГОДНЯ()-(1&-ГОД(ТДАТА())))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда единичку нужно прибавить
Код
=СУММ(B3:B12)/(СЕГОДНЯ()-(1&-ГОД(ТДАТА())))

Автор - _Boroda_
Дата добавления - 27.06.2017 в 14:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с кол-вом дней на сегодня (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!