Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула по поиску данных в горизонтальном диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула по поиску данных в горизонтальном диапазоне (Формулы/Formulas)
формула по поиску данных в горизонтальном диапазоне
Speedy Дата: Воскресенье, 02.07.2017, 18:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
добрый вечер!
сломала голову... не могу найти формулу, которая подтянет инфо:
два листа - план и задание
на листе план указаны № операций 1.1, 1.2, 1.3. стоят они либо в столбце А, либо в С
как подтянуть к № операции в листе задание изделие, если номер операции на листе план может стоять либо в столбце А, либо в С
К сообщению приложен файл: 1362316.xlsx(9Kb)


Сообщение отредактировал Speedy - Воскресенье, 02.07.2017, 18:16
 
Ответить
Сообщениедобрый вечер!
сломала голову... не могу найти формулу, которая подтянет инфо:
два листа - план и задание
на листе план указаны № операций 1.1, 1.2, 1.3. стоят они либо в столбце А, либо в С
как подтянуть к № операции в листе задание изделие, если номер операции на листе план может стоять либо в столбце А, либо в С

Автор - Speedy
Дата добавления - 02.07.2017 в 18:14
Pelena Дата: Воскресенье, 02.07.2017, 18:45 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11756
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(план!$E$2:$E$4;ЕСЛИОШИБКА(ПОИСКПОЗ(A2;план!$A$2:$A$4;0);ПОИСКПОЗ(A2;план!$C$2:$C$4;0)));"")
К сообщению приложен файл: 9387199.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(план!$E$2:$E$4;ЕСЛИОШИБКА(ПОИСКПОЗ(A2;план!$A$2:$A$4;0);ПОИСКПОЗ(A2;план!$C$2:$C$4;0)));"")

Автор - Pelena
Дата добавления - 02.07.2017 в 18:45
Speedy Дата: Воскресенье, 02.07.2017, 18:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ОГРОМНОЕ СПАСИБО!!!!!! ВЫ ЛУЧШИЕ!!!!!!!!!!!!! ))
 
Ответить
СообщениеОГРОМНОЕ СПАСИБО!!!!!! ВЫ ЛУЧШИЕ!!!!!!!!!!!!! ))

Автор - Speedy
Дата добавления - 02.07.2017 в 18:50
_Boroda_ Дата: Воскресенье, 02.07.2017, 18:50 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(A2=план!A$2:A$9&план!C$2:C$9);план!E$2:E$9);"")
К сообщению приложен файл: 1362316_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(A2=план!A$2:A$9&план!C$2:C$9);план!E$2:E$9);"")

Автор - _Boroda_
Дата добавления - 02.07.2017 в 18:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула по поиску данных в горизонтальном диапазоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!