Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставить значения столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить значения столбцов (Формулы/Formulas)
Сопоставить значения столбцов
Ragnar_ok Дата: Понедельник, 03.07.2017, 08:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Первый столбец содержит e-mail-адреса. Второй столбец частично повторяет первый, но порядок данных нарушен, а некоторые e-mail, присутствующие в первом столбце, отсутствуют во втором. Третий столбец содержит уникальный id, соответствующий e-mail из второго столбца. Нужно присвоить e-mail'ам из первого столбца соответствующий ему ID. Прикрепляю пример.
К сообщению приложен файл: 2024984.xlsx(8Kb)


Сообщение отредактировал Ragnar_ok - Понедельник, 03.07.2017, 08:50
 
Ответить
СообщениеПервый столбец содержит e-mail-адреса. Второй столбец частично повторяет первый, но порядок данных нарушен, а некоторые e-mail, присутствующие в первом столбце, отсутствуют во втором. Третий столбец содержит уникальный id, соответствующий e-mail из второго столбца. Нужно присвоить e-mail'ам из первого столбца соответствующий ему ID. Прикрепляю пример.

Автор - Ragnar_ok
Дата добавления - 03.07.2017 в 08:38
vikttur Дата: Понедельник, 03.07.2017, 08:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

Код
=ЕСЛИОШИБКА(ВПР(A2;$B$2:$C$6;2;);"")
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(A2;$B$2:$C$6;2;);"")

Автор - vikttur
Дата добавления - 03.07.2017 в 08:43
Ragnar_ok Дата: Понедельник, 03.07.2017, 09:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Выводит #ИМЯ?. Ознакомился с формулами, проверил синтаксис. Не понимаю почему не работает.
К сообщению приложен файл: 1-.xlsx(9Kb)
 
Ответить
СообщениеВыводит #ИМЯ?. Ознакомился с формулами, проверил синтаксис. Не понимаю почему не работает.

Автор - Ragnar_ok
Дата добавления - 03.07.2017 в 09:07
buchlotnik Дата: Понедельник, 03.07.2017, 09:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Не понимаю почему не работает
видимо из-за Excel 2003, попробуйте так:
Код
=ЕСЛИ(ЕОШИБКА(ВПР(A2;$B$2:$C$6;2;));"";ВПР(A2;$B$2:$C$6;2;))
К сообщению приложен файл: 7549777.xlsx(10Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 03.07.2017, 09:17
 
Ответить
Сообщение
Цитата
Не понимаю почему не работает
видимо из-за Excel 2003, попробуйте так:
Код
=ЕСЛИ(ЕОШИБКА(ВПР(A2;$B$2:$C$6;2;));"";ВПР(A2;$B$2:$C$6;2;))

Автор - buchlotnik
Дата добавления - 03.07.2017 в 09:17
vikttur Дата: Понедельник, 03.07.2017, 09:22 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

видимо из-за Excel 2003

Фал-пример в первом сообщении совсем не из-под Excel-2003
 
Ответить
Сообщение
видимо из-за Excel 2003

Фал-пример в первом сообщении совсем не из-под Excel-2003

Автор - vikttur
Дата добавления - 03.07.2017 в 09:22
buchlotnik Дата: Понедельник, 03.07.2017, 09:48 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3328
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
[offtop]
Цитата
совсем не из-под Excel-2003
ну как сказать :
К сообщению приложен файл: 3156480.jpg(77Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 03.07.2017, 09:49
 
Ответить
Сообщение[offtop]
Цитата
совсем не из-под Excel-2003
ну как сказать :

Автор - buchlotnik
Дата добавления - 03.07.2017 в 09:48
Ragnar_ok Дата: Понедельник, 03.07.2017, 10:13 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Спасибо! Проблема действительно в том, что у меня установлен 2003 excel.


Сообщение отредактировал Ragnar_ok - Понедельник, 03.07.2017, 10:14
 
Ответить
СообщениеСпасибо! Проблема действительно в том, что у меня установлен 2003 excel.

Автор - Ragnar_ok
Дата добавления - 03.07.2017 в 10:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить значения столбцов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!