Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простая формула с ИНДЕКС и ПОИСКПОЗ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простая формула с ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
Простая формула с ИНДЕКС и ПОИСКПОЗ
heaven33rus Дата: Четверг, 06.07.2017, 22:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Миллион раз применял данную формулу

Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10))


Но по какой-то причине в одном частном случае она работает крайне странно, половину значений находит правильно, а для второй половины начинает выбирать не то, что должна. (см.файл пример)
Красным подсветил те строки, в которых формула работает не верно.

Подскажите с чем это связанно?
К сообщению приложен файл: _-.xlsx(11Kb)
 
Ответить
СообщениеМиллион раз применял данную формулу

Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10))


Но по какой-то причине в одном частном случае она работает крайне странно, половину значений находит правильно, а для второй половины начинает выбирать не то, что должна. (см.файл пример)
Красным подсветил те строки, в которых формула работает не верно.

Подскажите с чем это связанно?

Автор - heaven33rus
Дата добавления - 06.07.2017 в 22:00
_Boroda_ Дата: Четверг, 06.07.2017, 22:03 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
С тем, что в ПОИСКПОЗ у Вас нет третьего аргумента. После С10 поставьте точку с запятой
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;0))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;ЛОЖЬ))

Все это одно и то же


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеС тем, что в ПОИСКПОЗ у Вас нет третьего аргумента. После С10 поставьте точку с запятой
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;0))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;ЛОЖЬ))

Все это одно и то же

Автор - _Boroda_
Дата добавления - 06.07.2017 в 22:03
jakim Дата: Четверг, 06.07.2017, 22:08 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 786
Репутация: 205 ±
Замечаний: 0% ±

Код
=INDEX($F$3:$F$10;MATCH(H5;$C$3:$C$10;0))


Сообщение отредактировал jakim - Четверг, 06.07.2017, 22:09
 
Ответить
Сообщение
Код
=INDEX($F$3:$F$10;MATCH(H5;$C$3:$C$10;0))

Автор - jakim
Дата добавления - 06.07.2017 в 22:08
heaven33rus Дата: Четверг, 06.07.2017, 22:22 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
_Boroda_, jakim,
Спасибо, это уже называется глаз замылился :-)
 
Ответить
Сообщение_Boroda_, jakim,
Спасибо, это уже называется глаз замылился :-)

Автор - heaven33rus
Дата добавления - 06.07.2017 в 22:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простая формула с ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!