Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простая формула с ИНДЕКС и ПОИСКПОЗ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простая формула с ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
Простая формула с ИНДЕКС и ПОИСКПОЗ
heaven33rus Дата: Четверг, 06.07.2017, 22:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Миллион раз применял данную формулу

Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10))


Но по какой-то причине в одном частном случае она работает крайне странно, половину значений находит правильно, а для второй половины начинает выбирать не то, что должна. (см.файл пример)
Красным подсветил те строки, в которых формула работает не верно.

Подскажите с чем это связанно?
К сообщению приложен файл: _-.xlsx(11Kb)
 
Ответить
СообщениеМиллион раз применял данную формулу

Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10))


Но по какой-то причине в одном частном случае она работает крайне странно, половину значений находит правильно, а для второй половины начинает выбирать не то, что должна. (см.файл пример)
Красным подсветил те строки, в которых формула работает не верно.

Подскажите с чем это связанно?

Автор - heaven33rus
Дата добавления - 06.07.2017 в 22:00
_Boroda_ Дата: Четверг, 06.07.2017, 22:03 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11666
Репутация: 4833 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
С тем, что в ПОИСКПОЗ у Вас нет третьего аргумента. После С10 поставьте точку с запятой
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;0))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;ЛОЖЬ))

Все это одно и то же


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеС тем, что в ПОИСКПОЗ у Вас нет третьего аргумента. После С10 поставьте точку с запятой
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;0))

или
Код
=ИНДЕКС($F$3:$F$10;ПОИСКПОЗ(H5;$C$3:$C$10;ЛОЖЬ))

Все это одно и то же

Автор - _Boroda_
Дата добавления - 06.07.2017 в 22:03
jakim Дата: Четверг, 06.07.2017, 22:08 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 808
Репутация: 209 ±
Замечаний: 0% ±

Код
=INDEX($F$3:$F$10;MATCH(H5;$C$3:$C$10;0))


Сообщение отредактировал jakim - Четверг, 06.07.2017, 22:09
 
Ответить
Сообщение
Код
=INDEX($F$3:$F$10;MATCH(H5;$C$3:$C$10;0))

Автор - jakim
Дата добавления - 06.07.2017 в 22:08
heaven33rus Дата: Четверг, 06.07.2017, 22:22 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
_Boroda_, jakim,
Спасибо, это уже называется глаз замылился :-)
 
Ответить
Сообщение_Boroda_, jakim,
Спасибо, это уже называется глаз замылился :-)

Автор - heaven33rus
Дата добавления - 06.07.2017 в 22:22
Kemmi Дата: Пятница, 25.08.2017, 13:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте,помогите решить вот эту задачу (см. приложение)

Если две таблицы с разными наименованиями, но с одинаковыми значениями (для каждой таблицы значение свое; то есть всего два значения)

Нужно сделать третью таблицу в которой будет собраны все наименования вразброс; соответственно значения должны быть из первых двух таблиц)

Таблицы расположены на разных листах и на разных уровнях, для удобства свел таблицы в один лист. Мне главное формулу для получения третьей таблицы.

Заранее спасибо откликнувшимся
К сообщению приложен файл: DOC.xls(36Kb)
 
Ответить
СообщениеЗдравствуйте,помогите решить вот эту задачу (см. приложение)

Если две таблицы с разными наименованиями, но с одинаковыми значениями (для каждой таблицы значение свое; то есть всего два значения)

Нужно сделать третью таблицу в которой будет собраны все наименования вразброс; соответственно значения должны быть из первых двух таблиц)

Таблицы расположены на разных листах и на разных уровнях, для удобства свел таблицы в один лист. Мне главное формулу для получения третьей таблицы.

Заранее спасибо откликнувшимся

Автор - Kemmi
Дата добавления - 25.08.2017 в 13:29
китин Дата: Пятница, 25.08.2017, 13:37 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4419
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Kemmi, а почему в чужой теме? тут вам никто не ответит


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеKemmi, а почему в чужой теме? тут вам никто не ответит

Автор - китин
Дата добавления - 25.08.2017 в 13:37
Kemmi Дата: Пятница, 25.08.2017, 13:44 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, подскажите тему)))
просто я пытался её решить с помощью ИНДЕКС и ПОИСКПОЗ
 
Ответить
Сообщениекитин, подскажите тему)))
просто я пытался её решить с помощью ИНДЕКС и ПОИСКПОЗ

Автор - Kemmi
Дата добавления - 25.08.2017 в 13:44
китин Дата: Пятница, 25.08.2017, 13:52 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4419
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Kemmi, просто создайте свою тему с вашим вопросом. а то ведь щаз придут наши добрейшей души модераторы и закроют тему(эту) а вам влепят замечание


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеKemmi, просто создайте свою тему с вашим вопросом. а то ведь щаз придут наши добрейшей души модераторы и закроют тему(эту) а вам влепят замечание

Автор - китин
Дата добавления - 25.08.2017 в 13:52
Kemmi Дата: Пятница, 25.08.2017, 13:54 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
окай спасибо
 
Ответить
Сообщениеокай спасибо

Автор - Kemmi
Дата добавления - 25.08.2017 в 13:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простая формула с ИНДЕКС и ПОИСКПОЗ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!