Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести следующее по порядку значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести следующее по порядку значение (Формулы/Formulas)
Вывести следующее по порядку значение
zegor Дата: Пятница, 07.07.2017, 11:05 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Прошу помощи. Есть огромный массив A1:BX35 на листе Two (на самом деле он больше, повырезал всё что только можно, включая формулы, дабы объёмом файлика соответствовать правилам) из которого следует копировать данные по двум критериям на лист One в массив H:I. С этой задачей отлично справляются формулы
Код
=ЕСЛИОШИБКА(ВПР(B2;ИНДЕКС(Two!B$2:BP$2;ПОИСКПОЗ(A2;Two!A$1:BO$1;)):ИНДЕКС(Two!J$50:BX$50;ПОИСКПОЗ(A2;Two!A$1:BO$1;));9;);"")

Код
=ЕСЛИОШИБКА(ВПР(A2;ИНДЕКС(Two!A$2:BO$2;ПОИСКПОЗ(B2;Two!A$1:BO$1;)):ИНДЕКС(Two!J$50:BX$50;ПОИСКПОЗ(B2;Two!A$1:BO$1;));10;);"")

В строке 308 пара Alois-Andy встречается ещё раз. Возникла проблема выдачи "устаревших" данных. Работающая формула находит первое соответствие паре и выдает результаты которые теперь не актуальны.

Спасибо _Boroda_ за помощь в выборе верного направления
К сообщению приложен файл: help_2.xlsb(53Kb)


Сообщение отредактировал zegor - Пятница, 07.07.2017, 11:51
 
Ответить
СообщениеЗдравствуйте. Прошу помощи. Есть огромный массив A1:BX35 на листе Two (на самом деле он больше, повырезал всё что только можно, включая формулы, дабы объёмом файлика соответствовать правилам) из которого следует копировать данные по двум критериям на лист One в массив H:I. С этой задачей отлично справляются формулы
Код
=ЕСЛИОШИБКА(ВПР(B2;ИНДЕКС(Two!B$2:BP$2;ПОИСКПОЗ(A2;Two!A$1:BO$1;)):ИНДЕКС(Two!J$50:BX$50;ПОИСКПОЗ(A2;Two!A$1:BO$1;));9;);"")

Код
=ЕСЛИОШИБКА(ВПР(A2;ИНДЕКС(Two!A$2:BO$2;ПОИСКПОЗ(B2;Two!A$1:BO$1;)):ИНДЕКС(Two!J$50:BX$50;ПОИСКПОЗ(B2;Two!A$1:BO$1;));10;);"")

В строке 308 пара Alois-Andy встречается ещё раз. Возникла проблема выдачи "устаревших" данных. Работающая формула находит первое соответствие паре и выдает результаты которые теперь не актуальны.

Спасибо _Boroda_ за помощь в выборе верного направления

Автор - zegor
Дата добавления - 07.07.2017 в 11:05
_Boroda_ Дата: Пятница, 07.07.2017, 11:26 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11666
Репутация: 4833 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Имена смотрите в именованных диапазонах - Контрл F3
И сдается мне, что предыдущая формула (моя же, кстати) не совсем правильно считала
К сообщению приложен файл: help_3.xlsb(51Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Имена смотрите в именованных диапазонах - Контрл F3
И сдается мне, что предыдущая формула (моя же, кстати) не совсем правильно считала

Автор - _Boroda_
Дата добавления - 07.07.2017 в 11:26
zegor Дата: Пятница, 07.07.2017, 11:42 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Не совсем то. Буду косноязычить, не взыщите. Таблица растущая, одинаковые пары могут встречаться и по пять раз. В каждом случае должны быть свои данные (как есть сверху вниз).

1. Alois-Andy 1,18 : 0,24
2. Alois-Andy -0,96 : 0,23

Если пары (любые пары) встречаются снова то для каждой будут свои значения с листа Two.

3. Alois-Andy 1,16 : 0,03

Добавил третий случай. Формула Ваша, это правда.
К сообщению приложен файл: 5147302.xlsb(50Kb)


Сообщение отредактировал zegor - Пятница, 07.07.2017, 11:43
 
Ответить
СообщениеНе совсем то. Буду косноязычить, не взыщите. Таблица растущая, одинаковые пары могут встречаться и по пять раз. В каждом случае должны быть свои данные (как есть сверху вниз).

1. Alois-Andy 1,18 : 0,24
2. Alois-Andy -0,96 : 0,23

Если пары (любые пары) встречаются снова то для каждой будут свои значения с листа Two.

3. Alois-Andy 1,16 : 0,03

Добавил третий случай. Формула Ваша, это правда.

Автор - zegor
Дата добавления - 07.07.2017 в 11:42
_Boroda_ Дата: Пятница, 07.07.2017, 11:48 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11666
Репутация: 4833 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А, ну тогда Вам нужно не нижнее значение, а следующее по порядку? Если пара встречается 3 раза, то в первый раз нужно вывести первое значение, второй- второе, третий - третье? Или как?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА, ну тогда Вам нужно не нижнее значение, а следующее по порядку? Если пара встречается 3 раза, то в первый раз нужно вывести первое значение, второй- второе, третий - третье? Или как?

Автор - _Boroda_
Дата добавления - 07.07.2017 в 11:48
zegor Дата: Пятница, 07.07.2017, 11:50 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, то что нужно) Название темы поправил.
 
Ответить
Сообщение_Boroda_, то что нужно) Название темы поправил.

Автор - zegor
Дата добавления - 07.07.2017 в 11:50
_Boroda_ Дата: Пятница, 07.07.2017, 11:58 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11666
Репутация: 4833 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так. Формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(izA;НАИМЕНЬШИЙ(ЕСЛИ((A2=AvA)*(B2=AvB);СТРОКА(izA)-1);СЧЁТЕСЛИМН(A$1:A2;A2;B$1:B2;B2)));"")
К сообщению приложен файл: 5147302_1.xlsb(63Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так. Формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(izA;НАИМЕНЬШИЙ(ЕСЛИ((A2=AvA)*(B2=AvB);СТРОКА(izA)-1);СЧЁТЕСЛИМН(A$1:A2;A2;B$1:B2;B2)));"")

Автор - _Boroda_
Дата добавления - 07.07.2017 в 11:58
zegor Дата: Пятница, 07.07.2017, 12:02 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 71
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, hands Спасибо за помощь. Но самое большое СПАСИБО за терпение ко мне неразумному. Вы очень хороший человек.
 
Ответить
Сообщение_Boroda_, hands Спасибо за помощь. Но самое большое СПАСИБО за терпение ко мне неразумному. Вы очень хороший человек.

Автор - zegor
Дата добавления - 07.07.2017 в 12:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести следующее по порядку значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!