Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск минимальной стоимости - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск минимальной стоимости (Формулы/Formulas)
Поиск минимальной стоимости
FreeZe Дата: Среда, 12.07.2017, 15:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

Есть такая задача, цена на продукцию, которая меняется в зависимости от времени покупки(условно утром купить дешевле, вечером дороже), есть необходимое количество единиц (эти данные меняются в зависимости от потребностей в закупке). Нужна формула (неважно, формула, макрос, поиск условий), с помощью которой можно определить минимальную стоимость закупки (купить требуемое количество единиц по минимальной цене), но есть условие, что по умолчанию по указанной цене можно купить только 1 единицу продукции.

Заранее спасибо )
К сообщению приложен файл: 1207_.xls(24Kb)


Сообщение отредактировал FreeZe - Среда, 12.07.2017, 16:00
 
Ответить
СообщениеДобрый день.

Есть такая задача, цена на продукцию, которая меняется в зависимости от времени покупки(условно утром купить дешевле, вечером дороже), есть необходимое количество единиц (эти данные меняются в зависимости от потребностей в закупке). Нужна формула (неважно, формула, макрос, поиск условий), с помощью которой можно определить минимальную стоимость закупки (купить требуемое количество единиц по минимальной цене), но есть условие, что по умолчанию по указанной цене можно купить только 1 единицу продукции.

Заранее спасибо )

Автор - FreeZe
Дата добавления - 12.07.2017 в 15:59
sboy Дата: Среда, 12.07.2017, 16:20 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Проверяйте
Код
=СУММПРОИЗВ(НАИМЕНЬШИЙ(D4:K4;СТРОКА(ДВССЫЛ("A1:A"&M4))))
К сообщению приложен файл: 9329614.xls(24Kb)
 
Ответить
СообщениеДобрый день.
Проверяйте
Код
=СУММПРОИЗВ(НАИМЕНЬШИЙ(D4:K4;СТРОКА(ДВССЫЛ("A1:A"&M4))))

Автор - sboy
Дата добавления - 12.07.2017 в 16:20
FreeZe Дата: Среда, 12.07.2017, 16:31 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, спасибо, буду тестить на своих массивах данных.

Если у меня цена в столбце, то я меняю в формуле СТРОКА на СТОЛБЕЦ, а далее ДВССЫЛ и логическое выражение - как его расшифровать? Пытаюсь преобразовать.
 
Ответить
Сообщениеsboy, спасибо, буду тестить на своих массивах данных.

Если у меня цена в столбце, то я меняю в формуле СТРОКА на СТОЛБЕЦ, а далее ДВССЫЛ и логическое выражение - как его расшифровать? Пытаюсь преобразовать.

Автор - FreeZe
Дата добавления - 12.07.2017 в 16:31
sboy Дата: Среда, 12.07.2017, 16:40 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
FreeZe, диапазон цен в первом аргументе функции Наименьший(), в примере это D4:K4
Строка(...&M4) отвечает за количество единиц товара
 
Ответить
СообщениеFreeZe, диапазон цен в первом аргументе функции Наименьший(), в примере это D4:K4
Строка(...&M4) отвечает за количество единиц товара

Автор - sboy
Дата добавления - 12.07.2017 в 16:40
_Boroda_ Дата: Среда, 12.07.2017, 16:54 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если суммы у Вас по позрастанию, то можно так
Код
=СУММ(C4:ИНДЕКС(C4:K4;M4+1))

Если в произвольном порядке, то
Код
=СУММПРОИЗВ(НАИМЕНЬШИЙ(D4:K4;СТРОКА(A$1:ИНДЕКС(A:A;M4))))

С ДВССЫЛ оно хоть и покороче, но зато с ИНДЕКСом формула нелетучая
Если цены не в строке, а в столбце, то поменять нужно только кусок
D5:K5
К сообщению приложен файл: 1207_1.xls(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли суммы у Вас по позрастанию, то можно так
Код
=СУММ(C4:ИНДЕКС(C4:K4;M4+1))

Если в произвольном порядке, то
Код
=СУММПРОИЗВ(НАИМЕНЬШИЙ(D4:K4;СТРОКА(A$1:ИНДЕКС(A:A;M4))))

С ДВССЫЛ оно хоть и покороче, но зато с ИНДЕКСом формула нелетучая
Если цены не в строке, а в столбце, то поменять нужно только кусок
D5:K5

Автор - _Boroda_
Дата добавления - 12.07.2017 в 16:54
FreeZe Дата: Среда, 12.07.2017, 18:35 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А если немного переформулировать задачу, тот же файл, но в столбик и немного другое ЦУ, распишу подробнее по шагам, ибо тяжело формулировать:
-разбить начальные столбцы с ценами каждый на три части (дешевая, средняя, дорогая);
-при перемножении цены на кол-во расчет стоимости по алгоритму: наименьшая цена (из раздела дешевых)*нужное кол-во товара(с кф 0.6)+наименьшая цена (раздел средних цен)*кол-во товара(с кф 0.2)+наименьшая цена(раздел дорогих цен)*кол-во товара (кф 0.2).

Смысл в том, чтобы на выходе получить закупку полного спектра товаров из каждой ценовой категории, но опять же с минимизацией затрат и сохранением условия, что по цену из одной ячейки можно использовать 1 раз.
К сообщению приложен файл: 1207_2.xls(29Kb)


Сообщение отредактировал FreeZe - Среда, 12.07.2017, 18:35
 
Ответить
СообщениеА если немного переформулировать задачу, тот же файл, но в столбик и немного другое ЦУ, распишу подробнее по шагам, ибо тяжело формулировать:
-разбить начальные столбцы с ценами каждый на три части (дешевая, средняя, дорогая);
-при перемножении цены на кол-во расчет стоимости по алгоритму: наименьшая цена (из раздела дешевых)*нужное кол-во товара(с кф 0.6)+наименьшая цена (раздел средних цен)*кол-во товара(с кф 0.2)+наименьшая цена(раздел дорогих цен)*кол-во товара (кф 0.2).

Смысл в том, чтобы на выходе получить закупку полного спектра товаров из каждой ценовой категории, но опять же с минимизацией затрат и сохранением условия, что по цену из одной ячейки можно использовать 1 раз.

Автор - FreeZe
Дата добавления - 12.07.2017 в 18:35
sboy Дата: Четверг, 13.07.2017, 10:53 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
нужное кол-во товара(с кф 0.6)

кол-во товара 6*0,6=3,6. Сколько дешевого товара покупаем? 3 или 4?


Сообщение отредактировал sboy - Четверг, 13.07.2017, 10:54
 
Ответить
Сообщение
нужное кол-во товара(с кф 0.6)

кол-во товара 6*0,6=3,6. Сколько дешевого товара покупаем? 3 или 4?

Автор - sboy
Дата добавления - 13.07.2017 в 10:53
FreeZe Дата: Четверг, 13.07.2017, 11:00 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, округляем до большего, 4.
 
Ответить
Сообщениеsboy, округляем до большего, 4.

Автор - FreeZe
Дата добавления - 13.07.2017 в 11:00
sboy Дата: Четверг, 13.07.2017, 11:17 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
FreeZe,
дешевый 6*0,6 =4
средний 6*0,2 = 2
дорогой 6*0,2 = 2
Итого 8, а надо 6, как быть?)))
 
Ответить
СообщениеFreeZe,
дешевый 6*0,6 =4
средний 6*0,2 = 2
дорогой 6*0,2 = 2
Итого 8, а надо 6, как быть?)))

Автор - sboy
Дата добавления - 13.07.2017 в 11:17
FreeZe Дата: Четверг, 13.07.2017, 11:22 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, %) :D

тогда есть смысл в дешевом сегменте округлять кол-во до большего, а в среднем и дорогом до меньшего, тогда примерно будем попадать в общее количество при изменении вводных.


Сообщение отредактировал FreeZe - Четверг, 13.07.2017, 11:22
 
Ответить
Сообщениеsboy, %) :D

тогда есть смысл в дешевом сегменте округлять кол-во до большего, а в среднем и дорогом до меньшего, тогда примерно будем попадать в общее количество при изменении вводных.

Автор - FreeZe
Дата добавления - 13.07.2017 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск минимальной стоимости (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!