Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Учет праздничных часов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет праздничных часов (Формулы/Formulas)
Учет праздничных часов
Tallen Дата: Четверг, 13.07.2017, 15:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Excel 2003/
Учет праздничных часов.. возможно ли сделать привязку к календарю? ... если поездка с 07 марта 22-00 до 08 марта 06-00, то общее время работы 8 часов, из них 6 приходится на праздничные
К сообщению приложен файл: 2-__.xls(20Kb)


Сообщение отредактировал Tallen - Четверг, 13.07.2017, 16:22
 
Ответить
СообщениеExcel 2003/
Учет праздничных часов.. возможно ли сделать привязку к календарю? ... если поездка с 07 марта 22-00 до 08 марта 06-00, то общее время работы 8 часов, из них 6 приходится на праздничные

Автор - Tallen
Дата добавления - 13.07.2017 в 15:41
pabchek Дата: Четверг, 13.07.2017, 16:01 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 168 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так
(на листе "Списки" создал диапазон праздничных дат
ошибся. поправил
Код
=ЕСЛИ((B11+F11+D11)<(РАБДЕНЬ(B11+1;1;Праздники)-1);0;(B11+F11+D11)-(РАБДЕНЬ(B11+1;1;Праздники)-1))
К сообщению приложен файл: 9246028.xls(18Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 13.07.2017, 16:19
 
Ответить
СообщениеПопробуйте так
(на листе "Списки" создал диапазон праздничных дат
ошибся. поправил
Код
=ЕСЛИ((B11+F11+D11)<(РАБДЕНЬ(B11+1;1;Праздники)-1);0;(B11+F11+D11)-(РАБДЕНЬ(B11+1;1;Праздники)-1))

Автор - pabchek
Дата добавления - 13.07.2017 в 16:01
Tallen Дата: Четверг, 13.07.2017, 16:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Pabchek, спасибо большое!!! Я забыла в теме указать версию Excel. 2003 - я так поняла что РАБДЕНЬ это от 2007? Сейчас поправлю в теме
 
Ответить
СообщениеPabchek, спасибо большое!!! Я забыла в теме указать версию Excel. 2003 - я так поняла что РАБДЕНЬ это от 2007? Сейчас поправлю в теме

Автор - Tallen
Дата добавления - 13.07.2017 в 16:22
_Boroda_ Дата: Четверг, 13.07.2017, 17:25 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Просто установите надстройку Пакет Анализа
Сервис - Надстройки

И еще вариант формулы (тоже с доп. списком)
Код
=СУММПРОИЗВ(ТЕКСТ(B11+D11+F11-Пр;"[<0]\0;[<1]ч;\0")+ТЕКСТ(Пр-B11-D11+1;"[<0]\0;[<1]ч;\0"))/24
К сообщению приложен файл: 2-2.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПросто установите надстройку Пакет Анализа
Сервис - Надстройки

И еще вариант формулы (тоже с доп. списком)
Код
=СУММПРОИЗВ(ТЕКСТ(B11+D11+F11-Пр;"[<0]\0;[<1]ч;\0")+ТЕКСТ(Пр-B11-D11+1;"[<0]\0;[<1]ч;\0"))/24

Автор - _Boroda_
Дата добавления - 13.07.2017 в 17:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Учет праздничных часов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!