Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование данных ячейки при условиина другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных ячейки при условиина другой лист (Формулы/Formulas)
Копирование данных ячейки при условиина другой лист
njkzy2412 Дата: Суббота, 15.07.2017, 10:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть база данных в которой требуется копирование названия на другой лист при переменном условии тоесть если ингос то лист 2 если альфа то лист 3 если суды то лист 4 в примере забито вручную а нужно чтоб автоматом. Очень прошу помощи. Спасибо
К сообщению приложен файл: __.xlsx(12Kb)
 
Ответить
СообщениеЕсть база данных в которой требуется копирование названия на другой лист при переменном условии тоесть если ингос то лист 2 если альфа то лист 3 если суды то лист 4 в примере забито вручную а нужно чтоб автоматом. Очень прошу помощи. Спасибо

Автор - njkzy2412
Дата добавления - 15.07.2017 в 10:13
vikttur Дата: Суббота, 15.07.2017, 10:36 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2261
Репутация: 389 ±
Замечаний: 0% ±

Уберите Проверку_данных.
Код
=ИНДЕКС(Лист1!$A$1:$A$12;ПОИСКПОЗ("ингос";Лист1!$E$1:$E$12;))

С автоопределением имени листа:
Код
=ИНДЕКС(Лист1!$A$1:$A$12;ПОИСКПОЗ(ПСТР(ЯЧЕЙКА("имяфайла");ПОИСК("]";ЯЧЕЙКА("имяфайла"))+1;20);Лист1!$E$1:$E$12;))

Лучше имя листа прописывать в формуле.
 
Ответить
СообщениеУберите Проверку_данных.
Код
=ИНДЕКС(Лист1!$A$1:$A$12;ПОИСКПОЗ("ингос";Лист1!$E$1:$E$12;))

С автоопределением имени листа:
Код
=ИНДЕКС(Лист1!$A$1:$A$12;ПОИСКПОЗ(ПСТР(ЯЧЕЙКА("имяфайла");ПОИСК("]";ЯЧЕЙКА("имяфайла"))+1;20);Лист1!$E$1:$E$12;))

Лучше имя листа прописывать в формуле.

Автор - vikttur
Дата добавления - 15.07.2017 в 10:36
njkzy2412 Дата: Суббота, 15.07.2017, 11:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur,
да щас вижу стал копировать на нужные ячейки при условиях
но не формирует список. тоесть у меня просто дублирует машину подряд.. как сделать чтоб формировался список пример в файле спасибо.
если есть возможность подредактировать.. буду очень счастлив...
К сообщению приложен файл: _2.xlsx(12Kb)
 
Ответить
Сообщениеvikttur,
да щас вижу стал копировать на нужные ячейки при условиях
но не формирует список. тоесть у меня просто дублирует машину подряд.. как сделать чтоб формировался список пример в файле спасибо.
если есть возможность подредактировать.. буду очень счастлив...

Автор - njkzy2412
Дата добавления - 15.07.2017 в 11:30
vikttur Дата: Суббота, 15.07.2017, 11:34 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2261
Репутация: 389 ±
Замечаний: 0% ±

Непонятно. Если нужен выпадающий список значений столбца А, то при чем здесь название листа?
 
Ответить
СообщениеНепонятно. Если нужен выпадающий список значений столбца А, то при чем здесь название листа?

Автор - vikttur
Дата добавления - 15.07.2017 в 11:34
njkzy2412 Дата: Суббота, 15.07.2017, 11:43 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, будет идти общий список машин машин 100 из них надо сформировать отдельные списки 3 штуки в зависимости от условия ингос альфа и суды

файл подправил чтоб было видно как должный списки формироваться. название листа не обязательно
К сообщению приложен файл: 0684885.xlsx(13Kb)


Сообщение отредактировал njkzy2412 - Суббота, 15.07.2017, 11:51
 
Ответить
Сообщениеvikttur, будет идти общий список машин машин 100 из них надо сформировать отдельные списки 3 штуки в зависимости от условия ингос альфа и суды

файл подправил чтоб было видно как должный списки формироваться. название листа не обязательно

Автор - njkzy2412
Дата добавления - 15.07.2017 в 11:43
Pelena Дата: Суббота, 15.07.2017, 20:08 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11257
Репутация: 2502 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
К сообщению приложен файл: 1000505.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?

Автор - Pelena
Дата добавления - 15.07.2017 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование данных ячейки при условиина другой лист (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!