Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Записать значение в f из b если е=a - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Записать значение в f из b если е=a (Формулы/Formulas)
Записать значение в f из b если е=a
negodyaj Дата: Воскресенье, 16.07.2017, 16:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть меняющиеся значения в порядке в столбце А. Как сделать так что б Записать значение в f из b если е=a
К сообщению приложен файл: 11.xlsx(10Kb)
 
Ответить
СообщениеЕсть меняющиеся значения в порядке в столбце А. Как сделать так что б Записать значение в f из b если е=a

Автор - negodyaj
Дата добавления - 16.07.2017 в 16:40
Udik Дата: Воскресенье, 16.07.2017, 17:01 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1586
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
вот это надо
Код

=ЕСЛИ(E1=A1;B1;"")
К сообщению приложен файл: 4571303.xlsx(11Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Воскресенье, 16.07.2017, 17:04
 
Ответить
Сообщениевот это надо
Код

=ЕСЛИ(E1=A1;B1;"")

Автор - Udik
Дата добавления - 16.07.2017 в 17:01
negodyaj Дата: Воскресенье, 16.07.2017, 17:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не правильно обьяснил наверное, значения в А1 постоянно меняются местами, т.е. сегодня 807 на А1 а завтра на А5. И вот так что б он находил где это начение и подставлял в Ф1 значение из Б1
 
Ответить
СообщениеНе правильно обьяснил наверное, значения в А1 постоянно меняются местами, т.е. сегодня 807 на А1 а завтра на А5. И вот так что б он находил где это начение и подставлял в Ф1 значение из Б1

Автор - negodyaj
Дата добавления - 16.07.2017 в 17:28
negodyaj Дата: Воскресенье, 16.07.2017, 17:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(E1=A2;B2;)+ЕСЛИ(E1=A6;B6;)

Если вот так сделать и продолжить плюсование все ячеек то он покажет только нужное значение 300 Но плюсовать так 100 формул долго и не удобно..


Сообщение отредактировал negodyaj - Понедельник, 17.07.2017, 13:38
 
Ответить
Сообщение
Код
=ЕСЛИ(E1=A2;B2;)+ЕСЛИ(E1=A6;B6;)

Если вот так сделать и продолжить плюсование все ячеек то он покажет только нужное значение 300 Но плюсовать так 100 формул долго и не удобно..

Автор - negodyaj
Дата добавления - 16.07.2017 в 17:32
Udik Дата: Воскресенье, 16.07.2017, 17:37 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1586
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
И вот так что б он находил где это начение

Какое это? Вы значение сменили, старое нигде не записано, что искать будем? Или Вам нужно в массиве найти значение из Е1, тогда это через ВПР
Код

=ЕСЛИОШИБКА(ВПР(E1;A1:B19;2;0);"")
К сообщению приложен файл: 3641321.xlsx(11Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Воскресенье, 16.07.2017, 17:46
 
Ответить
Сообщение
И вот так что б он находил где это начение

Какое это? Вы значение сменили, старое нигде не записано, что искать будем? Или Вам нужно в массиве найти значение из Е1, тогда это через ВПР
Код

=ЕСЛИОШИБКА(ВПР(E1;A1:B19;2;0);"")

Автор - Udik
Дата добавления - 16.07.2017 в 17:37
Pelena Дата: Воскресенье, 16.07.2017, 18:57 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11481
Репутация: 2549 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
negodyaj, оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеnegodyaj, оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 16.07.2017 в 18:57
negodyaj Дата: Понедельник, 17.07.2017, 13:32 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ЕСЛИОШИБКА(ВПР(E1;A1:B19;2;0);"")

Спасибо, это то что надо, но не могли обяьснить логику всей этой офрмулы? 2,0, впр...
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ВПР(E1;A1:B19;2;0);"")

Спасибо, это то что надо, но не могли обяьснить логику всей этой офрмулы? 2,0, впр...

Автор - negodyaj
Дата добавления - 17.07.2017 в 13:32
negodyaj Дата: Понедельник, 17.07.2017, 13:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Оформил
 
Ответить
СообщениеОформил

Автор - negodyaj
Дата добавления - 17.07.2017 в 13:39
Udik Дата: Понедельник, 17.07.2017, 13:44 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1586
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
но не могли обяьснить логику всей этой офрмулы

ЕСЛИОШИБКА - если искомого числа нет
А по ВПР - таки прочтите справку :) 0-эквивалент ложь


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщение
но не могли обяьснить логику всей этой офрмулы

ЕСЛИОШИБКА - если искомого числа нет
А по ВПР - таки прочтите справку :) 0-эквивалент ложь

Автор - Udik
Дата добавления - 17.07.2017 в 13:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Записать значение в f из b если е=a (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!