Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения в 3-х столбцах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения в 3-х столбцах (Формулы/Formulas)
Поиск значения в 3-х столбцах
Saff Дата: Вторник, 18.07.2017, 10:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

Всем привет!
С одним столбцом я решил как найти наименование а вот с тремя проблемка.
Надо в диапазоне D4:F5 найти значение А1 и в B1 чтобы было наименование строки диапазона столбца С4:С5 в котором нашли значение.
К сообщению приложен файл: 1485666.xlsx(10Kb)
 
Ответить
СообщениеВсем привет!
С одним столбцом я решил как найти наименование а вот с тремя проблемка.
Надо в диапазоне D4:F5 найти значение А1 и в B1 чтобы было наименование строки диапазона столбца С4:С5 в котором нашли значение.

Автор - Saff
Дата добавления - 18.07.2017 в 10:14
_Boroda_ Дата: Вторник, 18.07.2017, 10:18 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС(C:C;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5))))
К сообщению приложен файл: 1485666_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС(C:C;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5))))

Автор - _Boroda_
Дата добавления - 18.07.2017 в 10:18
vikttur Дата: Вторник, 18.07.2017, 11:29 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2313
Репутация: 401 ±
Замечаний: 0% ±

Обычный ввод:
Код
=ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3)
 
Ответить
СообщениеОбычный ввод:
Код
=ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3)

Автор - vikttur
Дата добавления - 18.07.2017 в 11:29
Saff Дата: Вторник, 18.07.2017, 11:42 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

_Boroda_, Спасибо, как всегда оригинально.

А если такого значения нет, как сделать пустой ячейку B2 при условии что выбран диапазон C4:C5 (я работаю с умной таблицей)
К сообщению приложен файл: _1485666_1.xlsx(10Kb)
 
Ответить
Сообщение_Boroda_, Спасибо, как всегда оригинально.

А если такого значения нет, как сделать пустой ячейку B2 при условии что выбран диапазон C4:C5 (я работаю с умной таблицей)

Автор - Saff
Дата добавления - 18.07.2017 в 11:42
Saff Дата: Вторник, 18.07.2017, 11:46 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

vikttur, Спасибо и вам!
с вашим вариантом я решил свой предыдущий вопрос через
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3);"")


и что значит "-3" в формуле. Я такую формулу применял найдя её на форуме тут, но она не корректно работала, а с вашим "-3" всё правильно получается.

разобрался.. вспомнил что такое "-3"


Сообщение отредактировал Saff - Вторник, 18.07.2017, 15:52
 
Ответить
Сообщениеvikttur, Спасибо и вам!
с вашим вариантом я решил свой предыдущий вопрос через
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3);"")


и что значит "-3" в формуле. Я такую формулу применял найдя её на форуме тут, но она не корректно работала, а с вашим "-3" всё правильно получается.

разобрался.. вспомнил что такое "-3"

Автор - Saff
Дата добавления - 18.07.2017 в 11:46
_Boroda_ Дата: Вторник, 18.07.2017, 11:49 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 4564 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
я работаю с умной таблицей

Требования по составлению примера в Правилах форума
Цитата
старайтесь сохранить структуру, расположение таблиц, имена листов - аналогично оригиналу

Где Ваша умная таблица в примере?

Кстати, а повторений в таблице не может быть?
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5)-3;-1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС((A1=D4:F5)*СТРОКА(D4:F5))-3);"")

Код
=ИНДЕКС(C3:C5;МАКС((A1=D4:F5)*СТРОКА(C2:C3)))&""
К сообщению приложен файл: _1485666_2.xlsx(10Kb) · _1485666_3.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
я работаю с умной таблицей

Требования по составлению примера в Правилах форума
Цитата
старайтесь сохранить структуру, расположение таблиц, имена листов - аналогично оригиналу

Где Ваша умная таблица в примере?

Кстати, а повторений в таблице не может быть?
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5)-3;-1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС((A1=D4:F5)*СТРОКА(D4:F5))-3);"")

Код
=ИНДЕКС(C3:C5;МАКС((A1=D4:F5)*СТРОКА(C2:C3)))&""

Автор - _Boroda_
Дата добавления - 18.07.2017 в 11:49
Saff Дата: Вторник, 18.07.2017, 11:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 1 ±
Замечаний: 20% ±

_Boroda_,
Цитата
Кстати, а повторений в таблице не может быть?
нет, повторения исключены.
Таблица содержит уникальные значения.

На счёт сохранения структуры, файл массивный. Максимально упростил для ваших глаз ;)

Ваши формулы работают, я вашу структуру формул применяю уже к своим таблицам. Ведь хочется не просто скопировать, а ещё и самим разобраться ;)

Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5)-3;-1)));"")

и
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3);"")


Сообщение отредактировал Saff - Вторник, 18.07.2017, 12:02
 
Ответить
Сообщение_Boroda_,
Цитата
Кстати, а повторений в таблице не может быть?
нет, повторения исключены.
Таблица содержит уникальные значения.

На счёт сохранения структуры, файл массивный. Максимально упростил для ваших глаз ;)

Ваши формулы работают, я вашу структуру формул применяю уже к своим таблицам. Ведь хочется не просто скопировать, а ещё и самим разобраться ;)

Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;МАКС(ЕСЛИ(A1=D4:F5;СТРОКА(D4:F5)-3;-1)));"")

и
Код
=ЕСЛИОШИБКА(ИНДЕКС(C4:C5;СУММПРОИЗВ((D4:F5=A1)*СТРОКА(C4:C5))-3);"")

Автор - Saff
Дата добавления - 18.07.2017 в 11:58
jakim Дата: Вторник, 18.07.2017, 12:27 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 791
Репутация: 205 ±
Замечаний: 0% ±

Ещё одна формула без массивного ввода

Код
=INDEX(C1:C10;MAX(INDEX(ROW($1:$10)*(D1:F10=A1);0)))
 
Ответить
Сообщение
Ещё одна формула без массивного ввода

Код
=INDEX(C1:C10;MAX(INDEX(ROW($1:$10)*(D1:F10=A1);0)))

Автор - jakim
Дата добавления - 18.07.2017 в 12:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения в 3-х столбцах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!