Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение данных из одной книги с поиском по артикулу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных из одной книги с поиском по артикулу (Формулы/Formulas)
Извлечение данных из одной книги с поиском по артикулу
BUDDA Дата: Четверг, 20.07.2017, 17:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приветствую. Стоит задача подготовить файл для загрузки в интернет-магазин (для обновления остатков).
Данные нужно взять из файла ostatki. В нем мне уже удалось сделать формулу, определяющую наличие товара сразу по двум складам. Если есть товар хотя бы на одном из складов, то ставиться "+", если нет нигде "0".

Как эти данные по наличию перенести в файл для загрузки в интернет-магазин? %) Чтобы наличие ставилось товару с соответствующим артикулом. Сортировка товаров и общее количество строк в двух книгах не совпадает. Также могут быть товары, которых вообще нет в "свежей" базе остатков, напротив них в файле загрузки нужно поставить 0, как и у отсутствующих.

Мозг мой закипел, прошу помощи :)
К сообщению приложен файл: na_zagryzky.xls(70Kb) · ostatki.xls(25Kb)


Сообщение отредактировал BUDDA - Четверг, 20.07.2017, 18:16
 
Ответить
СообщениеПриветствую. Стоит задача подготовить файл для загрузки в интернет-магазин (для обновления остатков).
Данные нужно взять из файла ostatki. В нем мне уже удалось сделать формулу, определяющую наличие товара сразу по двум складам. Если есть товар хотя бы на одном из складов, то ставиться "+", если нет нигде "0".

Как эти данные по наличию перенести в файл для загрузки в интернет-магазин? %) Чтобы наличие ставилось товару с соответствующим артикулом. Сортировка товаров и общее количество строк в двух книгах не совпадает. Также могут быть товары, которых вообще нет в "свежей" базе остатков, напротив них в файле загрузки нужно поставить 0, как и у отсутствующих.

Мозг мой закипел, прошу помощи :)

Автор - BUDDA
Дата добавления - 20.07.2017 в 17:47
sboy Дата: Четверг, 20.07.2017, 17:57 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 255 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял
Код
=ЕСЛИОШИБКА(ВПР(A2;[ostatki.xls]Лист1!$A$2:$E$9;5;);"0")
 
Ответить
СообщениеДобрый день.
Если правильно понял
Код
=ЕСЛИОШИБКА(ВПР(A2;[ostatki.xls]Лист1!$A$2:$E$9;5;);"0")

Автор - sboy
Дата добавления - 20.07.2017 в 17:57
BUDDA Дата: Четверг, 20.07.2017, 18:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Если правильно понял


Гениально! hands Спасибо! вроде работает... Попробую интегрировать в большую базу (6000 товаров) и отпишусь по результату.


Сообщение отредактировал BUDDA - Четверг, 20.07.2017, 18:15
 
Ответить
Сообщение
Если правильно понял


Гениально! hands Спасибо! вроде работает... Попробую интегрировать в большую базу (6000 товаров) и отпишусь по результату.

Автор - BUDDA
Дата добавления - 20.07.2017 в 18:14
BUDDA Дата: Суббота, 22.07.2017, 14:19 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Попробую интегрировать в большую базу (6000 товаров) и отпишусь по результату.


Интеграция удалась! Был небольшой затуп, который решил самостоятельно. Сайт интернет-магазина не понимал полученные значения остатков в полученном от формулы виде (видимо ему мешала формула, установленная в ячейке). Создал новый столбец, в который скопировал полученные значения остатков с помощью "вставка только значений". А исходный столбец удалил.

Может быть кто подскажет более правильно решение. Хотя и так около дела.

 
Ответить
Сообщение
Попробую интегрировать в большую базу (6000 товаров) и отпишусь по результату.


Интеграция удалась! Был небольшой затуп, который решил самостоятельно. Сайт интернет-магазина не понимал полученные значения остатков в полученном от формулы виде (видимо ему мешала формула, установленная в ячейке). Создал новый столбец, в который скопировал полученные значения остатков с помощью "вставка только значений". А исходный столбец удалил.

Может быть кто подскажет более правильно решение. Хотя и так около дела.


Автор - BUDDA
Дата добавления - 22.07.2017 в 14:19
InExSu Дата: Воскресенье, 23.07.2017, 09:48 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 22 ±
Замечаний: 60% ±

Excel 2010
[vba]
Код
Private Sub Worksheet_Calculate()
  Range("f:f").Copy
  Columns("g:g").PasteSpecial Paste:=xlPasteValues
  Cells(1, 7) = "ЗначНал"
End Sub
[/vba]
К сообщению приложен файл: 9133921.xls(80Kb)


Сообщение отредактировал InExSu - Воскресенье, 23.07.2017, 09:52
 
Ответить
Сообщение[vba]
Код
Private Sub Worksheet_Calculate()
  Range("f:f").Copy
  Columns("g:g").PasteSpecial Paste:=xlPasteValues
  Cells(1, 7) = "ЗначНал"
End Sub
[/vba]

Автор - InExSu
Дата добавления - 23.07.2017 в 09:48
Nic70y Дата: Воскресенье, 23.07.2017, 21:03 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4126
Репутация: 882 ±
Замечаний: 0% ±

Excel 2013
[vba]
Код
Private Sub Worksheet_Calculate()
    u = Cells(Rows.Count, 1).End(xlUp).Row
    Range("g2:g" & u) = Range("f2:f" & u).Value
    Cells(1, 7) = "ЗначНал" 'нафигоно надо
End Sub
[/vba]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 23.07.2017, 21:04
 
Ответить
Сообщение[vba]
Код
Private Sub Worksheet_Calculate()
    u = Cells(Rows.Count, 1).End(xlUp).Row
    Range("g2:g" & u) = Range("f2:f" & u).Value
    Cells(1, 7) = "ЗначНал" 'нафигоно надо
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 23.07.2017 в 21:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение данных из одной книги с поиском по артикулу (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!