Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула расчета суммы значений ячеек при соблюдении условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула расчета суммы значений ячеек при соблюдении условий (Формулы/Formulas)
Формула расчета суммы значений ячеек при соблюдении условий
sairaff Дата: Суббота, 22.07.2017, 16:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Здравствуйте. Применительно к приложенному изображению и примеру файла мне необходимо подобрать формулу вычисления значения ячейки N7, которое должно быть равно сумме значений ячеек А1:А12 при условии, что каждое значение данного диапазона суммируется только, если в диапазоне G1:K12 имеется определенное числовое значение.
Например, если в диапазоне G1:K12 имеется значение 15, то N7 должно быть равно сумме значений А6 и А7 из диапазона А1:А12, так как число 15 имеется в строках 6 и 7 диапазона G1:K12.
Я планировал использовать следующую формулу:
Код
=СУММЕСЛИ(G1:K12;15;A1:A12)
, но она неверна.
Я в exel полный новичок, так что прошу помощи.
К сообщению приложил файл с примером и изображение.
 
Ответить
СообщениеЗдравствуйте. Применительно к приложенному изображению и примеру файла мне необходимо подобрать формулу вычисления значения ячейки N7, которое должно быть равно сумме значений ячеек А1:А12 при условии, что каждое значение данного диапазона суммируется только, если в диапазоне G1:K12 имеется определенное числовое значение.
Например, если в диапазоне G1:K12 имеется значение 15, то N7 должно быть равно сумме значений А6 и А7 из диапазона А1:А12, так как число 15 имеется в строках 6 и 7 диапазона G1:K12.
Я планировал использовать следующую формулу:
Код
=СУММЕСЛИ(G1:K12;15;A1:A12)
, но она неверна.
Я в exel полный новичок, так что прошу помощи.
К сообщению приложил файл с примером и изображение.

Автор - sairaff
Дата добавления - 22.07.2017 в 16:02
sairaff Дата: Суббота, 22.07.2017, 16:06 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Приложенные файлы:
К сообщению приложен файл: 4103004.xls(14Kb) · 7269575.png(94Kb)
 
Ответить
СообщениеПриложенные файлы:

Автор - sairaff
Дата добавления - 22.07.2017 в 16:06
Nic70y Дата: Суббота, 22.07.2017, 16:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4236
Репутация: 922 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ((G1:K12=15)*A1:A12)
вдруг правильно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((G1:K12=15)*A1:A12)
вдруг правильно

Автор - Nic70y
Дата добавления - 22.07.2017 в 16:19
sairaff Дата: Суббота, 22.07.2017, 16:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Формула подошла, большое спасибо за оперативный ответ.
 
Ответить
СообщениеФормула подошла, большое спасибо за оперативный ответ.

Автор - sairaff
Дата добавления - 22.07.2017 в 16:45
Che79 Дата: Суббота, 22.07.2017, 17:29 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
sairaff, как вариант, можно и так
Код
{=СУММ(ЕСЛИ(G1:K12=15;A1:A12))}
формула массива


Делай нормально и будет нормально!
 
Ответить
Сообщениеsairaff, как вариант, можно и так
Код
{=СУММ(ЕСЛИ(G1:K12=15;A1:A12))}
формула массива

Автор - Che79
Дата добавления - 22.07.2017 в 17:29
sairaff Дата: Суббота, 22.07.2017, 17:43 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Спасибо, пригодится и альтернативный вариант
 
Ответить
СообщениеСпасибо, пригодится и альтернативный вариант

Автор - sairaff
Дата добавления - 22.07.2017 в 17:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула расчета суммы значений ячеек при соблюдении условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!