Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соответствие и подсчет уникальных значений в двух столбцах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соответствие и подсчет уникальных значений в двух столбцах (Формулы/Formulas)
Соответствие и подсчет уникальных значений в двух столбцах
duercos Дата: Суббота, 22.07.2017, 18:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет! Помогите, пожалуйста, с такой задачкой. У меня имеется два столбца: в столбце А написаны фрукты, в столбце В - люди, которые взяли эти фрукты.

Нужно показать, сколько человек взяли тот или иной фрукт.

Я нашел формулу, которая может подсчитать количество раз, когда тот или иной человек брал фрукт:
Код
=СУММПРОИЗВ(($A$1:$A$22=E1)*($B$1:$B$22<>""))


Но теперь мне нужно как-то доработать эту формулу, чтобы она считала только уникальные имена, а не количество раз, когда брались фрукты. Т.е. если Вася взял яблоки 2 раза, то учитываться должна цифра 1, а не 2.

Всем заранее спасибо за помощь!
К сообщению приложен файл: 3331740.xls(28Kb)


Сообщение отредактировал duercos - Суббота, 22.07.2017, 18:37
 
Ответить
СообщениеВсем привет! Помогите, пожалуйста, с такой задачкой. У меня имеется два столбца: в столбце А написаны фрукты, в столбце В - люди, которые взяли эти фрукты.

Нужно показать, сколько человек взяли тот или иной фрукт.

Я нашел формулу, которая может подсчитать количество раз, когда тот или иной человек брал фрукт:
Код
=СУММПРОИЗВ(($A$1:$A$22=E1)*($B$1:$B$22<>""))


Но теперь мне нужно как-то доработать эту формулу, чтобы она считала только уникальные имена, а не количество раз, когда брались фрукты. Т.е. если Вася взял яблоки 2 раза, то учитываться должна цифра 1, а не 2.

Всем заранее спасибо за помощь!

Автор - duercos
Дата добавления - 22.07.2017 в 18:10
Pelena Дата: Суббота, 22.07.2017, 19:43 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11314
Репутация: 2514 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=СУММПРОИЗВ(($A$1:$A$22=E1)*($B$1:$B$22<>"")*(ЕСЛИОШИБКА(ПОИСКПОЗ($A$1:$A$22&$B$1:$B$22;$A$1:$A$22&$B$1:$B$22;0)=СТРОКА($B$1:$B$22);0)))
К сообщению приложен файл: 9560667.xls(29Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=СУММПРОИЗВ(($A$1:$A$22=E1)*($B$1:$B$22<>"")*(ЕСЛИОШИБКА(ПОИСКПОЗ($A$1:$A$22&$B$1:$B$22;$A$1:$A$22&$B$1:$B$22;0)=СТРОКА($B$1:$B$22);0)))

Автор - Pelena
Дата добавления - 22.07.2017 в 19:43
duercos Дата: Суббота, 22.07.2017, 21:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
То, что нужно! Спасибо большое!
 
Ответить
СообщениеТо, что нужно! Спасибо большое!

Автор - duercos
Дата добавления - 22.07.2017 в 21:33
vikttur Дата: Суббота, 22.07.2017, 23:46 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2298
Репутация: 395 ±
Замечаний: 0% ±

Вводится, как формула массива:
Код
=СЧЁТ(1/ЧАСТОТА(ЕСЛИ($A$1:$A$22=E1;ЕСЛИ($B$1:$B$22<>"";ПОИСКПОЗ($B$1:$B$22;$B$1:$B$22;)));СТРОКА($B$1:$B$22)))
 
Ответить
СообщениеВводится, как формула массива:
Код
=СЧЁТ(1/ЧАСТОТА(ЕСЛИ($A$1:$A$22=E1;ЕСЛИ($B$1:$B$22<>"";ПОИСКПОЗ($B$1:$B$22;$B$1:$B$22;)));СТРОКА($B$1:$B$22)))

Автор - vikttur
Дата добавления - 22.07.2017 в 23:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соответствие и подсчет уникальных значений в двух столбцах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!