Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отсеять пустые ячеки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсеять пустые ячеки (Формулы/Formulas)
Отсеять пустые ячеки
Qualcomm Дата: Среда, 26.07.2017, 23:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
В одной области имеются значения вперемешку с пустыми ячейками. Как собрать все значения (подряд, отсеяв пустые ячейки) в отдельной таблице? Буду очень благодарен за помощь
К сообщению приложен файл: 3675951.xlsx(8Kb)
 
Ответить
СообщениеВ одной области имеются значения вперемешку с пустыми ячейками. Как собрать все значения (подряд, отсеяв пустые ячейки) в отдельной таблице? Буду очень благодарен за помощь

Автор - Qualcomm
Дата добавления - 26.07.2017 в 23:38
Gustav Дата: Четверг, 27.07.2017, 00:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1442
Репутация: 550 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Про такие понятия как "сортировка" и "автофильтр" слышали? Или Вам надо в другую область формулами вытянуть?


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Четверг, 27.07.2017, 00:23
 
Ответить
СообщениеПро такие понятия как "сортировка" и "автофильтр" слышали? Или Вам надо в другую область формулами вытянуть?

Автор - Gustav
Дата добавления - 27.07.2017 в 00:02
Qualcomm Дата: Четверг, 27.07.2017, 01:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Gustav, разумеется вопрос в формуле
 
Ответить
СообщениеGustav, разумеется вопрос в формуле

Автор - Qualcomm
Дата добавления - 27.07.2017 в 01:00
Светлый Дата: Четверг, 27.07.2017, 07:05 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 294
Репутация: 73 ±
Замечаний: 0% ±

Excel 2007
Можно воспользоваться такой формулой (массивная - Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C$2:C$22<>"";СТРОКА(C$2:C$22));СТРОКА(A1)));"")

Скопировать протянуть вниз.

А название осмысленнее было бы "Скопировать без пустых ячеек"


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 27.07.2017, 07:11
 
Ответить
СообщениеМожно воспользоваться такой формулой (массивная - Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C$2:C$22<>"";СТРОКА(C$2:C$22));СТРОКА(A1)));"")

Скопировать протянуть вниз.

А название осмысленнее было бы "Скопировать без пустых ячеек"

Автор - Светлый
Дата добавления - 27.07.2017 в 07:05
_Boroda_ Дата: Четверг, 27.07.2017, 10:29 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11547
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если это разовая операция, то можно выделить диапазон С2:С22, пойти на вкладку Главная - Найти и выделить - Константы (или F5 - Выделить - Константы) - Контрл+С - встать в нужное место - Контрл+V
Если порядок неважен, то можно отсортировать данные по возрастанию/убыванию
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(C$2:C$22;СТРОКА(E1));"")

Код
=ЕСЛИОШИБКА(НАИБОЛЬШИЙ(C$2:C$22;СТРОКА(E1));"")
К сообщению приложен файл: 3675951_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли это разовая операция, то можно выделить диапазон С2:С22, пойти на вкладку Главная - Найти и выделить - Константы (или F5 - Выделить - Константы) - Контрл+С - встать в нужное место - Контрл+V
Если порядок неважен, то можно отсортировать данные по возрастанию/убыванию
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(C$2:C$22;СТРОКА(E1));"")

Код
=ЕСЛИОШИБКА(НАИБОЛЬШИЙ(C$2:C$22;СТРОКА(E1));"")

Автор - _Boroda_
Дата добавления - 27.07.2017 в 10:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсеять пустые ячеки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!