Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для подсчёта количества повторяющихся данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчёта количества повторяющихся данных (Формулы/Formulas)
Формула для подсчёта количества повторяющихся данных
baneska Дата: Четверг, 27.07.2017, 08:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток. Нуждаюсь в помощи, прошу направить на путь истинный.

Дана температура для одного города за 6 лет. После некоторых махинаций нужно посчитать количество повторяющихся ячеек за определённый период. Т.е. в столбец "S" нужно вписать количество повторяющихся ячеек с наличием цифры "5" (так называемая волна) в столбце "J". Т.е. когда в подряд идут цифры "5" без перерыва (цифры "0") это и есть одна волна. За один год может быть как 0 волн, так и 3 и 4. Например, в период с 1915 по 1917 было по одной волне. В 1918 г. волн не было. В 1920 году было 2 волны и в 1919 - 3 волны.
Нужна формула которая бы смогла такие расчёты выполнить для более длинного периода (100 лет, например). Надеюсь понятно изложила суть. Заранее спасибо за помощь.
К сообщению приложен файл: 0442982.xlsx(23Kb)


Новичок
 
Ответить
СообщениеДоброго времени суток. Нуждаюсь в помощи, прошу направить на путь истинный.

Дана температура для одного города за 6 лет. После некоторых махинаций нужно посчитать количество повторяющихся ячеек за определённый период. Т.е. в столбец "S" нужно вписать количество повторяющихся ячеек с наличием цифры "5" (так называемая волна) в столбце "J". Т.е. когда в подряд идут цифры "5" без перерыва (цифры "0") это и есть одна волна. За один год может быть как 0 волн, так и 3 и 4. Например, в период с 1915 по 1917 было по одной волне. В 1918 г. волн не было. В 1920 году было 2 волны и в 1919 - 3 волны.
Нужна формула которая бы смогла такие расчёты выполнить для более длинного периода (100 лет, например). Надеюсь понятно изложила суть. Заранее спасибо за помощь.

Автор - baneska
Дата добавления - 27.07.2017 в 08:02
Pelena Дата: Четверг, 27.07.2017, 08:44 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11597
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СЧЁТЕСЛИМН($A$2:$A$192;P4;$J$2:$J$192;5;$J$3:$J$193;0)
К сообщению приложен файл: 5986736.xlsx(21Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СЧЁТЕСЛИМН($A$2:$A$192;P4;$J$2:$J$192;5;$J$3:$J$193;0)

Автор - Pelena
Дата добавления - 27.07.2017 в 08:44
Светлый Дата: Четверг, 27.07.2017, 08:53 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 294
Репутация: 73 ±
Замечаний: 0% ±

Excel 2007
Для количества волн:
Код
=СУММ((A2:A999=P4)*(J2:J999=5)*(J1:J998=0))

Для продолжительности:
Код
=СУММ(--(A:A&-J:J=P4&-5))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДля количества волн:
Код
=СУММ((A2:A999=P4)*(J2:J999=5)*(J1:J998=0))

Для продолжительности:
Код
=СУММ(--(A:A&-J:J=P4&-5))

Автор - Светлый
Дата добавления - 27.07.2017 в 08:53
_Boroda_ Дата: Четверг, 27.07.2017, 09:22 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11512
Репутация: 4736 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Аналогично
формула массива, вводится одновременным нажатием КОнтрл Шифт Ентер
Код
=СУММ(--(A2:A998&J2:J998&J3:J999=P4&50))

Но лучше обычную
Код
=СУММПРОИЗВ(--(A2:A998&J2:J998&J3:J999=P4&50))

Из той же серии продолжительность
(по всему столбцу будет очень долго считать)
Код
=СУММПРОИЗВ(--(A2:A998&J2:J998=P4&5))

А вообще СЧЁТЕСЛИМН побыстрее будет
К сообщению приложен файл: 0442982_1.xlsx(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАналогично
формула массива, вводится одновременным нажатием КОнтрл Шифт Ентер
Код
=СУММ(--(A2:A998&J2:J998&J3:J999=P4&50))

Но лучше обычную
Код
=СУММПРОИЗВ(--(A2:A998&J2:J998&J3:J999=P4&50))

Из той же серии продолжительность
(по всему столбцу будет очень долго считать)
Код
=СУММПРОИЗВ(--(A2:A998&J2:J998=P4&5))

А вообще СЧЁТЕСЛИМН побыстрее будет

Автор - _Boroda_
Дата добавления - 27.07.2017 в 09:22
baneska Дата: Четверг, 27.07.2017, 10:09 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое за помощь.


Новичок
 
Ответить
СообщениеСпасибо большое за помощь.

Автор - baneska
Дата добавления - 27.07.2017 в 10:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчёта количества повторяющихся данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!