Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения в зависимости от соотношения двух ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения в зависимости от соотношения двух ячеек (Формулы/Formulas)
Выбор значения в зависимости от соотношения двух ячеек
Qixing Дата: Пятница, 04.08.2017, 08:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Возникла проблема с выборкой при условии для автоматического расчёта зарплаты клиенту
Есть две вкладки "Планы и Расчёт", Мотивация

В планы и расчёт две таблицы - одна план, вторая фактическое выполнение. Фактическое выполнение влияет на премию и бонус. Во Вкладке мотивация я проставил цифры для формул. Но не могу запрограммировать всё это. Мне нужно получить формулы для
1) Премия
KPI= KPI1*Вес%*КВыпПл+ KPI2*Вес%*КВыпПл+ KPI3*Вес%*КВыпПл . KPI1*Вес% это одна константа, значения которой мы берем в столбце. В нашем случае
KPI = 0,2*КвыПл+0,3*КвыПл+0,1*КвыПл+0,4*КвыПл. А вот КвыПл(коэфицент выполнения) должен выбираться из соседней справа таблицы в зависимости от соотношения факт/план. То есть соотношения процента выполнения на связь с таблицей

Для бонуса аналогично, но если будет решение с премией, то уже сам смогу.
К сообщению приложен файл: repost_report.xlsx(74Kb)
 
Ответить
СообщениеВозникла проблема с выборкой при условии для автоматического расчёта зарплаты клиенту
Есть две вкладки "Планы и Расчёт", Мотивация

В планы и расчёт две таблицы - одна план, вторая фактическое выполнение. Фактическое выполнение влияет на премию и бонус. Во Вкладке мотивация я проставил цифры для формул. Но не могу запрограммировать всё это. Мне нужно получить формулы для
1) Премия
KPI= KPI1*Вес%*КВыпПл+ KPI2*Вес%*КВыпПл+ KPI3*Вес%*КВыпПл . KPI1*Вес% это одна константа, значения которой мы берем в столбце. В нашем случае
KPI = 0,2*КвыПл+0,3*КвыПл+0,1*КвыПл+0,4*КвыПл. А вот КвыПл(коэфицент выполнения) должен выбираться из соседней справа таблицы в зависимости от соотношения факт/план. То есть соотношения процента выполнения на связь с таблицей

Для бонуса аналогично, но если будет решение с премией, то уже сам смогу.

Автор - Qixing
Дата добавления - 04.08.2017 в 08:09
sboy Дата: Пятница, 04.08.2017, 09:30 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 851
Репутация: 226 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял. Формула массива
Код
=СУММ(ПРОСМОТР(J3:M3/B3:E3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*ТРАНСП(Мотивация!C4:C7)*Мотивация!$B$3)
К сообщению приложен файл: 1301413.xlsx(75Kb)
 
Ответить
СообщениеДобрый день.
Если правильно понял. Формула массива
Код
=СУММ(ПРОСМОТР(J3:M3/B3:E3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*ТРАНСП(Мотивация!C4:C7)*Мотивация!$B$3)

Автор - sboy
Дата добавления - 04.08.2017 в 09:30
Qixing Дата: Пятница, 04.08.2017, 14:12 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Если правильно понял. Формула массива

Пока разбираюсь спасибо.

Попозже отпишусь, если будут вопросы.
 
Ответить
Сообщение
Добрый день.
Если правильно понял. Формула массива

Пока разбираюсь спасибо.

Попозже отпишусь, если будут вопросы.

Автор - Qixing
Дата добавления - 04.08.2017 в 14:12
Qixing Дата: Пятница, 04.08.2017, 14:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Давайте по порядку. С простого по бонусу:

Стоит план: G3 - 30 000.
Бонус Мотивация!B9 (10% = 0,1)
По факту (O3) может быть любая сумма в зависимости от этого 4е варианта (Мотивация! F10-F13). Распишу словами
1) Если O3/F3 от 0 до 0,89(или меньше 0,89) то = B9*O3 * F10
2) Если O3/F3 от 0,9 до 0,95 то = B9*O3 * F11
3) Если O3/F3 от 0,96 до 1,15 то = B9*O3 * F12
4) Если O3/F3 от 1,15 и больше то = B9*O3 * F13

Пока мысль что так
Код
=ПРОСМОТР(O3/G3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*'Планы и расчёт'!B9*'Планы и расчёт'!O3
, но не считает.


Сообщение отредактировал Qixing - Суббота, 05.08.2017, 04:15
 
Ответить
СообщениеДавайте по порядку. С простого по бонусу:

Стоит план: G3 - 30 000.
Бонус Мотивация!B9 (10% = 0,1)
По факту (O3) может быть любая сумма в зависимости от этого 4е варианта (Мотивация! F10-F13). Распишу словами
1) Если O3/F3 от 0 до 0,89(или меньше 0,89) то = B9*O3 * F10
2) Если O3/F3 от 0,9 до 0,95 то = B9*O3 * F11
3) Если O3/F3 от 0,96 до 1,15 то = B9*O3 * F12
4) Если O3/F3 от 1,15 и больше то = B9*O3 * F13

Пока мысль что так
Код
=ПРОСМОТР(O3/G3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*'Планы и расчёт'!B9*'Планы и расчёт'!O3
, но не считает.

Автор - Qixing
Дата добавления - 04.08.2017 в 14:24
sboy Дата: Пятница, 04.08.2017, 14:38 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 851
Репутация: 226 ±
Замечаний: 0% ±

Excel 2010
Qixing, оформите код в тэги (в режиме правки своего сообщения, выделите формулу и нажмите кнопку fx)
B9 не с того листа берете
 
Ответить
СообщениеQixing, оформите код в тэги (в режиме правки своего сообщения, выделите формулу и нажмите кнопку fx)
B9 не с того листа берете

Автор - sboy
Дата добавления - 04.08.2017 в 14:38
Qixing Дата: Суббота, 05.08.2017, 06:05 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Qixing, оформите код в тэги (в режиме правки своего сообщения, выделите формулу и нажмите кнопку fx)
B9 не с того листа берете

Переделал формулу не берет.
Код
=ПРОСМОТР('Планы и расчёт'!O3/'Планы и расчёт'!G3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*'Планы и расчёт'!O3*Мотивация!$B$9
К сообщению приложен файл: 6065688.xlsx(75Kb)
 
Ответить
Сообщение
Qixing, оформите код в тэги (в режиме правки своего сообщения, выделите формулу и нажмите кнопку fx)
B9 не с того листа берете

Переделал формулу не берет.
Код
=ПРОСМОТР('Планы и расчёт'!O3/'Планы и расчёт'!G3;Мотивация!$G$10:$G$13;Мотивация!$F$10:$F$13)*'Планы и расчёт'!O3*Мотивация!$B$9

Автор - Qixing
Дата добавления - 05.08.2017 в 06:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения в зависимости от соотношения двух ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!