Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формат времени внезависимости от локали - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формат времени внезависимости от локали (Формулы/Formulas)
Формат времени внезависимости от локали
skais Дата: Понедельник, 07.08.2017, 16:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Как написать одну формулу или задать формат, чтобы получить время в формате 13:35 вне зависимости от локали.
Код
=ТЕКСТ(B2;"чч:мм")

Код
=TEXT(B2;"hh:mm")

Чтобы работало при любой локали
Это я уже почитал, но хотелось более изящного способа или кто знает универсальный код этого формата?


Сообщение отредактировал skais - Понедельник, 07.08.2017, 16:46
 
Ответить
СообщениеКак написать одну формулу или задать формат, чтобы получить время в формате 13:35 вне зависимости от локали.
Код
=ТЕКСТ(B2;"чч:мм")

Код
=TEXT(B2;"hh:mm")

Чтобы работало при любой локали
Это я уже почитал, но хотелось более изящного способа или кто знает универсальный код этого формата?

Автор - skais
Дата добавления - 07.08.2017 в 16:42
vikttur Дата: Понедельник, 07.08.2017, 16:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2299
Репутация: 396 ±
Замечаний: 0% ±

Текст - это текст, не время.
Задайте ячейке нужный формат.
 
Ответить
СообщениеТекст - это текст, не время.
Задайте ячейке нужный формат.

Автор - vikttur
Дата добавления - 07.08.2017 в 16:45
skais Дата: Понедельник, 07.08.2017, 16:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Мне нужно это использовать в формуле, а не просто формат.
Типа указать начало и конец времени к примеру работа с 13:35 до 17:56


Сообщение отредактировал skais - Понедельник, 07.08.2017, 16:51
 
Ответить
СообщениеМне нужно это использовать в формуле, а не просто формат.
Типа указать начало и конец времени к примеру работа с 13:35 до 17:56

Автор - skais
Дата добавления - 07.08.2017 в 16:46
vikttur Дата: Понедельник, 07.08.2017, 16:51 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2299
Репутация: 396 ±
Замечаний: 0% ±

Код
=ЧАС(B2)&":"&МИНУТЫ(B2)
 
Ответить
Сообщение
Код
=ЧАС(B2)&":"&МИНУТЫ(B2)

Автор - vikttur
Дата добавления - 07.08.2017 в 16:51
skais Дата: Понедельник, 07.08.2017, 17:01 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
А нолик впереди? 09:15 - 12:45
 
Ответить
СообщениеА нолик впереди? 09:15 - 12:45

Автор - skais
Дата добавления - 07.08.2017 в 17:01
sboy Дата: Понедельник, 07.08.2017, 17:22 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 845
Репутация: 224 ±
Замечаний: 0% ±

Excel 2010
А нолик впереди?

Код
=ПРАВБ("0"&ЧАС(B2);2)&":"&МИНУТЫ(B2)

upd. Забыл про нолик перед минутами
Код
=ПРАВБ("0"&ЧАС(B2);2)&":"&ПРАВБ("0"&МИНУТЫ(B2);2)


Сообщение отредактировал sboy - Понедельник, 07.08.2017, 17:29
 
Ответить
Сообщение
А нолик впереди?

Код
=ПРАВБ("0"&ЧАС(B2);2)&":"&МИНУТЫ(B2)

upd. Забыл про нолик перед минутами
Код
=ПРАВБ("0"&ЧАС(B2);2)&":"&ПРАВБ("0"&МИНУТЫ(B2);2)

Автор - sboy
Дата добавления - 07.08.2017 в 17:22
skais Дата: Понедельник, 07.08.2017, 17:46 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
vikttur, sboy Спасибо!!!
Мог бы и сам догадаться, поиграться с формулами. Однако думал может есть более изящный метод. Pelena в теме по ссылке говорила о каких-то спец кодах формата в [] скобках.
 
Ответить
Сообщениеvikttur, sboy Спасибо!!!
Мог бы и сам догадаться, поиграться с формулами. Однако думал может есть более изящный метод. Pelena в теме по ссылке говорила о каких-то спец кодах формата в [] скобках.

Автор - skais
Дата добавления - 07.08.2017 в 17:46
vikttur Дата: Понедельник, 07.08.2017, 18:04 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2299
Репутация: 396 ±
Замечаний: 0% ±

Код
=ТЕКСТ(ЧАС(B2);"00:")&ТЕКСТ(МИНУТЫ(B2);"00")
 
Ответить
Сообщение
Код
=ТЕКСТ(ЧАС(B2);"00:")&ТЕКСТ(МИНУТЫ(B2);"00")

Автор - vikttur
Дата добавления - 07.08.2017 в 18:04
skais Дата: Понедельник, 07.08.2017, 18:35 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
vikttur Это поинтересней!
 
Ответить
Сообщениеvikttur Это поинтересней!

Автор - skais
Дата добавления - 07.08.2017 в 18:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формат времени внезависимости от локали (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!