Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматический подсчет литров по дням - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический подсчет литров по дням (Формулы/Formulas)
Автоматический подсчет литров по дням
gorodgrehov Дата: Вторник, 08.08.2017, 13:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день друзья мне необходимо ссздать формулу для того чтобы автоматом считала по дням сколько литров израсходовано важное то что он должен считать с 01.08.2017 года 07:59:59 утра по 02.08.2017 до 07:59:59 (это за 1 число)
Пример во вложении указал 2 цветами как должен считать.

Спасибо
К сообщению приложен файл: 9272663.xlsx(25Kb)
 
Ответить
СообщениеДобрый день друзья мне необходимо ссздать формулу для того чтобы автоматом считала по дням сколько литров израсходовано важное то что он должен считать с 01.08.2017 года 07:59:59 утра по 02.08.2017 до 07:59:59 (это за 1 число)
Пример во вложении указал 2 цветами как должен считать.

Спасибо

Автор - gorodgrehov
Дата добавления - 08.08.2017 в 13:00
_Boroda_ Дата: Вторник, 08.08.2017, 13:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10955
Репутация: 4553 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:";A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+"32:")

И почему 1 августа 771? Разве две первых строки считаем?
К сообщению приложен файл: 9272663_1.xlsx(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:";A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+"32:")

И почему 1 августа 771? Разве две первых строки считаем?

Автор - _Boroda_
Дата добавления - 08.08.2017 в 13:08
gorodgrehov Дата: Вторник, 08.08.2017, 13:10 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
сорри забыл написать, первое число надо считать с 00:00:00
 
Ответить
Сообщениесорри забыл написать, первое число надо считать с 00:00:00

Автор - gorodgrehov
Дата добавления - 08.08.2017 в 13:10
sboy Дата: Вторник, 08.08.2017, 13:17 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 841
Репутация: 224 ±
Замечаний: 0% ±

Excel 2010
еще вариант
Код
=СУММПРОИЗВ((ДЕНЬ($A$4:$A$94)=E3)*(ЧАС($A$4:$A$94)>7)*$B$4:$B$94)+СУММПРОИЗВ((ДЕНЬ($A$4:$A$94)=(E3+1))*(ЧАС($A$4:$A$94)<8)*$B$4:$B$94)
К сообщению приложен файл: 8513732.xlsx(26Kb)
 
Ответить
Сообщениееще вариант
Код
=СУММПРОИЗВ((ДЕНЬ($A$4:$A$94)=E3)*(ЧАС($A$4:$A$94)>7)*$B$4:$B$94)+СУММПРОИЗВ((ДЕНЬ($A$4:$A$94)=(E3+1))*(ЧАС($A$4:$A$94)<8)*$B$4:$B$94)

Автор - sboy
Дата добавления - 08.08.2017 в 13:17
sboy Дата: Вторник, 08.08.2017, 13:18 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 841
Репутация: 224 ±
Замечаний: 0% ±

Excel 2010
сорри забыл написать

а что тогда с последним днем месяца???
 
Ответить
Сообщение
сорри забыл написать

а что тогда с последним днем месяца???

Автор - sboy
Дата добавления - 08.08.2017 в 13:18
_Boroda_ Дата: Вторник, 08.08.2017, 13:18 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10955
Репутация: 4553 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда так (файл _2)
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:"*(E3<>1);A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+"32:")


====================
Кстати да, последний день тогда тоже считается без добавки. Тогда так (файл _2)
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:"*(E3<>1);A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+1+"8:"*(E4<>""))


====================
И не так
"Тут важное то что, должен считать с 7:59:59 по 8:00:00 по дням.",
а вот так
"Тут важное то что, должен считать с 8:00:00 по 7:59:59 по дням."
Иначе Вы считаете две лишних секунды каждый день и возможны наложения
К сообщению приложен файл: 9272663_2.xlsx(25Kb) · 9272663_3.xlsx(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда так (файл _2)
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:"*(E3<>1);A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+"32:")


====================
Кстати да, последний день тогда тоже считается без добавки. Тогда так (файл _2)
Код
=СУММЕСЛИМН(B$4:B$94;A$4:A$94;">="&(E3&ЛЕВБ(E$2;3))+"8:"*(E3<>1);A$4:A$94;"<"&(E3&ЛЕВБ(E$2;3))+1+"8:"*(E4<>""))


====================
И не так
"Тут важное то что, должен считать с 7:59:59 по 8:00:00 по дням.",
а вот так
"Тут важное то что, должен считать с 8:00:00 по 7:59:59 по дням."
Иначе Вы считаете две лишних секунды каждый день и возможны наложения

Автор - _Boroda_
Дата добавления - 08.08.2017 в 13:18
sboy Дата: Вторник, 08.08.2017, 13:26 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 841
Репутация: 224 ±
Замечаний: 0% ±

Excel 2010
">="&(E3&ЛЕВБ(E$2;3))+"8:"

Александр, это круто, не знал, что так можно в дату/время преобразовать
 
Ответить
Сообщение
">="&(E3&ЛЕВБ(E$2;3))+"8:"

Александр, это круто, не знал, что так можно в дату/время преобразовать

Автор - sboy
Дата добавления - 08.08.2017 в 13:26
_Boroda_ Дата: Вторник, 08.08.2017, 13:34 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10955
Репутация: 4553 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Там по сути (на время внимания не обращаем)
вот это написано
Код
=--(5&"авг")
- 5 августа текущего года
Если нужно первое число, то так можно
Код
=--("авг"&-17)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТам по сути (на время внимания не обращаем)
вот это написано
Код
=--(5&"авг")
- 5 августа текущего года
Если нужно первое число, то так можно
Код
=--("авг"&-17)

Автор - _Boroda_
Дата добавления - 08.08.2017 в 13:34
gorodgrehov Дата: Вторник, 08.08.2017, 13:34 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
я что то не могу повторить формулу, во вложении свой исходник можете здесь сделать это.
А 1 и 31 число вручную приплюсую ( это не трудно будет)
К сообщению приложен файл: _2.xlsx(73Kb)
 
Ответить
Сообщениея что то не могу повторить формулу, во вложении свой исходник можете здесь сделать это.
А 1 и 31 число вручную приплюсую ( это не трудно будет)

Автор - gorodgrehov
Дата добавления - 08.08.2017 в 13:34
gorodgrehov Дата: Вторник, 08.08.2017, 13:36 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а ещё вопрос, эти данные каждый раз меняются по количеству. если выделить определённый диапазон то формула будет считать ?
 
Ответить
Сообщениеа ещё вопрос, эти данные каждый раз меняются по количеству. если выделить определённый диапазон то формула будет считать ?

Автор - gorodgrehov
Дата добавления - 08.08.2017 в 13:36
_Boroda_ Дата: Вторник, 08.08.2017, 13:42 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10955
Репутация: 4553 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В последнем условии ссылка на строку ниже
Просто сделайте диапазон больше
Код
=СУММЕСЛИМН(I$4:I$999;G$4:G$999;">="&(M2&ЛЕВБ(M$1;3))+"8:"*(M2<>1);G$4:G$999;"<"&(M2&ЛЕВБ(M$1;3))+1+"8:"*(M3<>""))

Или даже так, для СУММЕСЛИ так можно, она сама отсечет нижнее лишнее
Код
=СУММЕСЛИМН(I:I;G:G;">="&(M2&ЛЕВБ(M$1;3))+"8:"*(M2<>1);G:G;"<"&(M2&ЛЕВБ(M$1;3))+1+"8:"*(M3<>""))
К сообщению приложен файл: _2-5-1.xlsx(69Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ последнем условии ссылка на строку ниже
Просто сделайте диапазон больше
Код
=СУММЕСЛИМН(I$4:I$999;G$4:G$999;">="&(M2&ЛЕВБ(M$1;3))+"8:"*(M2<>1);G$4:G$999;"<"&(M2&ЛЕВБ(M$1;3))+1+"8:"*(M3<>""))

Или даже так, для СУММЕСЛИ так можно, она сама отсечет нижнее лишнее
Код
=СУММЕСЛИМН(I:I;G:G;">="&(M2&ЛЕВБ(M$1;3))+"8:"*(M2<>1);G:G;"<"&(M2&ЛЕВБ(M$1;3))+1+"8:"*(M3<>""))

Автор - _Boroda_
Дата добавления - 08.08.2017 в 13:42
gorodgrehov Дата: Вторник, 08.08.2017, 14:01 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Все получилось, спасибо большое... :)
 
Ответить
СообщениеВсе получилось, спасибо большое... :)

Автор - gorodgrehov
Дата добавления - 08.08.2017 в 14:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический подсчет литров по дням (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!