Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отметить ячейку, содержащую определенный символ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отметить ячейку, содержащую определенный символ (Формулы/Formulas)
Отметить ячейку, содержащую определенный символ
duercos Дата: Суббота, 12.08.2017, 10:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!
У меня достаточно простой вопрос, но ответ на него что-то никак не могу найти. Может тут помогут добрые люди)

Есть ли в Экселе знак "содержит"? Мне нужно связать это с формулой ЕСЛИ.

Когда нужен знак РАВНО, то понятно:
Если ячейка А2 равна "5", то выводить "0":
Код
=ЕСЛИ(A2="5";0)


А можно ли теперь как-то изменить эту формулу, чтобы выводился "0", когда ячейка А2 содержит "5", например, когда ячейка А2="ааа5ссс"?

Всем заранее спасибо!


Сообщение отредактировал duercos - Суббота, 12.08.2017, 11:27
 
Ответить
СообщениеВсем привет!
У меня достаточно простой вопрос, но ответ на него что-то никак не могу найти. Может тут помогут добрые люди)

Есть ли в Экселе знак "содержит"? Мне нужно связать это с формулой ЕСЛИ.

Когда нужен знак РАВНО, то понятно:
Если ячейка А2 равна "5", то выводить "0":
Код
=ЕСЛИ(A2="5";0)


А можно ли теперь как-то изменить эту формулу, чтобы выводился "0", когда ячейка А2 содержит "5", например, когда ячейка А2="ааа5ссс"?

Всем заранее спасибо!

Автор - duercos
Дата добавления - 12.08.2017 в 10:27
китин Дата: Суббота, 12.08.2017, 10:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4278
Репутация: 665 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
duercos, поменяйте название темы на более информативное. и поясните: что значит
не была равна "5", а просто содержала "5"?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеduercos, поменяйте название темы на более информативное. и поясните: что значит
не была равна "5", а просто содержала "5"?

Автор - китин
Дата добавления - 12.08.2017 в 10:49
Nic70y Дата: Суббота, 12.08.2017, 11:54 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4041
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(5;A2));0)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(5;A2));0)

Автор - Nic70y
Дата добавления - 12.08.2017 в 11:54
duercos Дата: Суббота, 12.08.2017, 12:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013


Спасибо! Т.е. просто какого-нибудь символа, типа звездочки нет?)
 
Ответить
Сообщение

Спасибо! Т.е. просто какого-нибудь символа, типа звездочки нет?)

Автор - duercos
Дата добавления - 12.08.2017 в 12:07
Nic70y Дата: Суббота, 12.08.2017, 12:26 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4041
Репутация: 861 ±
Замечаний: 0% ±

Excel 2013
= оно и есть рано, а не примерно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение= оно и есть рано, а не примерно

Автор - Nic70y
Дата добавления - 12.08.2017 в 12:26
AndreTM Дата: Суббота, 12.08.2017, 21:05 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1629
Репутация: 478 ±
Замечаний: 0% ±

2003 & 2010
просто какого-нибудь символа, типа звездочки нет
Почему же нет? Есть.
Просто подход в Excel более прагматичный - вы же не просто так ищете это самое "содержит что-то", а собираетесь использовать результат в другой функции?
Соответственно, многие агрегирующие функции позволяют в критерии сравнения задавать и подстановочные знаки.
Например, "посчитать количество ячеек, содержащих символ '5'":
Код
=СЧЁТЕСЛИ(A1:A5;"*5*")


С другой стороны, если у вас "смешанные данные (текст/числа/ошибки)", или вам действительно "просто надо" - то тут и приходится искать обходные пути. Впрочем, во многих языках вы также не можете "просто так" использовать шаблоны, особенно к нетипизированным данным, хотя, если дело касается "языков программирования" - то и в том же VBA есть оператор Like.


Skype: andre.tm.007
Donate: Qiwi: 9517375010
 
Ответить
Сообщение
просто какого-нибудь символа, типа звездочки нет
Почему же нет? Есть.
Просто подход в Excel более прагматичный - вы же не просто так ищете это самое "содержит что-то", а собираетесь использовать результат в другой функции?
Соответственно, многие агрегирующие функции позволяют в критерии сравнения задавать и подстановочные знаки.
Например, "посчитать количество ячеек, содержащих символ '5'":
Код
=СЧЁТЕСЛИ(A1:A5;"*5*")


С другой стороны, если у вас "смешанные данные (текст/числа/ошибки)", или вам действительно "просто надо" - то тут и приходится искать обходные пути. Впрочем, во многих языках вы также не можете "просто так" использовать шаблоны, особенно к нетипизированным данным, хотя, если дело касается "языков программирования" - то и в том же VBA есть оператор Like.

Автор - AndreTM
Дата добавления - 12.08.2017 в 21:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отметить ячейку, содержащую определенный символ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!