Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение ячеек по одинаковым значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячеек по одинаковым значениям (Формулы/Formulas)
Автоматическое заполнение ячеек по одинаковым значениям
Ilena Дата: Суббота, 12.08.2017, 15:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Есть два листа. На обоих таблицы с колонкой с артиклами и колонкой с ценами. На листе "лист3" упорядоченно в соответствии с артиклами ведется учет цен. На листе1 артиклы разбросаны. Надо чтобы эти цены автоматически изменялись на листе "лист1" в соответствии с изменениями на "листе3".
Помогите, плиз, с формулой для лист1, или как вообще можно это решить?
Может макрос, или формулы не позволяют работать на разных листах, надо копировать две таблицы в один лист?
К сообщению приложен файл: 3424328.xlsx(18Kb)


Сообщение отредактировал Ilena - Суббота, 12.08.2017, 15:50
 
Ответить
СообщениеЗдравствуйте!
Есть два листа. На обоих таблицы с колонкой с артиклами и колонкой с ценами. На листе "лист3" упорядоченно в соответствии с артиклами ведется учет цен. На листе1 артиклы разбросаны. Надо чтобы эти цены автоматически изменялись на листе "лист1" в соответствии с изменениями на "листе3".
Помогите, плиз, с формулой для лист1, или как вообще можно это решить?
Может макрос, или формулы не позволяют работать на разных листах, надо копировать две таблицы в один лист?

Автор - Ilena
Дата добавления - 12.08.2017 в 15:50
anvg Дата: Суббота, 12.08.2017, 15:53 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 324
Репутация: 178 ±
Замечаний: 0% ±

2010, 2016
 
Ответить
СообщениеКросс

Автор - anvg
Дата добавления - 12.08.2017 в 15:53
Karataev Дата: Суббота, 12.08.2017, 16:00 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 873
Репутация: 325 ±
Замечаний: 0% ±

Excel
Формула для листа1 для "C3". Предполагается, что артикулы уникальные.
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист3!B:C;2;0);"")

Аналогичные формулы для остальных столбцов, только меняется "B2" на соответствующую ячейку.
Я вставил формулы в столбцы "C" и "E".
К сообщению приложен файл: 3585015.xlsx(19Kb)


 
Ответить
СообщениеФормула для листа1 для "C3". Предполагается, что артикулы уникальные.
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист3!B:C;2;0);"")

Аналогичные формулы для остальных столбцов, только меняется "B2" на соответствующую ячейку.
Я вставил формулы в столбцы "C" и "E".

Автор - Karataev
Дата добавления - 12.08.2017 в 16:00
Ilena Дата: Суббота, 12.08.2017, 16:14 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!!!!!!!!!!!!!!!!!!! respect pray
ЗЫ: от меня плюсик в карму)


Сообщение отредактировал Ilena - Суббота, 12.08.2017, 17:29
 
Ответить
СообщениеСпасибо!!!!!!!!!!!!!!!!!!! respect pray
ЗЫ: от меня плюсик в карму)

Автор - Ilena
Дата добавления - 12.08.2017 в 16:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение ячеек по одинаковым значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!