Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Индекс и Поискпоз с несколькими условиями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Индекс и Поискпоз с несколькими условиями
Acya96 Дата: Среда, 30.08.2017, 00:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем доброй ночи!
Задали задачку, никак не могу сообразить, как составить формулу, используя ИНДЕКС и ПОИСКПОЗ, если даны 4 условия. При этом в ответе должна быть фраза "есть/нет". Если просто вписывать в формулу всю таблицу, а потом в поискпоз забивать условия - получается полная фигня. И не проще ли в ВПР просто сделать? В самом файле есть и основная таблица и, собственно, условия, которым нужно следовать.

Спасибо за любую помощь и комментарии!
К сообщению приложен файл: _Microsoft_Exce.xlsx (10.7 Kb)


Сообщение отредактировал Acya96 - Среда, 30.08.2017, 00:51
 
Ответить
СообщениеВсем доброй ночи!
Задали задачку, никак не могу сообразить, как составить формулу, используя ИНДЕКС и ПОИСКПОЗ, если даны 4 условия. При этом в ответе должна быть фраза "есть/нет". Если просто вписывать в формулу всю таблицу, а потом в поискпоз забивать условия - получается полная фигня. И не проще ли в ВПР просто сделать? В самом файле есть и основная таблица и, собственно, условия, которым нужно следовать.

Спасибо за любую помощь и комментарии!

Автор - Acya96
Дата добавления - 30.08.2017 в 00:49
vikttur Дата: Среда, 30.08.2017, 00:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2941
Репутация: 526 ±
Замечаний: 0% ±

Странное желание... Но если нужно (простая, не формула массива):
Код
=--ЕЧИСЛО(ПОИСКПОЗ(G5&H5&I5&J5;ИНДЕКС($A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;);))


Сообщение отредактировал vikttur - Среда, 30.08.2017, 01:13
 
Ответить
СообщениеСтранное желание... Но если нужно (простая, не формула массива):
Код
=--ЕЧИСЛО(ПОИСКПОЗ(G5&H5&I5&J5;ИНДЕКС($A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;);))

Автор - vikttur
Дата добавления - 30.08.2017 в 00:56
buchlotnik Дата: Среда, 30.08.2017, 01:00 | Сообщение № 3
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3442
Репутация: 929 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
видимо как-то так
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(G5&H5&I5&J5;$A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;0));"нет";"есть")
Цитата
не проще ли в ВПР просто сделать
сделайте, раз проще
К сообщению приложен файл: 4318870.xlsx (11.4 Kb)
 
Ответить
Сообщениевидимо как-то так
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(G5&H5&I5&J5;$A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;0));"нет";"есть")
Цитата
не проще ли в ВПР просто сделать
сделайте, раз проще

Автор - buchlotnik
Дата добавления - 30.08.2017 в 01:00
Acya96 Дата: Среда, 30.08.2017, 01:02 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, хмм, сама бы ни за что не догадалась. Даже не подумала про ЕЧИСЛО. Спасибо вам огромное!
А желание и, правда, крайне странное
 
Ответить
Сообщениеvikttur, хмм, сама бы ни за что не догадалась. Даже не подумала про ЕЧИСЛО. Спасибо вам огромное!
А желание и, правда, крайне странное

Автор - Acya96
Дата добавления - 30.08.2017 в 01:02
Acya96 Дата: Среда, 30.08.2017, 01:06 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, спасибо большое!
Тут просто сама суть задания сделать через ИНДЕКС и ПОИСКПОЗ. Для меня это немного странно и непонятно:/
 
Ответить
Сообщениеbuchlotnik, спасибо большое!
Тут просто сама суть задания сделать через ИНДЕКС и ПОИСКПОЗ. Для меня это немного странно и непонятно:/

Автор - Acya96
Дата добавления - 30.08.2017 в 01:06
vikttur Дата: Среда, 30.08.2017, 01:09 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2941
Репутация: 526 ±
Замечаний: 0% ±

Видимо, проверяют Вас на знание материала )
Цитата
не проще ли в ВПР просто сделать?

Нет, не проще. Проще -
Код
СЧЁТЕСЛИМН(), СУММПРОИЗВ()


Сообщение отредактировал vikttur - Среда, 30.08.2017, 01:12
 
Ответить
СообщениеВидимо, проверяют Вас на знание материала )
Цитата
не проще ли в ВПР просто сделать?

Нет, не проще. Проще -
Код
СЧЁТЕСЛИМН(), СУММПРОИЗВ()

Автор - vikttur
Дата добавления - 30.08.2017 в 01:09
buchlotnik Дата: Среда, 30.08.2017, 01:10 | Сообщение № 7
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3442
Репутация: 929 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
Цитата
через ИНДЕКС
ну куда тут его? давайте так
Код
=ИНДЕКС({"есть";"нет"};1+ЕНД(ПОИСКПОЗ(G5&H5&I5&J5;$A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;0)))
К сообщению приложен файл: 3971879.xlsx (11.6 Kb)
 
Ответить
Сообщение
Цитата
через ИНДЕКС
ну куда тут его? давайте так
Код
=ИНДЕКС({"есть";"нет"};1+ЕНД(ПОИСКПОЗ(G5&H5&I5&J5;$A$3:$A$40&$B$3:$B$40&$C$3:$C$40&$E$3:$E$40;0)))

Автор - buchlotnik
Дата добавления - 30.08.2017 в 01:10
_Boroda_ Дата: Среда, 30.08.2017, 01:10 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС({"Нет":"Есть"};1+ЕЧИСЛО(ПОИСКПОЗ(G5&H5&I5&J5;A$3:A$40&B$3:B$40&C$3:C$40&E$3:E$40;)))

И проверка там еще Условным форматированием
К сообщению приложен файл: 8613343.xlsx (13.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС({"Нет":"Есть"};1+ЕЧИСЛО(ПОИСКПОЗ(G5&H5&I5&J5;A$3:A$40&B$3:B$40&C$3:C$40&E$3:E$40;)))

И проверка там еще Условным форматированием

Автор - _Boroda_
Дата добавления - 30.08.2017 в 01:10
iMrTidy Дата: Среда, 30.08.2017, 01:24 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 85
Репутация: 14 ±
Замечаний: 0% ±

NO
Acya96, возможно, так?
Код
=INDEX($A$3:$A$40;MATCH(J5;$E$3:$E$40;0))&INDEX($B$3:$B$40;MATCH(J5;$E$3:$E$40;0))&INDEX($C$3:$C$40;MATCH(J5;$E$3:$E$40;0))=G5&H5&I5
К сообщению приложен файл: 3212140.xlsx (11.3 Kb)


Вышенаписанное мной не является истиной, но лишь моя точка зрения, которая скорее всего ошибочна.
 
Ответить
СообщениеAcya96, возможно, так?
Код
=INDEX($A$3:$A$40;MATCH(J5;$E$3:$E$40;0))&INDEX($B$3:$B$40;MATCH(J5;$E$3:$E$40;0))&INDEX($C$3:$C$40;MATCH(J5;$E$3:$E$40;0))=G5&H5&I5

Автор - iMrTidy
Дата добавления - 30.08.2017 в 01:24
Acya96 Дата: Среда, 30.08.2017, 01:24 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Еще раз спасибо. Пойду разбираться, что да как.
 
Ответить
СообщениеЕще раз спасибо. Пойду разбираться, что да как.

Автор - Acya96
Дата добавления - 30.08.2017 в 01:24
jakim Дата: Среда, 30.08.2017, 16:54 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Вариант с формулой

Код
=IF(MAX(INDEX((A$3:A$400=G6)*(B$3:B$400=H6)*(C$3:C$400=I6)*(E$3:E$400=J6);0))=1;"есть";"нет")
К сообщению приложен файл: Microsoft_Exce.xlsx (11.3 Kb)
 
Ответить
Сообщение
Вариант с формулой

Код
=IF(MAX(INDEX((A$3:A$400=G6)*(B$3:B$400=H6)*(C$3:C$400=I6)*(E$3:E$400=J6);0))=1;"есть";"нет")

Автор - jakim
Дата добавления - 30.08.2017 в 16:54
buchlotnik Дата: Среда, 30.08.2017, 16:57 | Сообщение № 12
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3442
Репутация: 929 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
jakim, а ПОИСКПОЗ()-то где? :D
 
Ответить
Сообщениеjakim, а ПОИСКПОЗ()-то где? :D

Автор - buchlotnik
Дата добавления - 30.08.2017 в 16:57
jakim Дата: Среда, 30.08.2017, 21:31 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Пожалуйста ПОИСКПОЗ только наоборот.

Код
=IFERROR(MATCH(1;INDEX((B$3:B$400=H5)*(C$3:C$400=I5)*(D$3:D$400=J5)*(F$3:F$400=K5);0);0);"нет")
К сообщению приложен файл: 5362367.xlsx (11.5 Kb)
 
Ответить
Сообщение
Пожалуйста ПОИСКПОЗ только наоборот.

Код
=IFERROR(MATCH(1;INDEX((B$3:B$400=H5)*(C$3:C$400=I5)*(D$3:D$400=J5)*(F$3:F$400=K5);0);0);"нет")

Автор - jakim
Дата добавления - 30.08.2017 в 21:31
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!