Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округлить с 2-мя условиями. Диапазон 1-50 до 50, 51-99 до 90 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округлить с 2-мя условиями. Диапазон 1-50 до 50, 51-99 до 90 (Формулы/Formulas)
Округлить с 2-мя условиями. Диапазон 1-50 до 50, 51-99 до 90
Pajta4ek Дата: Четверг, 07.09.2017, 11:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Условие:
формирование прайс-листов магазина.
Цены должны быть фиксированные
Цена 1000 должны быть 1000
диапазон 1001-1050 должен округляться до 1050
диапазон 1051-1099 должен округляться до 1090
Округлить до 50 смогу, благодаря DV вот его пост
Вот эта формула:
Код
=ОКРУГЛ(A1-50;-2)+СУММ((ОСТАТ(A1;100)>{45;55})*50)

С этой формулой, что выше приведена. Все отлично работает, акромя вот этих **90.
Что туда необходимо дописать?
Уже пробовал и функцию ЕСЛИ, и минусовал -10. Если минусовать, то минусутеся везде. И цены получаются 40 и 90. По йункции ЕСЛИ уже и не вспомню, что прописывал.
 
Ответить
СообщениеУсловие:
формирование прайс-листов магазина.
Цены должны быть фиксированные
Цена 1000 должны быть 1000
диапазон 1001-1050 должен округляться до 1050
диапазон 1051-1099 должен округляться до 1090
Округлить до 50 смогу, благодаря DV вот его пост
Вот эта формула:
Код
=ОКРУГЛ(A1-50;-2)+СУММ((ОСТАТ(A1;100)>{45;55})*50)

С этой формулой, что выше приведена. Все отлично работает, акромя вот этих **90.
Что туда необходимо дописать?
Уже пробовал и функцию ЕСЛИ, и минусовал -10. Если минусовать, то минусутеся везде. И цены получаются 40 и 90. По йункции ЕСЛИ уже и не вспомню, что прописывал.

Автор - Pajta4ek
Дата добавления - 07.09.2017 в 11:57
Pelena Дата: Четверг, 07.09.2017, 12:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11769
Репутация: 2599 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Как вариант
Код
=ОКРВВЕРХ(A1;50)-(ОСТАТ(A1;100)>50)*10


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=ОКРВВЕРХ(A1;50)-(ОСТАТ(A1;100)>50)*10

Автор - Pelena
Дата добавления - 07.09.2017 в 12:08
pabchek Дата: Четверг, 07.09.2017, 12:30 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 785
Репутация: 176 ±
Замечаний: 0% ±

Excel 2007
И мой вариант
Код
=ПРОСМОТР(A1;{1000:1001:1051};{1000:1050:1090})

Добавил
И более универсальный вариант
Код
=ЦЕЛОЕ(A1%)*100+ПРОСМОТР(ОСТАТ(A1;100);{0:1:51};{0:50:90})


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 07.09.2017, 12:37
 
Ответить
СообщениеИ мой вариант
Код
=ПРОСМОТР(A1;{1000:1001:1051};{1000:1050:1090})

Добавил
И более универсальный вариант
Код
=ЦЕЛОЕ(A1%)*100+ПРОСМОТР(ОСТАТ(A1;100);{0:1:51};{0:50:90})

Автор - pabchek
Дата добавления - 07.09.2017 в 12:30
_Boroda_ Дата: Четверг, 07.09.2017, 12:45 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И любимый ТЕКСТ
Код
=ОТБР(A1;-2)+ТЕКСТ(ПРАВБ(A1;2);"[>50]9;[>0]5;0")*10


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ любимый ТЕКСТ
Код
=ОТБР(A1;-2)+ТЕКСТ(ПРАВБ(A1;2);"[>50]9;[>0]5;0")*10

Автор - _Boroda_
Дата добавления - 07.09.2017 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округлить с 2-мя условиями. Диапазон 1-50 до 50, 51-99 до 90 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!