Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поочередная заливка разного количества строк. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поочередная заливка разного количества строк. (Формулы/Formulas)
Поочередная заливка разного количества строк.
Shtein Дата: Пятница, 15.09.2017, 12:00 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день всем.
Посоветуйте, как решить задачку. Во вложении пример, нужно закрасить поочередно 2 разными цветами блоки с одинаковыми цифрами. Если бы блоки содержали одинаковое количество, я бы справился, - например все содержали по 3 строки, но тут может быть блок как из одной строки, так и из 3,5,10 и т.п, и вот тут я затрудняюсь. Думал как-то, через функцию ЕСЛИ, проверять предыдущее значение, совпадает ли оно с текущей ячейкой, а потом фильтровать + и - ,и закрашивать двумя цветами, но докрутить до конца не могу.
К сообщению приложен файл: 7938089.xlsx(11Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Пятница, 15.09.2017, 12:14
 
Ответить
СообщениеДобрый день всем.
Посоветуйте, как решить задачку. Во вложении пример, нужно закрасить поочередно 2 разными цветами блоки с одинаковыми цифрами. Если бы блоки содержали одинаковое количество, я бы справился, - например все содержали по 3 строки, но тут может быть блок как из одной строки, так и из 3,5,10 и т.п, и вот тут я затрудняюсь. Думал как-то, через функцию ЕСЛИ, проверять предыдущее значение, совпадает ли оно с текущей ячейкой, а потом фильтровать + и - ,и закрашивать двумя цветами, но докрутить до конца не могу.

Автор - Shtein
Дата добавления - 15.09.2017 в 12:00
_Boroda_ Дата: Пятница, 15.09.2017, 12:11 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕНЕЧЁТ(СУММ(-($A2:$A$2<>$A$1:$A1)))

Это формула для Условного форматирования (вкладка Главная) для зеленых. А желтым изначально красим весь диапазон
К сообщению приложен файл: 7938089_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕНЕЧЁТ(СУММ(-($A2:$A$2<>$A$1:$A1)))

Это формула для Условного форматирования (вкладка Главная) для зеленых. А желтым изначально красим весь диапазон

Автор - _Boroda_
Дата добавления - 15.09.2017 в 12:11
Shtein Дата: Пятница, 15.09.2017, 13:00 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо, работает) . Ваша формула подала мне идею использовать просто функцию ЕНЕЧЁТ или ЕЧЁТ - а потом фильтровать ЛОЖЬ или ИСТИНА и закрашивать цветом.


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщение_Boroda_, спасибо, работает) . Ваша формула подала мне идею использовать просто функцию ЕНЕЧЁТ или ЕЧЁТ - а потом фильтровать ЛОЖЬ или ИСТИНА и закрашивать цветом.

Автор - Shtein
Дата добавления - 15.09.2017 в 13:00
_Boroda_ Дата: Пятница, 15.09.2017, 13:07 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если Вам в отдельном столбце, то можно так
Код
=ЕСЛИ(A2=A1;C1;НЕ(C1))
К сообщению приложен файл: 7938089_2.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли Вам в отдельном столбце, то можно так
Код
=ЕСЛИ(A2=A1;C1;НЕ(C1))

Автор - _Boroda_
Дата добавления - 15.09.2017 в 13:07
Shtein Дата: Пятница, 15.09.2017, 13:28 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 60
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Тоже вариант, благодарю.)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеТоже вариант, благодарю.)

Автор - Shtein
Дата добавления - 15.09.2017 в 13:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поочередная заливка разного количества строк. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!