Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выписать отдельно значения из ячеек со специальным символом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выписать отдельно значения из ячеек со специальным символом (Формулы/Formulas)
Выписать отдельно значения из ячеек со специальным символом
emegrelo Дата: Среда, 04.10.2017, 16:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста как можно выписать отдельно все значения из таблицы которые содержат в ячейке этот символ: /=
Пример я прикрепил в виде скриншота, но я эти значения выписал вручную, а хотелось бы чтоб был автоматический перенос
К сообщению приложен файл: 22182.xlsx(84Kb) · 1393303.png(161Kb)


Сообщение отредактировал emegrelo - Среда, 04.10.2017, 16:50
 
Ответить
СообщениеПодскажите пожалуйста как можно выписать отдельно все значения из таблицы которые содержат в ячейке этот символ: /=
Пример я прикрепил в виде скриншота, но я эти значения выписал вручную, а хотелось бы чтоб был автоматический перенос

Автор - emegrelo
Дата добавления - 04.10.2017 в 16:41
Nic70y Дата: Среда, 04.10.2017, 17:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4120
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
формула массива
Код
=ГПР("我";ИНДЕКС(E$8:R$738;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК("/=";E$8:R$738));СТРОКА(E$8:R$738)-7);СТРОКА(A1)););1)
К сообщению приложен файл: 1619297.xlsx(88Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеформула массива
Код
=ГПР("我";ИНДЕКС(E$8:R$738;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК("/=";E$8:R$738));СТРОКА(E$8:R$738)-7);СТРОКА(A1)););1)

Автор - Nic70y
Дата добавления - 04.10.2017 в 17:16
emegrelo Дата: Среда, 04.10.2017, 17:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо :)
 
Ответить
СообщениеСпасибо :)

Автор - emegrelo
Дата добавления - 04.10.2017 в 17:35
Che79 Дата: Среда, 04.10.2017, 17:48 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 533
Репутация: 92 ±
Замечаний: 0% ±

Excel 2010 RUS
emegrelo, ну и еще вариант
Все по строкам (Столбец S)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК("/=";$B8:$R8);$B$8:$R8);"")

Уникальные (Столбец Т) формула массива
Код
{=ЕСЛИОШИБКА(ИНДЕКС($S$8:$S$738;ПОИСКПОЗ(;СЧЁТЕСЛИ(T$7:T7;$S$8:$S$738);));"")}

+раскраска таблицы через УФ.
Файл заархивировал, ибо получился чуть больше 100кб.
К сообщению приложен файл: 22182_1.zip(92Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеemegrelo, ну и еще вариант
Все по строкам (Столбец S)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК("/=";$B8:$R8);$B$8:$R8);"")

Уникальные (Столбец Т) формула массива
Код
{=ЕСЛИОШИБКА(ИНДЕКС($S$8:$S$738;ПОИСКПОЗ(;СЧЁТЕСЛИ(T$7:T7;$S$8:$S$738);));"")}

+раскраска таблицы через УФ.
Файл заархивировал, ибо получился чуть больше 100кб.

Автор - Che79
Дата добавления - 04.10.2017 в 17:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выписать отдельно значения из ячеек со специальным символом (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!