Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт количества месяцев формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества месяцев формулой (Формулы/Formulas)
Подсчёт количества месяцев формулой
Markoli Дата: Четверг, 05.10.2017, 05:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго дня, подскажите, пожалуйста, а не то не могу сообразить, как в столбце с датами подсчитать их количества по месяцам?
Год не важно какой только месяц.
Интересует решение только формулой, не сводной.
К сообщению приложен файл: 6867048.xls(27Kb)
 
Ответить
СообщениеДоброго дня, подскажите, пожалуйста, а не то не могу сообразить, как в столбце с датами подсчитать их количества по месяцам?
Год не важно какой только месяц.
Интересует решение только формулой, не сводной.

Автор - Markoli
Дата добавления - 05.10.2017 в 05:14
Shurf Дата: Четверг, 05.10.2017, 05:24 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010
Markoli, Здравствуйте, вариант.
В таблице в которую выводим результаты расчетов даты выставляете в формате даты, то есть не "Январь" а "01.01.2017", формат ячеек выставляете что б отображалось только название месяца. и формулой
Код
=СУММПРОИЗВ((МЕСЯЦ($A$2:$A$17)=МЕСЯЦ(C2))*1)

спокойно подсчитываете количество.
Наглядно в примере можете посмотреть.
К сообщению приложен файл: _6867048.xls(29Kb)


Сообщение отредактировал Shurf - Четверг, 05.10.2017, 05:27
 
Ответить
СообщениеMarkoli, Здравствуйте, вариант.
В таблице в которую выводим результаты расчетов даты выставляете в формате даты, то есть не "Январь" а "01.01.2017", формат ячеек выставляете что б отображалось только название месяца. и формулой
Код
=СУММПРОИЗВ((МЕСЯЦ($A$2:$A$17)=МЕСЯЦ(C2))*1)

спокойно подсчитываете количество.
Наглядно в примере можете посмотреть.

Автор - Shurf
Дата добавления - 05.10.2017 в 05:24
Nic70y Дата: Четверг, 05.10.2017, 07:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4120
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(--(МЕСЯЦ(A$2:A$17)=СТРОКА(C1)))
Код
=СУММПРОИЗВ(--(МЕСЯЦ(A$2:A$17)=МЕСЯЦ(1&C2)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 05.10.2017, 07:39
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--(МЕСЯЦ(A$2:A$17)=СТРОКА(C1)))
Код
=СУММПРОИЗВ(--(МЕСЯЦ(A$2:A$17)=МЕСЯЦ(1&C2)))

Автор - Nic70y
Дата добавления - 05.10.2017 в 07:38
_Boroda_ Дата: Четверг, 05.10.2017, 09:10 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11525
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(--(ТЕКСТ(A$2:A$17;"ММММ")=C2))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(--(ТЕКСТ(A$2:A$17;"ММММ")=C2))

Автор - _Boroda_
Дата добавления - 05.10.2017 в 09:10
Markoli Дата: Четверг, 05.10.2017, 16:49 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое всем за формулы.
 
Ответить
СообщениеСпасибо большое всем за формулы.

Автор - Markoli
Дата добавления - 05.10.2017 в 16:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества месяцев формулой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!