Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадения по диапазону дат из другого файла - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадения по диапазону дат из другого файла (Формулы/Formulas)
Поиск совпадения по диапазону дат из другого файла
pisk1 Дата: Суббота, 07.10.2017, 09:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток, господа!

Вежливо прошу помощи в решении задачи:
Есть два файла: 123.xls и 456.xls. Необходимо, чтобы колонка "Совпадение" (файл 123.xls) окрашивалась или в ней прописывался любой символ (0 или 1) при соответствии диапазону дат из колонок "Начало" "Конец" (файл 456.xls).
Например: Человек Андреев Андрей Андреевич выполнял посещение объекта множество раз (колонка "Дата" в файле 123.xls). Необходимо обозначить ячейку в колонке "Совпадение" (цветом или символом) при условии, что дата посещения совпала с диапазоном дат из колонок "Начало" "Конец" для этого же человека (файл 456.xls).
Пример желаемого результата показан в файле 123.xls для Андреева Андрея Андреевича.

Премного благодарен за любую помощь!
К сообщению приложен файл: 123.xls(76Kb) · 456.xls(26Kb)


Не судите строго, чукча чукча.
 
Ответить
СообщениеДоброго времени суток, господа!

Вежливо прошу помощи в решении задачи:
Есть два файла: 123.xls и 456.xls. Необходимо, чтобы колонка "Совпадение" (файл 123.xls) окрашивалась или в ней прописывался любой символ (0 или 1) при соответствии диапазону дат из колонок "Начало" "Конец" (файл 456.xls).
Например: Человек Андреев Андрей Андреевич выполнял посещение объекта множество раз (колонка "Дата" в файле 123.xls). Необходимо обозначить ячейку в колонке "Совпадение" (цветом или символом) при условии, что дата посещения совпала с диапазоном дат из колонок "Начало" "Конец" для этого же человека (файл 456.xls).
Пример желаемого результата показан в файле 123.xls для Андреева Андрея Андреевича.

Премного благодарен за любую помощь!

Автор - pisk1
Дата добавления - 07.10.2017 в 09:50
Pelena Дата: Суббота, 07.10.2017, 11:50 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11844
Репутация: 2609 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=(ОТБР(B2)>=ВПР(A2;[456.xls]Лист2!$A$2:$C$15;2;0))*(ОТБР(B2)<=ВПР(A2;[456.xls]Лист2!$A$2:$C$15;3;0))
К сообщению приложен файл: 3124381.xls(86Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=(ОТБР(B2)>=ВПР(A2;[456.xls]Лист2!$A$2:$C$15;2;0))*(ОТБР(B2)<=ВПР(A2;[456.xls]Лист2!$A$2:$C$15;3;0))

Автор - Pelena
Дата добавления - 07.10.2017 в 11:50
pisk1 Дата: Суббота, 07.10.2017, 12:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, это великолепно!

Моя вам благодарность и плюсик!


Не судите строго, чукча чукча.
 
Ответить
СообщениеPelena, это великолепно!

Моя вам благодарность и плюсик!

Автор - pisk1
Дата добавления - 07.10.2017 в 12:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадения по диапазону дат из другого файла (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!