Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиске значения через INDEX + MATCH - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиске значения через INDEX + MATCH (Формулы/Formulas)
Поиске значения через INDEX + MATCH
KIMVSR Дата: Суббота, 07.10.2017, 14:48 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте,

Пытаюсь подтянуть значение из опредёлнного диапазона данных при помощи формул INDEX и MATCH.
В принципе, формула работает, но не совсем корректно.

Например, при значениях Сложность 5 и Умение 4 - результат 6,74€
Хотя, если посмотреть таблицу, правильный результат должен быть 7,09€

И так со всеми искомыми значениями: результат смещён на одну строчку выше.

Код
=INDEX(Data!$C$3:$R$9;MATCH(A2;Data!$B$4:$B$9;0);MATCH(B2;Data!$C$3:$R$3;0))

Подскажите, пожалуйтса, почему происходит смещение и где я допустил ошибку?

Файл приложен.
К сообщению приложен файл: KIMVSR.xlsx(46Kb)


Сообщение отредактировал KIMVSR - Суббота, 07.10.2017, 14:50
 
Ответить
СообщениеЗдравствуйте,

Пытаюсь подтянуть значение из опредёлнного диапазона данных при помощи формул INDEX и MATCH.
В принципе, формула работает, но не совсем корректно.

Например, при значениях Сложность 5 и Умение 4 - результат 6,74€
Хотя, если посмотреть таблицу, правильный результат должен быть 7,09€

И так со всеми искомыми значениями: результат смещён на одну строчку выше.

Код
=INDEX(Data!$C$3:$R$9;MATCH(A2;Data!$B$4:$B$9;0);MATCH(B2;Data!$C$3:$R$3;0))

Подскажите, пожалуйтса, почему происходит смещение и где я допустил ошибку?

Файл приложен.

Автор - KIMVSR
Дата добавления - 07.10.2017 в 14:48
Nic70y Дата: Суббота, 07.10.2017, 14:57 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4120
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
потомушто
Код
=ИНДЕКС(Data!$C$4:$R$9;ПОИСКПОЗ(A2;Data!$B$4:$B$9;0);ПОИСКПОЗ(B2;Data!$C$3:$R$3;0))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепотомушто
Код
=ИНДЕКС(Data!$C$4:$R$9;ПОИСКПОЗ(A2;Data!$B$4:$B$9;0);ПОИСКПОЗ(B2;Data!$C$3:$R$3;0))

Автор - Nic70y
Дата добавления - 07.10.2017 в 14:57
KIMVSR Дата: Суббота, 07.10.2017, 15:06 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, оууууу, спасибо! Блин, как же я так с диапазоном то промазал *facepalm*

closed
 
Ответить
СообщениеNic70y, оууууу, спасибо! Блин, как же я так с диапазоном то промазал *facepalm*

closed

Автор - KIMVSR
Дата добавления - 07.10.2017 в 15:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиске значения через INDEX + MATCH (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!