Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование части массива (комбинация) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование части массива (комбинация) (Формулы/Formulas)
Суммирование части массива (комбинация)
Спортсмен Дата: Суббота, 07.10.2017, 19:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Необходимо просуммировать часть массива чисел в столбце D, с соответствующими границами, заданными критериями дат.
Формула
Код
=СУММ(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4))

дает ошибку!
Раздельно все части формулы работают! Ошибку дает именно комбинация формул, а именно конкретно формула СУММ.
В чём проблема непонятно!
К сообщению приложен файл: 3146963.xlsx(9Kb)


Сообщение отредактировал Спортсмен - Суббота, 07.10.2017, 20:03
 
Ответить
СообщениеНеобходимо просуммировать часть массива чисел в столбце D, с соответствующими границами, заданными критериями дат.
Формула
Код
=СУММ(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4))

дает ошибку!
Раздельно все части формулы работают! Ошибку дает именно комбинация формул, а именно конкретно формула СУММ.
В чём проблема непонятно!

Автор - Спортсмен
Дата добавления - 07.10.2017 в 19:29
vikttur Дата: Суббота, 07.10.2017, 19:38 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

АДРЕС - это текст, не ссылка.
Используйте:
Код
=СУММ(ИНДЕКС(диапазон;ПОИСКПОЗ()):ссылка)

[offtop]Кстати: за 10 лет работы с Excel НИ РАЗУ не использвал АДРЕС(). За ненадобностью[/offtop]


Сообщение отредактировал vikttur - Суббота, 07.10.2017, 19:41
 
Ответить
СообщениеАДРЕС - это текст, не ссылка.
Используйте:
Код
=СУММ(ИНДЕКС(диапазон;ПОИСКПОЗ()):ссылка)

[offtop]Кстати: за 10 лет работы с Excel НИ РАЗУ не использвал АДРЕС(). За ненадобностью[/offtop]

Автор - vikttur
Дата добавления - 07.10.2017 в 19:38
Фомулист Дата: Понедельник, 09.10.2017, 15:11 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 189
Репутация: -12 ±
Замечаний: 60% ±

Excel 2003
Если именно Вашу формулу смотреть, то, думаю, вот так сработает:
Код
=СУММ(--(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4)))


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Понедельник, 09.10.2017, 15:14
 
Ответить
СообщениеЕсли именно Вашу формулу смотреть, то, думаю, вот так сработает:
Код
=СУММ(--(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4)))

Автор - Фомулист
Дата добавления - 09.10.2017 в 15:11
_Boroda_ Дата: Понедельник, 09.10.2017, 15:52 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Цитата Фомулист, 09.10.2017 в 15:11, в сообщении № 3 ()
думаю, вот так сработает:
=СУММ(--(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4)))

Фомулист, перед тем, как наложить "решение", нужно проверить его в файле. Не сработает так

Варианты -
Код
=СУММЕСЛИМН(C4:C16;C4:C16;">="&C19;C4:C16;"<="&C20)

Код
=СУММПРОИЗВ(C4:C16*(C4:C16>=C19)*(C4:C16<=C20))

Код
=СУММ(ИНДЕКС(C4:C16;ПОИСКПОЗ(C19;C4:C16;)):ИНДЕКС(C4:C16;ПОИСКПОЗ(C20;C4:C16;)))
К сообщению приложен файл: 3146963_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Цитата Фомулист, 09.10.2017 в 15:11, в сообщении № 3 ()
думаю, вот так сработает:
=СУММ(--(АДРЕС(ПОИСКПОЗ(C19;C4:C16;0 )+СТРОКА(C3);СТОЛБЕЦ(C4);4):АДРЕС(ПОИСКПОЗ(C20;C4:C16;0)+СТРОКА(C3);СТОЛБЕЦ(C4);4)))

Фомулист, перед тем, как наложить "решение", нужно проверить его в файле. Не сработает так

Варианты -
Код
=СУММЕСЛИМН(C4:C16;C4:C16;">="&C19;C4:C16;"<="&C20)

Код
=СУММПРОИЗВ(C4:C16*(C4:C16>=C19)*(C4:C16<=C20))

Код
=СУММ(ИНДЕКС(C4:C16;ПОИСКПОЗ(C19;C4:C16;)):ИНДЕКС(C4:C16;ПОИСКПОЗ(C20;C4:C16;)))

Автор - _Boroda_
Дата добавления - 09.10.2017 в 15:52
Che79 Дата: Понедельник, 09.10.2017, 15:52 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
Или я чего-то не понимаю в тяжелый понедельник или я чего-то, всё-таки, чего-то не понимаю :D . Но, если написано
Цитата Спортсмен, 07.10.2017 в 19:29, в сообщении № 1 ()
просуммировать часть массива чисел в столбце D
, то, может, так правильно?
Код
=СУММЕСЛИМН(D4:D16;C4:C16;">="&C19;C4:C16;"<="&C20)
См. желтую ячейку в файле
К сообщению приложен файл: 0499734.xlsx(9Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеИли я чего-то не понимаю в тяжелый понедельник или я чего-то, всё-таки, чего-то не понимаю :D . Но, если написано
Цитата Спортсмен, 07.10.2017 в 19:29, в сообщении № 1 ()
просуммировать часть массива чисел в столбце D
, то, может, так правильно?
Код
=СУММЕСЛИМН(D4:D16;C4:C16;">="&C19;C4:C16;"<="&C20)
См. желтую ячейку в файле

Автор - Che79
Дата добавления - 09.10.2017 в 15:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование части массива (комбинация) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!