Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет шкал с прямым и обратным порядком - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет шкал с прямым и обратным порядком (Формулы/Formulas)
Подсчет шкал с прямым и обратным порядком
Psy Дата: Вторник, 10.10.2017, 13:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 4 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые форумчане. Прошу помощи в написании формулы.

Дано:
Методика из 26 вопросов, по каждому из которых дают один ответ .выбирая из 5 вариантов (от совершенно не согласен до полностью согласен с промежуточными градациями)
Часть вопросов имеют прямую шкалу, то есть первый столбец имеет вес 1, второй - 2 ит д
Часть вопросов имеют обратную шкалу, то есть первый столбец имеет вес 5. второй - 4 ит д
При заполнении будет использоваться цифра 1, как маркер ответа.её человек будет ставить в нужную ячейку напротив каждого вопроса.

Нужно - превратить все единицы в верные значения в соответствии с условиями и просуммировать итог по всей таблице.

В приложении бланк с примером заполнения.

Заранее большое спасибо. Пыталась делать через функцию Если, но так и не разобралась, как правильно её использовать в моём случае.
К сообщению приложен файл: ___.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане. Прошу помощи в написании формулы.

Дано:
Методика из 26 вопросов, по каждому из которых дают один ответ .выбирая из 5 вариантов (от совершенно не согласен до полностью согласен с промежуточными градациями)
Часть вопросов имеют прямую шкалу, то есть первый столбец имеет вес 1, второй - 2 ит д
Часть вопросов имеют обратную шкалу, то есть первый столбец имеет вес 5. второй - 4 ит д
При заполнении будет использоваться цифра 1, как маркер ответа.её человек будет ставить в нужную ячейку напротив каждого вопроса.

Нужно - превратить все единицы в верные значения в соответствии с условиями и просуммировать итог по всей таблице.

В приложении бланк с примером заполнения.

Заранее большое спасибо. Пыталась делать через функцию Если, но так и не разобралась, как правильно её использовать в моём случае.

Автор - Psy
Дата добавления - 10.10.2017 в 13:13
_Boroda_ Дата: Вторник, 10.10.2017, 13:30 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11525
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(B2:F27*ABS(СТОЛБЕЦ(A2:E27)-6*ЕЧИСЛО(ПОИСК(" "&ЛЕВБ(A2:A27;ПОИСК(".";A2:A27)-1)&",";" "&L2&","))))
К сообщению приложен файл: -18-1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(B2:F27*ABS(СТОЛБЕЦ(A2:E27)-6*ЕЧИСЛО(ПОИСК(" "&ЛЕВБ(A2:A27;ПОИСК(".";A2:A27)-1)&",";" "&L2&","))))

Автор - _Boroda_
Дата добавления - 10.10.2017 в 13:30
Psy Дата: Вторник, 10.10.2017, 13:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 4 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Да-Да, спасибо огромное!!! Не буду обманывать, как вы это сделали, я не поняла, но главное, что все работает. Плюсик кажется поставился вам!)))Удачи вам в работе!!!!!
 
Ответить
Сообщение_Boroda_, Да-Да, спасибо огромное!!! Не буду обманывать, как вы это сделали, я не поняла, но главное, что все работает. Плюсик кажется поставился вам!)))Удачи вам в работе!!!!!

Автор - Psy
Дата добавления - 10.10.2017 в 13:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет шкал с прямым и обратным порядком (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!