Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Где в формуле с оператором И по содержанию текста в ячейках - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Где в формуле с оператором И по содержанию текста в ячейках (Формулы/Formulas)
Где в формуле с оператором И по содержанию текста в ячейках
SergeyNN Дата: Среда, 11.10.2017, 12:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите, пожалуйста, почему в столбце C формула всё время возвращает 1?

Смысл в том, что проверяю соблюдение двух условий-наличие в первом столбце *СГР* и во втором *БДИФ*. Совпадение этих двух условий в строке должно возвращать в столбец С единицу.

Не понимаю почему не работает. Подскажите, пожалуйста.
К сообщению приложен файл: 6487127.xlsx(10Kb)
 
Ответить
СообщениеПодскажите, пожалуйста, почему в столбце C формула всё время возвращает 1?

Смысл в том, что проверяю соблюдение двух условий-наличие в первом столбце *СГР* и во втором *БДИФ*. Совпадение этих двух условий в строке должно возвращать в столбец С единицу.

Не понимаю почему не работает. Подскажите, пожалуйста.

Автор - SergeyNN
Дата добавления - 11.10.2017 в 12:58
_Boroda_ Дата: Среда, 11.10.2017, 13:13 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Потому, что приравнивание звездочки не кушает
Можно вот так формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=--(СЧЁТ(ПОИСК({"СГР";"БДИФ"};A1:B1))=2)

Или вот так обычной формулой
Код
=--(СЧЁТ(ИНДЕКС(ПОИСК({"СГР";"БДИФ"};A1:B1);))=2)


===Добавлено
звезды в ПОИСКе не нужны. поправил
[offtop]Что ж я сегодня так торможу-то, а?
К сообщению приложен файл: 6487127_2.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПотому, что приравнивание звездочки не кушает
Можно вот так формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=--(СЧЁТ(ПОИСК({"СГР";"БДИФ"};A1:B1))=2)

Или вот так обычной формулой
Код
=--(СЧЁТ(ИНДЕКС(ПОИСК({"СГР";"БДИФ"};A1:B1);))=2)


===Добавлено
звезды в ПОИСКе не нужны. поправил
[offtop]Что ж я сегодня так торможу-то, а?

Автор - _Boroda_
Дата добавления - 11.10.2017 в 13:13
SergeyNN Дата: Среда, 11.10.2017, 13:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, спасибо огромное!)
 
Ответить
Сообщение_Boroda_, спасибо огромное!)

Автор - SergeyNN
Дата добавления - 11.10.2017 в 13:18
Che79 Дата: Среда, 11.10.2017, 13:20 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
вариант
Код
=--ЕСЛИОШИБКА((ПОИСК("СГР";A1)*ПОИСК("БДИФ";B1)>0);0)
К сообщению приложен файл: 6133927.xlsx(10Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениевариант
Код
=--ЕСЛИОШИБКА((ПОИСК("СГР";A1)*ПОИСК("БДИФ";B1)>0);0)

Автор - Che79
Дата добавления - 11.10.2017 в 13:20
SergeyNN Дата: Среда, 11.10.2017, 13:28 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо ещё раз!)
Да, так более понятно!)
 
Ответить
СообщениеСпасибо ещё раз!)
Да, так более понятно!)

Автор - SergeyNN
Дата добавления - 11.10.2017 в 13:28
китин Дата: Среда, 11.10.2017, 14:24 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4442
Репутация: 701 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или вариант с И
Код
=ЕСЛИ(И(A1="СГР"; ЕЧИСЛО(ПОИСК("БДИФ";B1)));1;"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили вариант с И
Код
=ЕСЛИ(И(A1="СГР"; ЕЧИСЛО(ПОИСК("БДИФ";B1)));1;"")

Автор - китин
Дата добавления - 11.10.2017 в 14:24
Che79 Дата: Среда, 11.10.2017, 18:43 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
Ну, тогда еще вариант. Хулиганский. Вдруг, там при сравнении значение имеют только единицы? Формула массива
Код
{=--И(ПОИСК({"СГР";"БДИФ"};A1:B1)>0)}
+ УФ: форматировать ячейки, содержащие ошибки - Формат: цвет шрифта белый
И еще УФ в самой таблице (зелёная заливка)
К сообщению приложен файл: 6195983.xlsx(11Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 11.10.2017, 18:43
 
Ответить
СообщениеНу, тогда еще вариант. Хулиганский. Вдруг, там при сравнении значение имеют только единицы? Формула массива
Код
{=--И(ПОИСК({"СГР";"БДИФ"};A1:B1)>0)}
+ УФ: форматировать ячейки, содержащие ошибки - Формат: цвет шрифта белый
И еще УФ в самой таблице (зелёная заливка)

Автор - Che79
Дата добавления - 11.10.2017 в 18:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Где в формуле с оператором И по содержанию текста в ячейках (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!