Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества уникальных значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений (Формулы/Formulas)
Подсчет количества уникальных значений
pirotehnik Дата: Среда, 11.10.2017, 23:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!

Коллеги, прошу оказать помощь в решении следующей задачи.

Имеется несколько магазинов с перечнем в них наименований товара.
Требуется вывести в отдельный столбец (ИТОГО) уникальное значение, которое наиболее часто встречается в каждом из магазинов.
В прикрепленном файле графу "Итого" я заполнил вручную. Но всё же хотелось данную процедуру решить с помощью формулы/формул.

Заранее всем большое спасибо!
К сообщению приложен файл: 8105930.xls(28Kb)
 
Ответить
СообщениеДобрый вечер!

Коллеги, прошу оказать помощь в решении следующей задачи.

Имеется несколько магазинов с перечнем в них наименований товара.
Требуется вывести в отдельный столбец (ИТОГО) уникальное значение, которое наиболее часто встречается в каждом из магазинов.
В прикрепленном файле графу "Итого" я заполнил вручную. Но всё же хотелось данную процедуру решить с помощью формулы/формул.

Заранее всем большое спасибо!

Автор - pirotehnik
Дата добавления - 11.10.2017 в 23:00
vikttur Дата: Среда, 11.10.2017, 23:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Апельсин/Банан - это такое оранжевое и длинное? :) Откуда такое взялось?
Почему нет Киви, Манго? Почему Апельсин 3 раза?
 
Ответить
СообщениеАпельсин/Банан - это такое оранжевое и длинное? :) Откуда такое взялось?
Почему нет Киви, Манго? Почему Апельсин 3 раза?

Автор - vikttur
Дата добавления - 11.10.2017 в 23:23
pirotehnik Дата: Среда, 11.10.2017, 23:29 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur, Апельсина как и банана оказалось равное количество, поэтому и вывел их вместе :D
в разных магазинах - разный ассортимент. Главная задача вывести в отдельный столбец наиболее часто встречающееся значение.
 
Ответить
Сообщениеvikttur, Апельсина как и банана оказалось равное количество, поэтому и вывел их вместе :D
в разных магазинах - разный ассортимент. Главная задача вывести в отдельный столбец наиболее часто встречающееся значение.

Автор - pirotehnik
Дата добавления - 11.10.2017 в 23:29
vikttur Дата: Среда, 11.10.2017, 23:37 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Наиболее часто это как? 4 магазина, Вы вывели 6 (7) подуктов... Почему не 4 или 8?
Давайте так: Вы опишете задачу правильно, чтобы не вызывать Вас в камеру допросов и тянуть из Вас информацию клещами.


Сообщение отредактировал vikttur - Среда, 11.10.2017, 23:39
 
Ответить
СообщениеНаиболее часто это как? 4 магазина, Вы вывели 6 (7) подуктов... Почему не 4 или 8?
Давайте так: Вы опишете задачу правильно, чтобы не вызывать Вас в камеру допросов и тянуть из Вас информацию клещами.

Автор - vikttur
Дата добавления - 11.10.2017 в 23:37
pirotehnik Дата: Среда, 11.10.2017, 23:46 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Упростил немного задачу.
Осталось всего два уникальных наименования. В крайнем столбце прокомментировал причину выбора итогового значения.
К сообщению приложен файл: 5268587.xls(28Kb)
 
Ответить
СообщениеУпростил немного задачу.
Осталось всего два уникальных наименования. В крайнем столбце прокомментировал причину выбора итогового значения.

Автор - pirotehnik
Дата добавления - 11.10.2017 в 23:46
vikttur Дата: Среда, 11.10.2017, 23:51 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Вот теперь понятно.
Формула массива:
Код
=ИНДЕКС(A2:D2;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(A2:D2;A2:D2));СЧЁТЕСЛИ(A2:D2;A2:D2);))
К сообщению приложен файл: 5659794.xls(29Kb)
 
Ответить
СообщениеВот теперь понятно.
Формула массива:
Код
=ИНДЕКС(A2:D2;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(A2:D2;A2:D2));СЧЁТЕСЛИ(A2:D2;A2:D2);))

Автор - vikttur
Дата добавления - 11.10.2017 в 23:51
pirotehnik Дата: Среда, 11.10.2017, 23:57 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur,
Огромное спасибо!!! hands
Формула массива прекрасно справилась с поставленной задачей!

Попутно появился ещё один вопрос. Если товаров в магазинах будет равное количество, тогда как быть?
К сообщению приложен файл: 6193893.xls(28Kb)


Сообщение отредактировал pirotehnik - Четверг, 12.10.2017, 00:07
 
Ответить
Сообщениеvikttur,
Огромное спасибо!!! hands
Формула массива прекрасно справилась с поставленной задачей!

Попутно появился ещё один вопрос. Если товаров в магазинах будет равное количество, тогда как быть?

Автор - pirotehnik
Дата добавления - 11.10.2017 в 23:57
Che79 Дата: Четверг, 12.10.2017, 05:09 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
Решил я развлечься и решить задачу по-другому :) . Через УФ. Чтобы цветом красилось только уникальное название товара в наибольшем количестве по всем магазинам (по строкам). Если таких товаров несколько, то красятся уникалы тех, которых равное количество. Все их дубликаты при этом не красятся (вот хотелось именно так, да и в глазах не так рябит). Добавил в файл количество магазинов и ассортимент товаров для наглядности. Вроде пашет так как нужно.
Формула в УФ
Код
=(СЧЁТЕСЛИ(A2:$T2;A2)=МАКС(СЧЁТЕСЛИ($A2:$T2;$A2:$T2)))*(A2<>0)

Но есть засада - формулу тестил на первой строке диапазона, а на весь диапазон перенеслось криво (подозреваю, что из-за баксов), поэтому сделал диапазоны построчно. Если найдутся желающие "допилить" этот момент - будет супер!
Справа в файле серым вывел проверку по количеству каждого товара, тоже залил УФ.
Может, и такой вариант кому пригодится.

Добавлено
[p.s.] Подозреваю, что третий СЧЁТЕСЛИ() там и не нужен, но сейчас уже проверять и править некогда. Делал всё ночью, параллельно с рабочим проектом. В любом случае, критика соратников по форуму категорически приветствуется!!
[p.s.]Формулу в УФ подкорректировал, файл перезалил
К сообщению приложен файл: 444555_2.xlsx(12Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Четверг, 12.10.2017, 11:39
 
Ответить
СообщениеРешил я развлечься и решить задачу по-другому :) . Через УФ. Чтобы цветом красилось только уникальное название товара в наибольшем количестве по всем магазинам (по строкам). Если таких товаров несколько, то красятся уникалы тех, которых равное количество. Все их дубликаты при этом не красятся (вот хотелось именно так, да и в глазах не так рябит). Добавил в файл количество магазинов и ассортимент товаров для наглядности. Вроде пашет так как нужно.
Формула в УФ
Код
=(СЧЁТЕСЛИ(A2:$T2;A2)=МАКС(СЧЁТЕСЛИ($A2:$T2;$A2:$T2)))*(A2<>0)

Но есть засада - формулу тестил на первой строке диапазона, а на весь диапазон перенеслось криво (подозреваю, что из-за баксов), поэтому сделал диапазоны построчно. Если найдутся желающие "допилить" этот момент - будет супер!
Справа в файле серым вывел проверку по количеству каждого товара, тоже залил УФ.
Может, и такой вариант кому пригодится.

Добавлено
[p.s.] Подозреваю, что третий СЧЁТЕСЛИ() там и не нужен, но сейчас уже проверять и править некогда. Делал всё ночью, параллельно с рабочим проектом. В любом случае, критика соратников по форуму категорически приветствуется!!
[p.s.]Формулу в УФ подкорректировал, файл перезалил

Автор - Che79
Дата добавления - 12.10.2017 в 05:09
vikttur Дата: Четверг, 12.10.2017, 09:34 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

на весь диапазон перенеслось криво (подозреваю, что из-за баксов)

Из-за них. Вы же строку закрепили.

Если товаров в магазинах будет равное количество, тогда как быть?

Если одинаковых 4? Формулой уже неоптимально, нужно макрос писать.
 
Ответить
Сообщение
на весь диапазон перенеслось криво (подозреваю, что из-за баксов)

Из-за них. Вы же строку закрепили.

Если товаров в магазинах будет равное количество, тогда как быть?

Если одинаковых 4? Формулой уже неоптимально, нужно макрос писать.

Автор - vikttur
Дата добавления - 12.10.2017 в 09:34
_Boroda_ Дата: Четверг, 12.10.2017, 10:17 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты формул. Не все из них одинаково считают. Например, в случае, когда каждого товара по одной штуке
Массивная
Код
=ИНДЕКС(A2:G2;МОДА(ЕСЛИОШИБКА(ПОИСКПОЗ(A2:G2;A2:G2;);"")))

Немассивная
Код
=ИНДЕКС(A2:D2;АГРЕГАТ(15;6;ПОИСКПОЗ(A2:D2;A2:D2;);1))


При нескольких одинаковых в одну ячейку да, полностью поддерживаю Виктора, гораздо проще макросом. А если в соседние ячейки, то так можно такой формулой массива
Код
=ИНДЕКС($A19:$G19;ИНДЕКС(МОДА.НСК(ЕСЛИОШИБКА(ПОИСКПОЗ($A19:$G19;$A19:$G19;);""));СТОЛБЕЦ(A19)))



В файле ошибки скрыты условным форматированием
К сообщению приложен файл: 5268587_1.xls(50Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты формул. Не все из них одинаково считают. Например, в случае, когда каждого товара по одной штуке
Массивная
Код
=ИНДЕКС(A2:G2;МОДА(ЕСЛИОШИБКА(ПОИСКПОЗ(A2:G2;A2:G2;);"")))

Немассивная
Код
=ИНДЕКС(A2:D2;АГРЕГАТ(15;6;ПОИСКПОЗ(A2:D2;A2:D2;);1))


При нескольких одинаковых в одну ячейку да, полностью поддерживаю Виктора, гораздо проще макросом. А если в соседние ячейки, то так можно такой формулой массива
Код
=ИНДЕКС($A19:$G19;ИНДЕКС(МОДА.НСК(ЕСЛИОШИБКА(ПОИСКПОЗ($A19:$G19;$A19:$G19;);""));СТОЛБЕЦ(A19)))



В файле ошибки скрыты условным форматированием

Автор - _Boroda_
Дата добавления - 12.10.2017 в 10:17
Che79 Дата: Четверг, 12.10.2017, 11:41 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
На трезвую голову :D внёс правки в свое сообщение выше, формулу в УФ сократил + теперь работает на весь диапазон. Корректный файл перезалил.


Делай нормально и будет нормально!
 
Ответить
СообщениеНа трезвую голову :D внёс правки в свое сообщение выше, формулу в УФ сократил + теперь работает на весь диапазон. Корректный файл перезалил.

Автор - Che79
Дата добавления - 12.10.2017 в 11:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!