Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод за ранее вбитого числа при соблюдении 3х условий. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод за ранее вбитого числа при соблюдении 3х условий. (Формулы/Formulas)
Вывод за ранее вбитого числа при соблюдении 3х условий.
Kubanoid Дата: Четверг, 12.10.2017, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Помогите решить задачу.
Мне нужно что бы при выборе из определенных чисел на выходе показывалось число с определенной ячейки.
То есть пример.
Есть 3 значения в разных ячейках

30, 5% и 7,5% . Так же есть результат 77,40%

Нужно что бы когда из выпадающего списка выбираешь 30, 5% и 5% , он выдавал мне число 77,40%
А если допустим 30, 10% и 12,5% он выдавал опять же заранее вбитые 16,10%

Логически задача вроде простая, но что-то с реализацией возникли проблемы
К сообщению приложен файл: 9403810.xlsx(12Kb)


Сообщение отредактировал Kubanoid - Четверг, 12.10.2017, 11:57
 
Ответить
СообщениеЗдравствуйте. Помогите решить задачу.
Мне нужно что бы при выборе из определенных чисел на выходе показывалось число с определенной ячейки.
То есть пример.
Есть 3 значения в разных ячейках

30, 5% и 7,5% . Так же есть результат 77,40%

Нужно что бы когда из выпадающего списка выбираешь 30, 5% и 5% , он выдавал мне число 77,40%
А если допустим 30, 10% и 12,5% он выдавал опять же заранее вбитые 16,10%

Логически задача вроде простая, но что-то с реализацией возникли проблемы

Автор - Kubanoid
Дата добавления - 12.10.2017 в 11:32
Kubanoid Дата: Понедельник, 16.10.2017, 22:34 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Так ни кто не чем помочь не может?
 
Ответить
СообщениеТак ни кто не чем помочь не может?

Автор - Kubanoid
Дата добавления - 16.10.2017 в 22:34
vikttur Дата: Понедельник, 16.10.2017, 22:46 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2468
Репутация: 430 ±
Замечаний: 0% ±

Помогу:
за ранее заранее
что бы чтобы
Так же Также
ни кто никто
не чем ни чем

Попутно:
Код
=ЕСЛИОШИБКА(ГПР(C13;$C$1:$K$9;МАКС(ЕСЛИ(A2:A9=A13;ЕСЛИ(B2:B9=B13;СТРОКА(B2:B9)))););"нет данных")

Формула массива, вводится тремя клавишами.
К сообщению приложен файл: 0918628.xlsx(12Kb)
 
Ответить
СообщениеПомогу:
за ранее заранее
что бы чтобы
Так же Также
ни кто никто
не чем ни чем

Попутно:
Код
=ЕСЛИОШИБКА(ГПР(C13;$C$1:$K$9;МАКС(ЕСЛИ(A2:A9=A13;ЕСЛИ(B2:B9=B13;СТРОКА(B2:B9)))););"нет данных")

Формула массива, вводится тремя клавишами.

Автор - vikttur
Дата добавления - 16.10.2017 в 22:46
Kubanoid Дата: Понедельник, 16.10.2017, 22:58 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Благодарю respect
 
Ответить
СообщениеБлагодарю respect

Автор - Kubanoid
Дата добавления - 16.10.2017 в 22:58
_Boroda_ Дата: Вторник, 17.10.2017, 11:57 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11525
Репутация: 4744 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(C2:J9*(C1:J1=C13)*(B2:B9=B13)*(A2:A9=A13))

Можно формат поставить
0,00%;;"--"
К сообщению приложен файл: 9403810-1-1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(C2:J9*(C1:J1=C13)*(B2:B9=B13)*(A2:A9=A13))

Можно формат поставить
0,00%;;"--"

Автор - _Boroda_
Дата добавления - 17.10.2017 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод за ранее вбитого числа при соблюдении 3х условий. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!