Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Общая формула для 4 математических операций - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Общая формула для 4 математических операций (Формулы/Formulas)
Общая формула для 4 математических операций
nikitan95 Дата: Воскресенье, 29.10.2017, 20:05 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 252
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброго всем вечера!
Интересная задачка. Имеем две ячейки и между ними через выпадающее меню выбирается одно из четырёх математических функций. Ниже написал формулу, но слишком длинная получилось. Есть варианты покороче?
К сообщению приложен файл: 4_..xlsx(10Kb)


Сообщение отредактировал nikitan95 - Воскресенье, 29.10.2017, 20:45
 
Ответить
СообщениеДоброго всем вечера!
Интересная задачка. Имеем две ячейки и между ними через выпадающее меню выбирается одно из четырёх математических функций. Ниже написал формулу, но слишком длинная получилось. Есть варианты покороче?

Автор - nikitan95
Дата добавления - 29.10.2017 в 20:05
ZORRO2005 Дата: Воскресенье, 29.10.2017, 20:18 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 147 ±
Замечаний: 0% ±

Excel2010
Покороче:
=Z
В списке имен:
Код
=ВЫЧИСЛИТЬ(Лист1!J10&Лист1!K10&Лист1!L10)
К сообщению приложен файл: 2017_10_29.xls(30Kb)


Сообщение отредактировал ZORRO2005 - Воскресенье, 29.10.2017, 20:19
 
Ответить
СообщениеПокороче:
=Z
В списке имен:
Код
=ВЫЧИСЛИТЬ(Лист1!J10&Лист1!K10&Лист1!L10)

Автор - ZORRO2005
Дата добавления - 29.10.2017 в 20:18
nikitan95 Дата: Воскресенье, 29.10.2017, 20:28 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 252
Репутация: 0 ±
Замечаний: 0% ±

2016
ZORRO2005, признаться мало чего понял, но работает). Спасибо. А обычными функциями можно добиться? Я ожидал через ПРОСМОТР, хотя сам так и не смог это реализовать...
 
Ответить
СообщениеZORRO2005, признаться мало чего понял, но работает). Спасибо. А обычными функциями можно добиться? Я ожидал через ПРОСМОТР, хотя сам так и не смог это реализовать...

Автор - nikitan95
Дата добавления - 29.10.2017 в 20:28
Pelena Дата: Воскресенье, 29.10.2017, 20:40 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
nikitan95, дайте теме более конкретное название в соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеnikitan95, дайте теме более конкретное название в соответствии с Правилами форума

Автор - Pelena
Дата добавления - 29.10.2017 в 20:40
nikitan95 Дата: Воскресенье, 29.10.2017, 20:49 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 252
Репутация: 0 ±
Замечаний: 0% ±

2016
Pelena, исправил. Но не думаю, чтобы я сильно нарушал Правила. Ведь основной проблемой была слишком длиннная формула. И название темы соответствовала содержанию
 
Ответить
СообщениеPelena, исправил. Но не думаю, чтобы я сильно нарушал Правила. Ведь основной проблемой была слишком длиннная формула. И название темы соответствовала содержанию

Автор - nikitan95
Дата добавления - 29.10.2017 в 20:49
Nic70y Дата: Воскресенье, 29.10.2017, 21:33 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
слишком длиннная формула
так многие спрашивают - соот. тем с таким названием было бы дофига.
а это надо?
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСК(ПРАВБ("ю"&C3);" /+-ю");B3*D3;B3/D3;B3+D3;B3-D3;"Т");"Деление на ноль")
а эта формула не сокращение,
а совершенно другая...


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
слишком длиннная формула
так многие спрашивают - соот. тем с таким названием было бы дофига.
а это надо?
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСК(ПРАВБ("ю"&C3);" /+-ю");B3*D3;B3/D3;B3+D3;B3-D3;"Т");"Деление на ноль")
а эта формула не сокращение,
а совершенно другая...

Автор - Nic70y
Дата добавления - 29.10.2017 в 21:33
Pelena Дата: Воскресенье, 29.10.2017, 21:35 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
не думаю
суть задачи: выполнить действие, соответствующее выбранному знаку, а не "Упростить формулу"

Варианты
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ("~"&C3;{"+";"-";"*";"/"};0);B3+D3;B3-D3;B3*D3;ЕСЛИОШИБКА(B3/D3;"Деление на ноль"));"не определено")

для Excel 2016
Код
=ПЕРЕКЛЮЧ(C3;"+";B3+D3;"-";B3-D3;"*";B3*D3;"/";ЕСЛИ(D3=0;"деление на 0";B3/D3);"не определено")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
не думаю
суть задачи: выполнить действие, соответствующее выбранному знаку, а не "Упростить формулу"

Варианты
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ("~"&C3;{"+";"-";"*";"/"};0);B3+D3;B3-D3;B3*D3;ЕСЛИОШИБКА(B3/D3;"Деление на ноль"));"не определено")

для Excel 2016
Код
=ПЕРЕКЛЮЧ(C3;"+";B3+D3;"-";B3-D3;"*";B3*D3;"/";ЕСЛИ(D3=0;"деление на 0";B3/D3);"не определено")

Автор - Pelena
Дата добавления - 29.10.2017 в 21:35
nikitan95 Дата: Понедельник, 30.10.2017, 08:40 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 252
Репутация: 0 ±
Замечаний: 0% ±

2016
Pelena, критику принимаю. Учту. Отдельное спасибо за формулы. Не думал, что так сложно обычными функциями. Остановлюсь на макрофункциях.
 
Ответить
СообщениеPelena, критику принимаю. Учту. Отдельное спасибо за формулы. Не думал, что так сложно обычными функциями. Остановлюсь на макрофункциях.

Автор - nikitan95
Дата добавления - 30.10.2017 в 08:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Общая формула для 4 математических операций (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!