Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Результат в зависимости от выбора значений из списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Результат в зависимости от выбора значений из списка (Формулы/Formulas)
Результат в зависимости от выбора значений из списка
stoniq Дата: Понедельник, 30.10.2017, 16:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем привет!
Нужна помощь с формулой. В столбце B, C и D имеется выбор вариантов из выпадающего списка. В столбце E результат. В случае выбора Вариант 1, Вариант 10 и Вариант 100 должно выдавать "ОК", в случае выбора Вариант 2, Вариант 20 и Вариант 200 должно выдавать "ОК", в случае выбора Вариант 3, Вариант 30 и Вариант 300 должно выдавать "ОК". Во всех остальных случаях "ОШИБКА". Если любое из полей пустое, то тоже "ОШИБКА".
К сообщению приложен файл: testtest.xlsx(9Kb)
 
Ответить
СообщениеВсем привет!
Нужна помощь с формулой. В столбце B, C и D имеется выбор вариантов из выпадающего списка. В столбце E результат. В случае выбора Вариант 1, Вариант 10 и Вариант 100 должно выдавать "ОК", в случае выбора Вариант 2, Вариант 20 и Вариант 200 должно выдавать "ОК", в случае выбора Вариант 3, Вариант 30 и Вариант 300 должно выдавать "ОК". Во всех остальных случаях "ОШИБКА". Если любое из полей пустое, то тоже "ОШИБКА".

Автор - stoniq
Дата добавления - 30.10.2017 в 16:13
sboy Дата: Понедельник, 30.10.2017, 16:45 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1103
Репутация: 276 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(СУММ(--ПОДСТАВИТЬ(B2:D2;"Вариант ";""));{111;222;333};);"ОШИБКА")

и в УФ с зеленой заливкой и форматом Ок
Код
=ЕЧИСЛО(F2)
К сообщению приложен файл: 0053876.xlsx(9Kb)
 
Ответить
СообщениеДобрый день.
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(СУММ(--ПОДСТАВИТЬ(B2:D2;"Вариант ";""));{111;222;333};);"ОШИБКА")

и в УФ с зеленой заливкой и форматом Ок
Код
=ЕЧИСЛО(F2)

Автор - sboy
Дата добавления - 30.10.2017 в 16:45
stoniq Дата: Понедельник, 30.10.2017, 16:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
[moder]Излишнее цитирование удалено[/moder]
Спасибо добрый человек!


Сообщение отредактировал Pelena - Понедельник, 30.10.2017, 17:20
 
Ответить
Сообщение[moder]Излишнее цитирование удалено[/moder]
Спасибо добрый человек!

Автор - stoniq
Дата добавления - 30.10.2017 в 16:54
Che79 Дата: Понедельник, 30.10.2017, 17:44 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 597
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
Вариант вне конкурса.
Поскольку, у ТС в каждом из столбцов выпадающий список с жесткими условиями, то, наверное, можно короче
Код
{=--(И(ПСТР(B2:C2;9;1)=ПСТР(C2:D2;9;1)))}
и формат ячеек "ОК";;"ОШИБКА"
К сообщению приложен файл: testtest_1.xlsx(10Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 30.10.2017, 19:46
 
Ответить
СообщениеВариант вне конкурса.
Поскольку, у ТС в каждом из столбцов выпадающий список с жесткими условиями, то, наверное, можно короче
Код
{=--(И(ПСТР(B2:C2;9;1)=ПСТР(C2:D2;9;1)))}
и формат ячеек "ОК";;"ОШИБКА"

Автор - Che79
Дата добавления - 30.10.2017 в 17:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Результат в зависимости от выбора значений из списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!